# Kibana (code=exited, status=78)

**URL:** <https://discuss.elastic.co/t/kibana-code-exited-status-78/319819>\
**Category:** Kibana\
**Created:** [November 25, 2022, 12:42pm UTC](https://discuss.elastic.co/t/kibana-code-exited-status-78/319819 "2022-11-25T12:42:10Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![barnabe](https://avatars.discourse-cdn.com/v4/letter/b/71c47a/32.png) [@barnabe](https://discuss.elastic.co/u/barnabe)\
**Post date:** [November 25, 2022, 12:45pm UTC](https://discuss.elastic.co/t/kibana-code-exited-status-78/319819/4 "2022-11-25T12:45:26Z")

</div>

I tried to solve the issue  
by allocating more memory for the jvm on both elasticsearch and kibana

for elasticsearch

```auto
/etc/elasticsearch/jvm.options

```

```auto
################################################################
##
## JVM configuration
##
################################################################
##
## WARNING: DO NOT EDIT THIS FILE. If you want to override the
## JVM options in this file, or set any additional options, you
## should create one or more files in the jvm.options.d
## directory containing your adjustments.
##
## See https://www.elastic.co/guide/en/elasticsearch/reference/8.5/jvm-options.html
## for more information.
##
################################################################

################################################################
## IMPORTANT: JVM heap size
################################################################
##
## The heap size is automatically configured by Elasticsearch
## based on the available memory in your system and the roles
## each node is configured to fulfill. If specifying heap is
## required, it should be done through a file in jvm.options.d,
## which should be named with .options suffix, and the min and
## max should be set to the same value. For example, to set the
## heap to 4 GB, create a new file in the jvm.options.d
## directory containing these lines:
##
-Xms4g
-Xmx4g
##
## See https://www.elastic.co/guide/en/elasticsearch/reference/8.5/heap-size.html
## for more information
##
################################################################

################################################################
## Expert settings
################################################################
##
## All settings below here are considered expert settings. Do
## not adjust them unless you understand what you are doing. Do
## not edit them in this file; instead, create a new file in the
## jvm.options.d directory containing your adjustments.
##
################################################################

-XX:+UseG1GC

## JVM temporary directory
-Djava.io.tmpdir=${ES_TMPDIR}

## heap dumps

# generate a heap dump when an allocation from the Java heap fails; heap dumps
# are created in the working directory of the JVM unless an alternative path is
# specified
-XX:+HeapDumpOnOutOfMemoryError

# exit right after heap dump on out of memory error
-XX:+ExitOnOutOfMemoryError

# specify an alternative path for heap dumps; ensure the directory exists and
# has sufficient space
-XX:HeapDumpPath=/var/lib/elasticsearch

# specify an alternative path for JVM fatal error logs
-XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log

## GC logging
-Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m

```

and kibana

```auto
/etc/kibana/node.options

```

```auto
## Node command line options
## See `node --help` and `node --v8-options` for available options
## Please note you should specify one option per line

## max size of old space in megabytes
--max-old-space-size=4096

## do not terminate process on unhandled promise rejection
 --unhandled-rejections=warn

```

I also saw this solved problem for a similar issue IE status=78

> [@Kibana service fails to start](https://discuss.elastic.co/t/kibana-service-fails-to-start/228766):
>
> I have installed Kibana as shown [here](https://www.elastic.co/guide/en/kibana/7.6/rpm.html#rpm-repo). Installation was successful and so I began to configure it as shown [here](https://www.howtoforge.com/tutorial/how-to-install-elastic-stack-on-centos-7/) by setting the following... server.port: 5601 server.host: "localhost" elasticsearch.hosts: ["http://localhost:9200"] I did not use the key elasticsearch.url because it has been deprecated. Upon this I have also turned on logging as such... logging.dest: "/home/syost/kibanalog.txt" logging.silent: false logging.quiet: false logging.verbose: true After this I have started the servic…

and so I followed what was told and created a new separated log file, but it did not work so i reverted back to the original log file.

I am quite lost I hope the community will be able to provide guidance.  
Kind regards and thanks in advance ^^.

---

_[View the full topic](https://discuss.elastic.co/t/kibana-code-exited-status-78/319819)._
