# Kibana connection failed (even with http.cors.allow-origin in elasticsearch.ym)

**URL:** https://discuss.elastic.co/t/kibana-connection-failed-even-with-http-cors-allow-origin-in-elasticsearch-ym/21085
**Category:** Elasticsearch
**Created:** [December 4, 2014, 3:17pm UTC](https://discuss.elastic.co/t/kibana-connection-failed-even-with-http-cors-allow-origin-in-elasticsearch-ym/21085 "2014-12-04T15:17:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Dan\_Langille](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dan_langille/32/786_2.png) [@Dan\_Langille](https://discuss.elastic.co/u/Dan_Langille)
#### Post date: [December 4, 2014, 3:17pm UTC](https://discuss.elastic.co/t/kibana-connection-failed-even-with-http-cors-allow-origin-in-elasticsearch-ym/21085/1 "2014-12-04T15:17:09Z")

</div>

I'm running:

elasticsearch-1.4.0\_1  
logstash-1.4.2\_1  
kibana-3.1.1  
on FreeBSD 9.3

On initial setup, the prebuilt dashboard: (Logstash Dashboard) at  
/index.html#/dashboard/file/logstash.json worked

I added more panels from github. The Logstash Dashboard still worked.  
Then it didn't.

screen shot: [http://img.ly/images/8746523/full](http://img.ly/images/8746523/full)

I have confirmed elasticsearch is running by browsing to port 9200 and  
checking with ps. Yes, it's running.

Next I tried changes to configuration:

$ sudo grep cors /usr/local/etc/elasticsearch/elasticsearch.yml  
http.cors.allow-origin: "/.\*/"  
http.cors.enabled: true

I also tried the FQDN of the host, but the results were the same.

No errors are seen in /var/log/elasticsearch/elasticsearch.log when the  
above message is produced.

Google searching led me to the above suggestions. Now I'm at a loss as to  
what to try next.

Suggestions please?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/902f8df3-c5ae-442c-b83e-4a7a649c2f41%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/902f8df3-c5ae-442c-b83e-4a7a649c2f41%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Dan\_Langille](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dan_langille/32/786_2.png) [@Dan\_Langille](https://discuss.elastic.co/u/Dan_Langille)
#### Post date: [December 4, 2014, 4:27pm UTC](https://discuss.elastic.co/t/kibana-connection-failed-even-with-http-cors-allow-origin-in-elasticsearch-ym/21085/2 "2014-12-04T16:27:10Z")

</div>

SOLVED.

Not sure how, but while messing around with the nginx.conf files, it  
started working. Sorry I do not have more information which points  
directly to the solution.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/adda21ef-cda3-4b11-a772-0b2c8b1f803a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/adda21ef-cda3-4b11-a772-0b2c8b1f803a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:45am UTC](https://discuss.elastic.co/t/kibana-connection-failed-even-with-http-cors-allow-origin-in-elasticsearch-ym/21085/3 "2017-07-06T00:45:54Z")

</div>


