# Kibana connection refused

**URL:** <https://discuss.elastic.co/t/kibana-connection-refused/183135>\
**Category:** Kibana\
**Created:** [May 28, 2019, 3:24pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135 "2019-05-28T15:24:55Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![George\_Smiley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/george_smiley/32/46325_2.png) [@George\_Smiley](https://discuss.elastic.co/u/George_Smiley)\
**Post date:** [May 28, 2019, 3:24pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135/1 "2019-05-28T15:24:56Z")

</div>

Hi everyone,

Can anyone help me with my kibana connection refused?

My kibana is running. When I try curl -X GET [http://localhost:5601](http://localhost:5601), it gave me error: curl: (7) Failed connect to localhost:5601; Connection refused

curl -X GET [http://localhost:9200](http://localhost:9200) is working fine:

{  
"name" : "aVMqaa2",  
"cluster\_name" : "elasticsearch",  
"cluster\_uuid" : "nz6JYM3CTdOWII2EzTrz4A",  
"version" : {  
"number" : "6.8.0",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "65b6179",  
"build\_date" : "2019-05-15T20:06:13.172855Z",  
"build\_snapshot" : false,  
"lucene\_version" : "7.7.0",  
"minimum\_wire\_compatibility\_version" : "5.6.0",  
"minimum\_index\_compatibility\_version" : "5.0.0"  
},  
"tagline" : "You Know, for Search"  
}

I checked the kibana log file there isn't any error message.

Version of logstash, elasticsearch, kibana  
logstash 6.8.0, elasticsearch 6.8.0, kibana 6.8.0.

I am running this server on a Centos 7-6.1810

Thank you very much if anyone can help!

---

<div class="post-metadata">

**Author:** ![Gidi\_Kalef](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gidi_kalef/32/43651_2.png) [@Gidi\_Kalef](https://discuss.elastic.co/u/Gidi_Kalef)\
**Post date:** [May 28, 2019, 3:49pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135/2 "2019-05-28T15:49:34Z")

</div>

Hi,  
Can you please show kibana.yml configuration?

---

<div class="post-metadata">

**Author:** ![George\_Smiley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/george_smiley/32/46325_2.png) [@George\_Smiley](https://discuss.elastic.co/u/George_Smiley)\
**Post date:** [May 28, 2019, 4:13pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135/3 "2019-05-28T16:13:48Z")

</div>

# Kibana is served by a back end server. This setting specifies the port to use.

#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

# The default is 'localhost', which usually means remote machines will not be able to connect.

# To allow connections from remote users, set this parameter to a non-loopback address.

server.host: "192.168.32.17"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.

# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath

# from requests it receives, and to prevent a deprecation warning at startup.

# This setting cannot end in a slash.

#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with

# `server.basePath` or require that they are rewritten by your reverse proxy.

# This setting was effectively always `false` before Kibana 6.3 and will

# default to `true` starting in Kibana 7.0.

#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.

#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]

Here is the part that I edited.

---

<div class="post-metadata">

**Author:** ![George\_Smiley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/george_smiley/32/46325_2.png) [@George\_Smiley](https://discuss.elastic.co/u/George_Smiley)\
**Post date:** [May 28, 2019, 4:15pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135/4 "2019-05-28T16:15:47Z")

</div>

Also, I double check the log file: there some error about elasticsearch:  
{"type":"log","@timestamp":"2019-05-27T23:09:12Z","tags":["warning","elasticsearch","admin"],"pid":26382,"message":"Unable to revive connection: [http://192.168.32.17:9200/](http://192.168.32.17:9200/)"}  
{"type":"log","@timestamp":"2019-05-27T23:09:12Z","tags":["warning","elasticsearch","admin"],"pid":26382,"message":"No living connections"}

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 25, 2019, 4:15pm UTC](https://discuss.elastic.co/t/kibana-connection-refused/183135/5 "2019-06-25T16:15:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
