# Kibana could not perform access check to Enterprise Search

**URL:** <https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708>\
**Category:** Elastic Search\
**Tags:** elastic-app-search\
**Created:** [December 21, 2022, 1:16am UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708 "2022-12-21T01:16:18Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![tavaradhan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tavaradhan/32/102983_2.png) [@tavaradhan](https://discuss.elastic.co/u/tavaradhan)\
**Post date:** [December 21, 2022, 1:16am UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708/1 "2022-12-21T01:16:18Z")

</div>

hi,  
I am setting up a self-managed setup (Elasticsearch, Kibana, Enterprise search) for a simple search application. Everything works fine with http. Once I enable ssl on enterprisesearch and on kibana, I get "Unable to connect", and the specific log message from kibana log is

```auto
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.4.0"},"@timestamp":"2022-12-21T01:06:56.172+00:00","message":"Could not perform access check to Enterprise Search: TypeError[ERR_INVALID_PROTOCOL]: Protocol \"https:\" not supported. Expected "http:"","log":{"level":"ERROR","logger":"plugins.enterpriseSearch"},"process":{"pid":215374},"trace":{"id":"7eebab3699db9dd62fe5fbdc14f637ce"},"transaction":{"id":"07f3ef1e7bcdefaf"}}

```

I looked up at common errors page and it does not have any solution for this log message..any pointers? looks like i am doing some simple mistake somewhere, but unable to fix.

thanks for the help

@Carlos_D - tagging you as I saw you had responded with solutions for a similar query sometime back.

varadhan

---

<div class="post-metadata">

**Author:** ![Serena\_Chou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/serena_chou/32/100087_2.png) [@Serena\_Chou](https://discuss.elastic.co/u/Serena_Chou)\
**Post date:** [January 9, 2023, 8:07pm UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708/2 "2023-01-09T20:07:10Z")

</div>

Hey there, did you also enable ssl for Elasticsearch as well? [Set up basic security for the Elastic Stack plus secured HTTPS traffic | Elasticsearch Guide [8.5] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-basic-setup-https.html)

---

<div class="post-metadata">

**Author:** ![tavaradhan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tavaradhan/32/102983_2.png) [@tavaradhan](https://discuss.elastic.co/u/tavaradhan)\
**Post date:** [January 14, 2023, 4:21am UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708/3 "2023-01-14T04:21:36Z")

</div>

yes.

---

<div class="post-metadata">

**Author:** ![Serena\_Chou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/serena_chou/32/100087_2.png) [@Serena\_Chou](https://discuss.elastic.co/u/Serena_Chou)\
**Post date:** [January 17, 2023, 9:18pm UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708/4 "2023-01-17T21:18:02Z")

</div>

What do you see in the Enterprise Search logs as well as the Kibana logs?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 14, 2023, 9:18pm UTC](https://discuss.elastic.co/t/kibana-could-not-perform-access-check-to-enterprise-search/321708/5 "2023-02-14T21:18:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
