# Kibana csv reporting error randomly

**URL:** <https://discuss.elastic.co/t/kibana-csv-reporting-error-randomly/318609>\
**Category:** Kibana\
**Created:** [November 10, 2022, 4:51am UTC](https://discuss.elastic.co/t/kibana-csv-reporting-error-randomly/318609 "2022-11-10T04:51:16Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sbyunnn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sbyunnn/32/107387_2.png) [@sbyunnn](https://discuss.elastic.co/u/sbyunnn)\
**Post date:** [November 10, 2022, 4:51am UTC](https://discuss.elastic.co/t/kibana-csv-reporting-error-randomly/318609/1 "2022-11-10T04:51:16Z")

</div>

my kibana error randomly when reporting a csv file.

error:

> Unable to generate report
> 
> Error: Failed to decrypt report job data. Please ensure that xpack.reporting.encryptionKey is set and re-generate this report. Error: Unsupported state or unable to authenticate data

I have 3 kibana instances, 1 Elasticsearch cluster, version is 7.10.0  
kibana is on each of the 3 k8s clusters.

I did :

- kibana.yml ( This is k8s deployment file, Deployed to all three clusters. )

```auto
          env:
            - name: xpack.reporting.encryptionKey
              value: "Xx5ZcRsOIu5PkSoxZU9abnAVN3uc667T"
            - name: xpack.reporting.csv.maxSizeBytes
              value: "200mb"
            - name: xpack.reporting.queue.timeout
              value: "5m"

```

- elasticsearch.yml

```auto
http.max_content_length: "200mb"

```

but

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/5/752905eea14389c1f33f1215a5a76d51d9300e2a.png)

how can I solve this problem ?

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [November 10, 2022, 1:34pm UTC](https://discuss.elastic.co/t/kibana-csv-reporting-error-randomly/318609/2 "2022-11-10T13:34:34Z")

</div>

Hi @sbyunnn. I believe your environment variables are being ignored because they need to be uppercase. [See this comment for more info](https://discuss.elastic.co/t/randomly-getting-error-failed-to-decrypt-report-job-data-with-kibana/179135/9).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2022, 1:34pm UTC](https://discuss.elastic.co/t/kibana-csv-reporting-error-randomly/318609/3 "2022-12-08T13:34:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
