# Kibana Dashboard Error – Set fielddata=true on fieldname

**URL:** https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812
**Category:** Kibana
**Created:** [April 19, 2017, 3:39am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812 "2017-04-19T03:39:03Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 19, 2017, 3:39am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/1 "2017-04-19T03:39:03Z")

</div>

I am getting performance data using metricbeat and I am trying to produce Dashboards in kibana.

Im using ELK stack version 5.3 and once i imported the metricbeat dashboards, im getting below error.

9Courier Fetch: 10 of 15 shards failed.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/6/a/6a4ae16728646cf38dafe006aeae38ddf504788f.png)

please help.

---

<div class="post-metadata">

### Author: ![cjcenizal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cjcenizal/32/11216_2.png) [@cjcenizal](https://discuss.elastic.co/u/cjcenizal)
#### Post date: [April 19, 2017, 4:26pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/2 "2017-04-19T16:26:57Z")

</div>

Hi there,

Wow, this is odd. Can you help me get more information on this problem?

1. What happens if you click on a visualization? Does it load? If it gives an error, what is the error?
2. Could you inspect your network response and let me know what it contains? The courier error in your screenshot originates in Elasticsearch, so maybe we can get more information by checking out the raw network response.

Thanks,  
CJ

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 20, 2017, 6:53am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/3 "2017-04-20T06:53:09Z")

</div>

Hello,

Yes, this error seems to be unique for me which im facing for the first time when i installed ELk stack 5.3 version.

And to your question,

1. Yes, when i click on any visualization, it will load but since then i get an error message as 2  
Courier Fetch: 10 of 20 shards failed. on top of the header in Kibana only when i click on metricbeat dashboard.

2. Please find the elasticsearch logs whereas at point of the error below.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 20, 2017, 7:15am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/4 "2017-04-20T07:15:31Z")

</div>

```
org.elasticsearch.transport.RemoteTransportException: [bngwidap108.aonnet.aon.net][10.209.68.107:9300][indices:data/read/search[phase/query]]
    Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory.
    	at org.elasticsearch.index.mapper.TextFieldMapper$TextFieldType.fielddataBuilder(TextFieldMapper.java:336) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.index.fielddata.IndexFieldDataService.getForField(IndexFieldDataService.java:111) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.index.query.QueryShardContext.getForField(QueryShardContext.java:166) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.support.ValuesSourceConfig.resolve(ValuesSourceConfig.java:97) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.support.ValuesSourceAggregationBuilder.resolveConfig(ValuesSourceAggregationBuilder.java:297) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.support.ValuesSourceAggregationBuilder.doBuild(ValuesSourceAggregationBuilder.java:290) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.support.ValuesSourceAggregationBuilder.doBuild(ValuesSourceAggregationBuilder.java:39) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.AbstractAggregationBuilder.build(AbstractAggregationBuilder.java:126) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.aggregations.AggregatorFactories$Builder.build(AggregatorFactories.java:333) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.SearchService.parseSource(SearchService.java:637) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.SearchService.createContext(SearchService.java:468) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.SearchService.createAndPutContext(SearchService.java:444) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:252) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.action.search.SearchTransportService$6.messageReceived(SearchTransportService.java:331) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.action.search.SearchTransportService$6.messageReceived(SearchTransportService.java:328) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.transport.RequestHandlerRegistry.processMessageReceived(RequestHandlerRegistry.java:69) ~[elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.transport.TransportService$7.doRun(TransportService.java:618) [elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:613) [elasticsearch-5.3.0.jar:5.3.0]
    	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-5.3.0.jar:5.3.0]
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_101]
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_101]
    	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
```

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 20, 2017, 7:15am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/5 "2017-04-20T07:15:42Z")

</div>

Also please find the network responses below in the server.

```
h:\>ping 10.209.68.107 -n 5

Pinging 10.209.68.107 with 32 bytes of data:
Reply from 10.209.68.107: bytes=32 time<1ms TTL=128
Reply from 10.209.68.107: bytes=32 time<1ms TTL=128
Reply from 10.209.68.107: bytes=32 time<1ms TTL=128
Reply from 10.209.68.107: bytes=32 time<1ms TTL=128
Reply from 10.209.68.107: bytes=32 time<1ms TTL=128

Ping statistics for 10.209.68.107:
    Packets: Sent = 20, Received = 20, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

h:\>tracert 10.209.68.107

Tracing route to BNGWIDAP108.aonnet.aon.net [10.209.68.107]
over a maximum of 30 hops:

  1 <1 ms <1 ms <1 ms BNGWIDAP108.aonnet.aon.net [10.209.68.107]

Trace complete.
```

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [April 20, 2017, 7:17pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/6 "2017-04-20T19:17:17Z")

</div>

> [@Sujith](#):
>
> Fielddata is disabled on text fields by default

Interesting. I've seen this error before with beats and dashboard imports, though usually you see a red error showing that message, not a yellow error bar with the `courier fetch` failure.

Anyhow, `beat.name` should be a keyword but it looks like it's not.

Can you go into management and show what it says for `beat.name`?

 ![](https://us1.discourse-cdn.com/elastic/original/3X/4/b/4bd770a6d02c29042b658b68c615f872f1c21a76.png)

I'm not sure how the field was set incorrectly. Are you using the same version of metricbeat as kibana and elasticsearch? Did you have metricbeat running, or dashboards imported, prior to upgrading to 5.3?

If you drill in to a time range that is more recent, do you still get the error? Sometimes you'll have data in old indexes with an invalid mapping, but data in more recent indexes (e.g. after you upgraded) in a newer format.

You should be able to set `fielddata=true` on that field to get it working by following this: [fielddata mapping parameter | Elasticsearch Guide [8.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html)

Though if there are multiple fields that are set wrong, you may want to wipe your metricbeat index and start over to see if that helps (but only if there isn't data in it you want to preserve).

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 25, 2017, 5:44am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/7 "2017-04-25T05:44:56Z")

</div>

Hi Stacey,

Sorry for the late reply.

Yes its strange how fielddata is disabled for me, where as while i was using ELk stack 5.2 version i dint faced any issue and then now after using ELK 5.3 version, i can see fielddats disabled for me.

and also first time im facing courier fetch failure error.

Please help me how do i amke beat.name = keyword.  
please find below image for management showing for beat.name

 ![](https://us1.discourse-cdn.com/elastic/original/3X/8/b/8bd47688ec0cdef2f51ca177d55c7df2c04185f4.png)

Yes, im using the same version of metricbeat as kibana and elasticsearch (ELK 5.3 including beats) and 5.3 dashboards imported, prior to upgrading to 5.3 also.

This issue seems to coming intermediate where 1 days it dint appeared after all now i can see continuously error appearing in recent days.

Please help in making fielddata=true where as i couldnt able to understand from below link.  
[https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html)

I can also see in my metricbeat.template.json file where fileddata for beat,name is keyword = true.

"beat": {  
"properties": {  
"hostname": {  
"ignore\_above": 1024,  
"type": "keyword"  
},  
"name": {  
"ignore\_above": 1024,  
"type": "keyword"  
},  
"version": {  
"ignore\_above": 1024,  
"type": "keyword"  
}  
}

correct me if im wrong.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 27, 2017, 6:34am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/9 "2017-04-27T06:34:21Z")

</div>

Hi Team,

Can anyone let us know how to resolve this issue please.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [April 28, 2017, 7:03am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/10 "2017-04-28T07:03:55Z")

</div>

Hi Team,

Does anyone reply back to us, We are stuck up in middle of ELK environment awaiting for your response. please give us some solution.

Thanks

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [May 1, 2017, 3:07pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/11 "2017-05-01T15:07:52Z")

</div>

Can you post the output of

```auto
GET metricbeat*/_mapping/metricsets/field/beat.name

```

The screenshot you shared shows the right data, so I'm not sure why [beat.name](http://beat.name) is throwing that error.

If you go back to the dashboard and shorten the time range, so it's something like `Last 15 minutes`, do you continue to see the error?

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 2, 2017, 4:17am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/12 "2017-05-02T04:17:47Z")

</div>

Hi Stacey,

Thanks for getting back to us.

Yes for the input  
GET metricbeat\*/\_mapping/metricsets/field/beat.name

Please find the below output

```
{
  "metricbeat-2017.04.24": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.23": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.26": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.05.02": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.25": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.28": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.17": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "text",
              "fields": {
                "keyword": {
                  "type": "keyword",
                  "ignore_above": 256
                }
              }
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.27": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.19": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.18": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "text",
              "fields": {
                "keyword": {
                  "type": "keyword",
                  "ignore_above": 256
                }
              }
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.29": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.20": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.30": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.05.01": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.22": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  },
  "metricbeat-2017.04.21": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "keyword",
              "ignore_above": 1024
            }
          }
        }
      }
    }
  }
}

```

And also If i go back to the dashboard and shorten the time range as of 15 minutes, its strange that no error is displayed now.

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [May 2, 2017, 1:47pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/13 "2017-05-02T13:47:31Z")

</div>

So the issue is that some of your indexes have the wrong format for [beat.name](http://beat.name). Specifically, the ones prior to 2017.04.18. You can see they look like this:

```auto
  "metricbeat-2017.04.17": {
    "mappings": {
      "metricsets": {
        "beat.name": {
          "full_name": "beat.name",
          "mapping": {
            "name": {
              "type": "text",
              "fields": {
                "keyword": {
                  "type": "keyword",
                  "ignore_above": 256
                }
              }
            }
          }
        }
      }
    }
  }

```

You can try to updating the mapping for these indexes specifically by running this command:

```auto
PUT metricbeat-2017.04.18/_mapping/metricsets
{
  "properties": {
    "beat.name": { 
      "type": "text",
      "fielddata": true
    }
  }
}

```

and the same for the rest of your older indexes (metricbeat-2017.04.17, etc)

Or, depending on how far back you need that data to go, you can just keep the time range so it doesn't pick up the indexes prior to 4-19.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 3, 2017, 4:38am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/14 "2017-05-03T04:38:31Z")

</div>

Thank you so much Stacey,

The issue seems to be resolved now with fielddata, but we can see there comes error with below message regarding shards too when i load dashboard of metricbeat.

Courier fetch: 10 of 85 shards failed.

please find the below error message and let us know what would be the issue for this.

 ![](https://us1.discourse-cdn.com/elastic/original/3X/a/4/a4cbb53010195e408f71bb04d83d07c79b8ba031.png)

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [May 3, 2017, 10:48am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/15 "2017-05-03T10:48:38Z")

</div>

That's really weird @Sujith. Are there any error messages in the console or the terminal? Does it happen for every dashboard, or just that one? What does Monitoring look like, maybe there is a legitimate issue with some of your shards? Do you see it when you open up a visualization in visualize, or navigate to discover, or just on dashboard?

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 8, 2017, 5:02am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/16 "2017-05-08T05:02:30Z")

</div>

Yeah that is a strange behavior happening with me in 5.3 version. There are only error message on kibana console. It happens only in metricbeat Dashboard whereas not daily, may be sometimes only the error comes up. When i open any visualization or navigate discover, this error wont turn up. Monitoring look like there might be an issue in shards where i can see all the active shards are unassigned shards.

{  
"cluster\_name" : "AON\_ECM\_ELK",  
"status" : "yellow",  
"timed\_out" : false,  
"number\_of\_nodes" : 1,  
"number\_of\_data\_nodes" : 1,  
"active\_primary\_shards" : 615,  
"active\_shards" : 615,  
"relocating\_shards" : 0,  
"initializing\_shards" : 0,  
"unassigned\_shards" : 615,  
"delayed\_unassigned\_shards" : 0,  
"number\_of\_pending\_tasks" : 0,  
"number\_of\_in\_flight\_fetch" : 0,  
"task\_max\_waiting\_in\_queue\_millis" : 0,  
"active\_shards\_percent\_as\_number" : 50.0  
}

May be can you help in shards to be assigned rather than being unassigned shards, that might resolve the issue hope so.

Hoping for solution from your side.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 10, 2017, 10:28am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/17 "2017-05-10T10:28:22Z")

</div>

Hi Team,

Does anyone reply back to us, We are stuck up in middle of ELK environment awaiting for your response. please give us some solution.

Many Thanks

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 15, 2017, 10:47am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/18 "2017-05-15T10:47:45Z")

</div>

Hi Team,

any update please 😞

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [May 16, 2017, 3:01pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/19 "2017-05-16T15:01:26Z")

</div>

Sorry for the delay. I suggest asking about the shard failures in the elasticsearch channel. The issue may not be specifically with Kibana, but an issue with some of your shards.

---

<div class="post-metadata">

### Author: ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)
#### Post date: [May 16, 2017, 6:31pm UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/20 "2017-05-16T18:31:35Z")

</div>

One last thing to try, because I just ran into this error myself, and it was due to a faulty painless scripted field.

Do you have any painless scripted fields? If so, perhaps try removing them?

Though for my situation, the error was 1 of 2 shards failed, and no data was retrieved at all, for the discover page.

---

<div class="post-metadata">

### Author: ![Sujith](https://avatars.discourse-cdn.com/v4/letter/s/77aa72/32.png) [@Sujith](https://discuss.elastic.co/u/Sujith)
#### Post date: [May 24, 2017, 6:46am UTC](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812/21 "2017-05-24T06:46:59Z")

</div>

Sorry for the late reply as i was on vacation Stacey.

yes i checked from my end and we can see there is no painless scripted fields used.

Or may be it might be of different issue.

[Next page](https://discuss.elastic.co/t/kibana-dashboard-error-set-fielddata-true-on-fieldname/82812.md?page=2)
