# Kibana Dashboard: I am using elastic cloud trial version and filebeat is running but failed to load fllebeat index pattern on kibana

**URL:** <https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 1, 2020, 10:40am UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023 "2020-04-01T10:40:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Manav\_Chopra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/manav_chopra/32/46106_2.png) [@Manav\_Chopra](https://discuss.elastic.co/u/Manav_Chopra)\
**Post date:** [April 1, 2020, 10:40am UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023/1 "2020-04-01T10:40:48Z")

</div>

I am working on windows system and working on elastic cloud: elasticsearch and kibana  
I have installed filebeat as well and configured properly . In console if i run filebeat -e, it is running but on kibana nothing is shown.  
No index pattern is coming i.e filebeat-\* is expected.

I have enabled the input configuration in filebeat.yml to be true and set the path to C:\Program Files\filebeat\logs\*

setup.dashboards.enabled: true  
setup.kibana,host: pointed to kibana endpoint url of elastic cloud

Please refer attached images as well and let me know what i am missing?

 ![test2](https://us1.discourse-cdn.com/elastic/original/3X/a/a/aa10f692b047cfb31b1fc9cff2e3a5e3822afab6.png) ![test3](https://us1.discourse-cdn.com/elastic/original/3X/b/b/bbdf485faef673ce4deec25f91d1e0eb69d9c7a9.png) ![test4](https://us1.discourse-cdn.com/elastic/original/3X/b/7/b747ec9cde5d94169ca8e17f5de20ed4c520754e.png)

---

<div class="post-metadata">

**Author:** ![ChrsMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrsmark/32/55858_2.png) [@ChrsMark](https://discuss.elastic.co/u/ChrsMark)\
**Post date:** [April 2, 2020, 8:21am UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023/2 "2020-04-02T08:21:15Z")

</div>

Hey!

For setting up dashboards I explicitly run:  
`./filebeat setup --dashboards -E setup.kibana.host="https://elastic:xxxxxxxxxx@xxxxxxxxxx.europe-west3.gcp.cloud.es.io:9243" -e -d "*"`

Could you give it a shot?

Then I start Filebeat like:  
`./metricbeat -e -d "*" -E cloud.id=test:xxxxxxxx -E cloud.auth=elastic:xxxxxxx`

I don't think that you need `output.elasticsearch.hosts`, `output.elasticsearch.username`, `output.elasticsearch.password` since these are overwritten ([https://www.elastic.co/guide/en/beats/metricbeat/current/configure-cloud-id.html#configure-cloud-id](https://www.elastic.co/guide/en/beats/metricbeat/current/configure-cloud-id.html#configure-cloud-id)).

Hope it helps!

---

<div class="post-metadata">

**Author:** ![Manav\_Chopra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/manav_chopra/32/46106_2.png) [@Manav\_Chopra](https://discuss.elastic.co/u/Manav_Chopra)\
**Post date:** [April 3, 2020, 11:37am UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023/3 "2020-04-03T11:37:52Z")

</div>

Hi there

Thanks for replying. I got into another trouble.  
When I ran  
./filebeat setup --dashboards -E setup.kibana.host="[https://elastic:xxxxxxxxxx@xxxxxxxxxx.europe-west3.gcp.cloud.es.io:9243](https://elastic:xxxxxxxxxx@xxxxxxxxxx.europe-west3.gcp.cloud.es.io:9243)" -e -d "\*"  
Exiting: The cloud.id setting enables the Elasticsearch output, but you already have the logstash output enabled in the config

This error is coming.  
I have now using logstash as well, so filebeat will take logs and give it to logstash. and logstash will take input from filebeat and then output to elasticsearch

But as you said, i have disabled the settings of `output.elasticsearch.hosts` , `output.elasticsearch.username` , `output.elasticsearch.password` since these are overwritten as I am working on cloud, so above error is coming.  
Also if i mentioned and enable the username and password in filebeat.yml file, then different error is coming which is:  
Exiting: error loading config file: yaml: line 170: did not find expected key

So please give me solution for both the errors:  
a) error loading config file: yaml: line 170: did not find expected key  
Please refer [https://pastebin.com/UXQa211V](https://pastebin.com/UXQa211V) for filebeat.yml file  
b) Exiting: The cloud.id setting enables the Elasticsearch output, but you already have the logstash output enabled in the config(if i comment the username and password from that yml file, then this error appears)

---

<div class="post-metadata">

**Author:** ![ChrsMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrsmark/32/55858_2.png) [@ChrsMark](https://discuss.elastic.co/u/ChrsMark)\
**Post date:** [April 3, 2020, 2:29pm UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023/4 "2020-04-03T14:29:45Z")

</div>

In order to fix issue number 2 you need to remove `cloud.*` settings from your config since it will try to set Elasticsearch as an output while you already have Logstash to be set. This is what the error indicates:  
`Exiting: The cloud.id setting enables the Elasticsearch output, but you already have the logstash output enabled in the config`

Regarding the first one it seems to be an indentation error, so please try to fix your configuration using an yaml validation tool (you can find many of them online).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 1, 2020, 2:29pm UTC](https://discuss.elastic.co/t/kibana-dashboard-i-am-using-elastic-cloud-trial-version-and-filebeat-is-running-but-failed-to-load-fllebeat-index-pattern-on-kibana/226023/5 "2020-05-01T14:29:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
