# Kibana Dashboard with error Code 504

**URL:** <https://discuss.elastic.co/t/kibana-dashboard-with-error-code-504/370872>\
**Category:** Kibana\
**Tags:** dashboard\
**Created:** [November 21, 2024, 4:39am UTC](https://discuss.elastic.co/t/kibana-dashboard-with-error-code-504/370872 "2024-11-21T04:39:48Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![balaa](https://avatars.discourse-cdn.com/v4/letter/b/85e7bf/32.png) [@balaa](https://discuss.elastic.co/u/balaa)\
**Post date:** [November 21, 2024, 4:39am UTC](https://discuss.elastic.co/t/kibana-dashboard-with-error-code-504/370872/1 "2024-11-21T04:39:48Z")

</div>

Hi Team,

We have recently upgraded elk stack from 7.17 to 8.12 and from then onwards we are getting the below error when we run dashboards for more than 7days. Any one please suggest what could be the cause and how to fix?

Note : Increased resource & timeout as suggested but its not working as expected.

 ![{4B504A0D-3E10-4627-9B46-32F6345C1298}](https://us1.discourse-cdn.com/elastic/original/3X/7/7/778a96c0488b884100c479097d16e6346bb4eda5.png)

Regards,  
Baalaa
