# Kibana degraded after upgrade

**URL:** https://discuss.elastic.co/t/kibana-degraded-after-upgrade/348160
**Category:** Kibana
**Created:** [November 28, 2023, 3:29pm UTC](https://discuss.elastic.co/t/kibana-degraded-after-upgrade/348160 "2023-11-28T15:29:33Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![rudyfaile](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudyfaile/32/101130_2.png) [@rudyfaile](https://discuss.elastic.co/u/rudyfaile)
#### Post date: [November 28, 2023, 3:29pm UTC](https://discuss.elastic.co/t/kibana-degraded-after-upgrade/348160/1 "2023-11-28T15:29:33Z")

</div>

Hi,

I upgraded my ELK stack running on self-hosted kubernetes. My Elasticsearch cluster is green, but my kibana instance is spewing error logs like:

```auto
│ kibana [2023-11-28T15:24:58.959+00:00][ERROR][plugins.taskManager] Failed to poll for work: ResponseError: {"took":4,"timed_out":false," │
│ kibana [2023-11-28T15:25:01.961+00:00][ERROR][plugins.taskManager] Failed to poll for work: ResponseError: {"took":4,"timed_out":false," │
│ kibana [2023-11-28T15:25:04.960+00:00][ERROR][plugins.taskManager] Failed to poll for work: ResponseError: {"took":6,"timed_out":false," 
│ etc.

```

If I go to /status it shows kibana in a yellow state, sometimes flapping to unavailable and back to yellow in the logs.

I saw similar posts to my own, but did not see a resolution to any of them:

> [@Kibana status is Yellow due to plugins degraded (after upgrade to version 8.8.2)](https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901):
>
> Hi, I just upgraded elasticseach/ kibana to 8.8.2. Cluster health is Green. But Kibana status is Yellow (when I navigate to http:///status ) What is see is there are lot of plugins in yellow status with the message degraded Can someone guide me how to resolve this issue ? One of Kibana Log at kubernetes pod level - [2023-09-13T03:37:25.766+00:00][ERROR][plugins.alerting.metrics.alert.threshold] Executing Rule sales-and-service-cloud-monitoring:metrics.alert.threshold:4156c8df-16e…

> [@Kibana Plugins Degraded](https://discuss.elastic.co/t/kibana-plugins-degraded/309748):
>
> Hi there, I´ve done a few searchs for this kind of solution and I could not find anywhere. Can someone help me? Jul 15 12:00:36 kbn kibana[3899]: [2022-07-15T12:00:36.438-03:00][ERROR][plugins.securitySolution] Bulk Indexing of signals failed: index: ".ds-logs-checkpoint.firewall-default-2022.07.14-000024" reason: "failed to create query: end-of-string expected at position 1" type: "query\_shard\_exception" caused by reason: "end-of-string expected at position 1" caused by type: "illeg…

FWIW When I upgraded the vast majority of the issues I encountered were related to security stuff. The forced "secure by default" in ELK 8.x+ is very frustrating.

Thankful for any help I can get on this.

---

<div class="post-metadata">

### Author: ![rudyfaile](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rudyfaile/32/101130_2.png) [@rudyfaile](https://discuss.elastic.co/u/rudyfaile)
#### Post date: [November 30, 2023, 8:53pm UTC](https://discuss.elastic.co/t/kibana-degraded-after-upgrade/348160/2 "2023-11-30T20:53:35Z")

</div>

The problem was this [Upgrade to 8.7.0 hitting cluster\_shard\_limit\_exceeded leads to write blocked index even after shard limit resolution · Issue #155136 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/155136)

even though we were nowhere near the limit. Somehow, `blocks.write` got set to true on an index, specifically: `.kibana_task_manager_7.17.1_001`. Removing the block fixed the problem.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 28, 2023, 8:53pm UTC](https://discuss.elastic.co/t/kibana-degraded-after-upgrade/348160/3 "2023-12-28T20:53:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
