# Kibana did not load properly. Check the server output for more information. Kibana in Docker for nginx

**URL:** <https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856>\
**Category:** Kibana\
**Created:** [February 11, 2019, 12:59pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856 "2019-02-11T12:59:59Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Stanislav\_O](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@Stanislav\_O](https://discuss.elastic.co/u/Stanislav_O)\
**Post date:** [February 11, 2019, 12:59pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/1 "2019-02-11T12:59:59Z")

</div>

Kibana: 6.5.4  
We run Kibana in Docker for nginx. Once you have launched the page, you’ve been receiving a message. "Kibana did not load properly. Check the server output for more information."  
Follow the link:

> [http://internal.server.com/kibana/](http://internal.server.com/kibana/)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/7/075cbef29f7f4c3bd8ac5e412c87210187f84bc9.png)

Config proxy Nginx:

```
map $http_upgrade $connection_upgrade {
    default upgrade;
    '' close;
}
server {
    listen 80;
    listen 443 ssl;
    ssl_certificate /etc/nginx/ssl/ssl.crt;
    ssl_certificate_key /etc/nginx/ssl/ssl.key;
    ssl_verify_depth 3
    server_name internal.server.com;

location /kibana {
            proxy_set_header Host $host;
            proxy_set_header X-Forwarded-Host $host;
            proxy_set_header X-Forwarded-Server $host;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_pass http://10.99.202.51:5601;
        }
}

```

Config Kibana.yml:

```
server.port: 5601
server.host: "0"
server.basePath: "/kibana"
server.rewriteBasePath: true
server.maxPayloadBytes: 1048576
elasticsearch.requestTimeout: 60000
elasticsearch.shardTimeout: 60000
elasticsearch.tribe.requestTimeout: 60000
elasticsearch.url: "http://10.99.202.51:9200"
kibana.index: ".kibana"

```

Additionally configured to access from another proxy. Its configuration is similar, but starts with:

```
location /

```

Kibana opens with another dns using this proxy.  
Logs docker container Kibana:

> {"type":"response","@timestamp":"2019-02-11T12:54:09Z","tags":,"pid":1,"method":"get","statusCode":304,"req":{"url":"/plugins/searchprofiler/index.css","method":"get","headers":{"host":"[internal.server.com](http://internal.server.com)","x-forwarded-host":"[internal.server.com](http://internal.server.com)","x-forwarded-server":"[internal.server.com](http://internal.server.com)","x-forwarded-for":"10.100.42.134","connection":"close","user-agent":"Mozilla/5.0 (X11; Ubuntu; Linux x86\_64; rv:65.0) Gecko/20100101 Firefox/65.0","accept":"text/css,_/_;q=0.1","accept-language":"en-US,en;q=0.5","accept-encoding":"gzip, deflate","referer":"[http://internal.server.com/kibana/","if-modified-since":"Mon](http://internal.server.com/kibana/%22,%22if-modified-since%22:%22Mon), 17 Dec 2018 21:33:57 GMT","if-none-match":""fdd633559f0864ace51268c661d47f7510746b6b-gzip""},"remoteAddress":"10.99.202.20","userAgent":"10.99.202.20","referer":"[http://internal.server.com/kibana/"},"res":{"statusCode":304,"responseTime":3,"contentLength":9},"message":"GET](http://internal.server.com/kibana/%22%7D,%22res%22:%7B%22statusCode%22:304,%22responseTime%22:3,%22contentLength%22:9%7D,%22message%22:%22GET) /plugins/searchprofiler/index.css 304 3ms - 9.0B"}

Tell me, please, what's the problem?

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [February 12, 2019, 5:44pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/2 "2019-02-12T17:44:36Z")

</div>

Your setup looks mostly right, or at least I don't immediately see anything wrong with it. Except for one thing; `server.host`. You have a value of `"0"`, which I'm not sure is actually correct. You may need to plug `localhost` or `0.0.0.0` in there, or possibly even `internal.server.com`... but I'm also not sure that's really the issue (maybe this is how you're supposed to network between Docker container? I'm not well versed in that personally).

If you open the browser debugger and watch the network tab when you load Kibana, what do you see? Are requests failing? If so, what's the URL they are trying to load, and what error does it produce? And also, are you seeing any error messages from the Kibana server (stdout or in log files)?

---

<div class="post-metadata">

**Author:** ![Stanislav\_O](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@Stanislav\_O](https://discuss.elastic.co/u/Stanislav_O)\
**Post date:** [February 13, 2019, 8:57am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/3 "2019-02-13T08:57:16Z")

</div>

Applied recommendations with the `server.host`, but they did not help.

 ![error](https://us1.discourse-cdn.com/elastic/original/3X/6/d/6d8414c858730d5231669311074dd2c0bb6cfced.png)

The same file is available from another proxy.  
In logs only "statusCode": 304 from this proxy. 502 is missing.

---

<div class="post-metadata">

**Author:** ![gowda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gowda/32/40867_2.png) [@gowda](https://discuss.elastic.co/u/gowda)\
**Post date:** [February 13, 2019, 9:31am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/4 "2019-02-13T09:31:34Z")

</div>

did you update kibana recently,  
and is this problem showing up after the update??  
if so try to add the dll files to kibana folder where its installed.

---

<div class="post-metadata">

**Author:** ![Stanislav\_O](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@Stanislav\_O](https://discuss.elastic.co/u/Stanislav_O)\
**Post date:** [February 13, 2019, 11:45am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/5 "2019-02-13T11:45:04Z")

</div>

Yes, the upgrade was from kibana 6 to kibana 6.5.4. Previously there were problems with the monitoring tab, but the kibana worked. Then the kibana was updated and shoved into the docker.

Kibina works, if you set the `xpack.monitoring.enabled` parameter `false` to `kibana.yml`.

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [February 13, 2019, 8:51pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/6 "2019-02-13T20:51:37Z")

</div>

So you have the monitoring UI disabled then? That may explain the 502 on that css file, but it's almost certainly a bug (that file shouldn't even be loaded if the plugin is disabled).

The other `getAttribute` error you're seeing is coming from the Spaces feature, and I don't see anything in the issue tracker about it (I may just be missing it though).

I'd be curious to know if you re-enable monitoring if that css error goes away. I suspect the 502 response is actually coming from your proxy, and not from Kibana, but again, that request shouldn't even be made.

@Brandon_Kobel have you seen that spaces error before? Is it possible that the monitoring issue is causing that error too?

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [February 13, 2019, 9:26pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/7 "2019-02-13T21:26:08Z")

</div>

> @Brandon_Kobel have you seen that spaces error before? Is it possible that the monitoring issue is causing that error too?

I have not seen that error before, it's possible that some monitoring code is being loaded as part of the space selector bundle.

---

<div class="post-metadata">

**Author:** ![gowda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gowda/32/40867_2.png) [@gowda](https://discuss.elastic.co/u/gowda)\
**Post date:** [February 14, 2019, 2:27am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/8 "2019-02-14T02:27:34Z")

</div>

so try to add the dll files to kibana folder where its installed.  
i to had the same issue (used brew services) and copying the .dll files solved the problem

---

<div class="post-metadata">

**Author:** ![sentient](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sentient/32/34996_2.png) [@sentient](https://discuss.elastic.co/u/sentient)\
**Post date:** [February 21, 2019, 7:18am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/9 "2019-02-21T07:18:37Z")

</div>

Running into a similar issue. Most css files loads except

using the image  
[docker.elastic.co/kibana/kibana-oss:6.5.4](http://docker.elastic.co/kibana/kibana-oss:6.5.4)

deployed to minikube

```auto
bootstrap.js:29 GET https://k8s-logs.test.com/plugins/status_page/index.css net::ERR_ABORTED 502
loadStyleSheet @ bootstrap.js:29
window.onload @ bootstrap.js:52
load (async)
(anonymous) @ bootstrap.js:1
bootstrap.js:29 GET https://k8s-logs.test.com/plugins/console/index.css net::ERR_ABORTED 502
loadStyleSheet @ bootstrap.js:29
window.onload @ bootstrap.js:47
load (async)
(anonymous) @ bootstrap.js:1
bootstrap.js:29 GET https://k8s-logs.test.com/plugins/inspector_views/index.css net::ERR_ABORTED 502
loadStyleSheet @ bootstrap.js:29
window.onload @ bootstrap.js:56
load (async)
(anonymous) @ bootstrap.js:1
kibana.bundle.js:82 Uncaught TypeError: Cannot read property 'getAttribute' of null
    at Object.<anonymous> (kibana.bundle.js:82)
    at __webpack_require__ (vendors.bundle.js:1)
    at webpackJsonpCallback (vendors.bundle.js:1)
    at kibana.bundle.js:1

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 21, 2019, 7:18am UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-in-docker-for-nginx/167856/10 "2019-03-21T07:18:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
