# Kibana @ docker no logfiles

**URL:** <https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [November 26, 2020, 11:46am UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766 "2020-11-26T11:46:59Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Waxman](https://avatars.discourse-cdn.com/v4/letter/w/c2a13f/32.png) [@Waxman](https://discuss.elastic.co/u/Waxman)\
**Post date:** [November 26, 2020, 11:46am UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/1 "2020-11-26T11:46:59Z")

</div>

Hi There,

I run kibana on docker-compose, but I cannot see the logfiles.  
Here is the part of the docker compose file with volumes mapped:  
indent preformatted text by 4 spaces

```auto
volumes:
      - /srv/Docker/config:/usr/share/kibana/config
      - /srv/Docker/logs:/usr/share/kibana/logs`
/srv/Docker/logs & config has full rights (temporarily)
Here is the output of kibana.yml:
`server.port: 5601
server.host: "0.0.0.0"
server.name: "kib01d"
elasticsearch.hosts: ["https://xxxx:9200","https://xxx:9200","https://xxx:9200"]
server.ssl.enabled: true
elasticsearch.username: "kibana_system"
elasticsearch.password: "xxx"
server.ssl.certificate: /usr/share/kibana/config/certs/xxx.crt
server.ssl.key: /usr/share/kibana/config/certs/xxx.key
elasticsearch.ssl.certificateAuthorities: ["/usr/share/kibana/config/certs/ca/ca.crt"]
elasticsearch.ssl.verificationMode: certificate
pid.file: /usr/share/kibana/kibana.pid
logging.verbose: true
logging.dest: "/usr/share/kibana/logs"

```

When I set the logging.dest: "/usr/share/kibana/logs as above i received this:

> Blockquote  
> | events.js:174  
> uelkkib01d | throw er; // Unhandled 'error' event  
> uelkkib01d | ^  
> uelkkib01d |  
> uelkkib01d | Error: EISDIR: illegal operation on a directory, open '/usr/share/kibana/logs'  
> uelkkib01d | Emitted 'error' event at:  
> uelkkib01d | at errorOrDestroy (internal/streams/destroy.js:107:12)  
> uelkkib01d | at WriteStream.onerror (\_stream\_readable.js:734:7)  
> uelkkib01d | at WriteStream.emit (events.js:198:13)  
> uelkkib01d | at lazyFs.open (internal/fs/streams.js:277:12)  
> uelkkib01d | at FSReqWrap.args [as oncomplete] (fs.js:140:20)

> Blockquote  
> Is there any idea what's going wrong here ? I can see the console log from docker file when I remove : " logging.dest: "/usr/share/kibana/logs" and kibana starts to work normally.

---

<div class="post-metadata">

**Author:** ![markov00](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/markov00/32/33316_2.png) [@markov00](https://discuss.elastic.co/u/markov00)\
**Post date:** [November 26, 2020, 3:11pm UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/2 "2020-11-26T15:11:10Z")

</div>

Hi, I think you can solve this just removing the quote around the file name:

```auto
logging.dest: /usr/share/kibana/logs

```

the same as the `pid.file` field works basically

---

<div class="post-metadata">

**Author:** ![Waxman](https://avatars.discourse-cdn.com/v4/letter/w/c2a13f/32.png) [@Waxman](https://discuss.elastic.co/u/Waxman)\
**Post date:** [November 26, 2020, 3:26pm UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/3 "2020-11-26T15:26:43Z")

</div>

Unfortunately It didn't help me ☹

```auto
uelkkib01d | events.js:174
uelkkib01d | throw er; // Unhandled 'error' event
uelkkib01d | ^
uelkkib01d |
uelkkib01d | Error: EISDIR: illegal operation on a directory, open '/usr/share/kibana/logs'
uelkkib01d | Emitted 'error' event at:
uelkkib01d | at errorOrDestroy (internal/streams/destroy.js:107:12)
uelkkib01d | at WriteStream.onerror (_stream_readable.js:734:7)
uelkkib01d | at WriteStream.emit (events.js:198:13)
uelkkib01d | at lazyFs.open (internal/fs/streams.js:277:12)
uelkkib01d | at FSReqWrap.args [as oncomplete] (fs.js:140:20)
uelkkib01d exited with code 1

```

---

<div class="post-metadata">

**Author:** ![markov00](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/markov00/32/33316_2.png) [@markov00](https://discuss.elastic.co/u/markov00)\
**Post date:** [November 26, 2020, 3:47pm UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/4 "2020-11-26T15:47:30Z")

</div>

oh sorry, I probably miss that: the documentation for that field says

```auto
#Enables you to specify a file where Kibana stores log output.
 logging.dest: stdout

```

so you should point to a file and not a directory

```auto
logging.dest: /usr/share/kibana/logs/kibana.log

```

---

<div class="post-metadata">

**Author:** ![Waxman](https://avatars.discourse-cdn.com/v4/letter/w/c2a13f/32.png) [@Waxman](https://discuss.elastic.co/u/Waxman)\
**Post date:** [November 26, 2020, 4:09pm UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/5 "2020-11-26T16:09:46Z")

</div>

> [@Waxman](#):
>
> ```auto
> 
> ```

This definetely solved my problem. Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 24, 2020, 4:09pm UTC](https://discuss.elastic.co/t/kibana-docker-no-logfiles/256766/6 "2020-12-24T16:09:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
