# Kibana does not create .kibana index

**URL:** https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405
**Category:** Kibana
**Created:** [October 6, 2016, 3:56pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405 "2016-10-06T15:56:46Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![ageldenberg](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@ageldenberg](https://discuss.elastic.co/u/ageldenberg)
#### Post date: [October 6, 2016, 3:56pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/1 "2016-10-06T15:56:47Z")

</div>

Upgraded to kibana 4.6.1 and elasticsearch 2.4.1. Before installing Kibana deleted an old version of .kibana index.  
Elasticsearch seems to work OK after the upgrade:

root@lablogstash:~/softshop# curl -XGET "localhost:9200"  
{  
"name" : "Savage Steel",  
"cluster\_name" : "labelastic",  
"cluster\_uuid" : "OCiX4Yi5QMKGVfrjQve7YQ",  
"version" : {  
"number" : "2.4.1",  
"build\_hash" : "c67dc32e24162035d18d6fe1e952c4cbcbe79d16",  
"build\_timestamp" : "2016-09-27T18:57:55Z",  
"build\_snapshot" : false,  
"lucene\_version" : "5.5.2"  
},  
"tagline" : "You Know, for Search"  
}

However, when starting kibana, it fails with:

root@lablogstash:~/softshop# curl -XGET "localhost:9200"  
{"@timestamp":"2016-10-06T15:43:26.711Z","level":"fatal","message":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index","index":".kibana","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":".kibana"}],"type":"index\_not\_found\_exception","reason":"no such index","index":".kibana","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":".kibana"},"node\_env":"production","error":{"message":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index","index":".kibana","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":".kibana"}],"type":"index\_not\_found\_exception","reason":"no such index","index":".kibana","resource.type":"index\_or\_alias","[resource.id](http://resource.id)":".kibana"},"name":"Error","stack":"Error: [object Object]\n at respond (/root/softshop/kibana/src/node\_modules/elasticsearch/src/lib/transport.js:235:15)\n at checkRespForFailure (/root/softshop/kibana/src/node\_modules/elasticsearch/src/lib/transport.js:203:7)\n at HttpConnector. (/root/softshop/kibana/src/node\_modules/elasticsearch/src/lib/connectors/http.js:156:7)\n at IncomingMessage.bound (/root/softshop/kibana/src/node\_modules/elasticsearch/node\_modules/lodash-node/modern/internals/baseBind.js:56:17)\n at IncomingMessage.emit (events.js:117:20)\n at \_stream\_readable.js:944:16\n at process.\_tickCallback (node.js:442:13)\n"}}

kibana.yml file:

root@lablogstash:/opt/kibana/config# cat kibana.yml | grep -v "^#" | grep -v "^$"  
server.port: 5601  
server.host: "127.0.0.1"  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"  
kibana.index: ".kibana"  
kibana.defaultAppId: "discover"  
logging.dest: /opt/kibana/config/kibana.log  
logging.verbose: true

I have no idea how to fix the issue. All previous Kibana installations just created .kibana index with no problem. I have no security plug-ins installed.

Thanks a lot for help.

---

<div class="post-metadata">

### Author: ![ageldenberg](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@ageldenberg](https://discuss.elastic.co/u/ageldenberg)
#### Post date: [October 6, 2016, 4:30pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/2 "2016-10-06T16:30:43Z")

</div>

Created .kibana manually. Now kibana process fails because it cannot find mappings. Please, HELP!!!

Thank you,

---

<div class="post-metadata">

### Author: ![ageldenberg](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@ageldenberg](https://discuss.elastic.co/u/ageldenberg)
#### Post date: [October 6, 2016, 4:38pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/3 "2016-10-06T16:38:06Z")

</div>

After creating .kibana manually, I started Kibana by running ./kibana and it did create proper mapping. I guess something did not work when I was starting kibana as "nohup" process:

nohup /opt/kibana/bin/kibana &

Interesting... However, now Kibana is running fine.

Regards,

---

<div class="post-metadata">

### Author: ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)
#### Post date: [October 7, 2016, 11:34pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/4 "2016-10-07T23:34:15Z")

</div>

Hi Alek,

I'm glad you got past the problem and have it working now.

I've never started Kibana with nohup. When running on Linux I usually install the deb package and start the service. Can you help me understand the how and why you use nohup to start Kibana?  
What OS are you on?  
Do you install the package using a package manager, of get the tar.gz and uncompress it (sounds like this one)?

If it's an important use case and there's a problem I want to understand and start testing it that way. And filing bugs if it doesn't work.

Thanks,  
Lee

---

<div class="post-metadata">

### Author: ![ageldenberg](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@ageldenberg](https://discuss.elastic.co/u/ageldenberg)
#### Post date: [October 8, 2016, 3:49am UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/5 "2016-10-08T03:49:54Z")

</div>

Hi, Lee.

Thanks a lot for your reply. I used a very old version of Kibana prior to upgrading to the latest one. As far as I remember, I could not start the old version as a service, i.e. in background. So I used to start it with:

Nohup ./kibana &

After I upgraded, I used the same method by habit. However, it did not work.

The previous version was a tar file. The new version was installed as package from .deb file. I use latesr Debian as OS.

Best regards,

Alek.

Get Outlook for Android[https://aka.ms/ghei36](https://aka.ms/ghei36)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:37pm UTC](https://discuss.elastic.co/t/kibana-does-not-create-kibana-index/62405/6 "2017-07-06T13:37:11Z")

</div>


