# Kibana does not start up with tribe node configuration

**URL:** <https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338>\
**Category:** Kibana\
**Created:** [May 3, 2017, 3:07am UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338 "2017-05-03T03:07:37Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [May 3, 2017, 3:07am UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338/1 "2017-05-03T03:07:37Z")

</div>

Hello.

I have a kibana fails to start up when initiating connection to tribe node.  
I am using the latest _5.3.2 series_.

Kibana's tribe node configuration is below. Tribe node is running on the same host as kibana.

```
# The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.url: "http://10.213.xxx.xx:9200"
elasticsearch.tribe.url: "http://127.0.0.1:9200"

```

Below are the logs .

```
May 3 11:58:04 BSU00390 systemd: Started Kibana.
May 3 11:58:04 BSU00390 systemd: Starting Kibana...
May 3 11:58:08 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:08Z","tags":["status","plugin:kibana@5.3.2","info"],"pid":8492,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:elasticsearch@5.3.2","info"],"pid":8492,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:xpack_main@5.3.2","info"],"pid":8492,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:graph@5.3.2","info"],"pid":8492,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:monitoring@5.3.2","info"],"pid":8492,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["reporting","warning"],"pid":8492,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:reporting@5.3.2","info"],"pid":8492,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:security@5.3.2","info"],"pid":8492,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["security","warning"],"pid":8492,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["security","warning"],"pid":8492,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:xpack_main@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from yellow to red - Authentication Exception","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:graph@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from yellow to red - Authentication Exception","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:reporting@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from yellow to red - Authentication Exception","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:security@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from yellow to red - Authentication Exception","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:elasticsearch@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from yellow to red - Authentication Exception","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:searchprofiler@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from uninitialized to red - Authentication Exception","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:tilemap@5.3.2","error"],"pid":8492,"state":"red","message":"Status changed from uninitialized to red - Authentication Exception","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","plugin:timelion@5.3.2","info"],"pid":8492,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["listening","info"],"pid":8492,"message":"Server running at http://10.213.xxx.xx:5601"}
May 3 11:58:09 BSU00390 kibana: {"type":"log","@timestamp":"2017-05-03T02:58:09Z","tags":["status","ui settings","error"],"pid":8492,"state":"red","message":"Status changed from uninitialized to red - Elasticsearch plugin is red","prevState":"uninitialized","prevMsg":"uninitialized"}

```

It looks like kibana is able to connect to **elasticsearch.url** but it fails to access to **tribe.url**.

I have also checked that tribe node is starting up with global address.

```
[xxxxxxx@xxx00390 ~]$ sudo netstat -atunp | grep 0.0.0.0:9200
tcp 0 0 0.0.0.0:9200 0.0.0.0:* LISTEN 22353/java

```

Is there anything else that I should look for? I would appreciate for any advice.

---

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [May 3, 2017, 3:10am UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338/2 "2017-05-03T03:10:21Z")

</div>

I was able to see the login screen of kibana when I take off _elasticsearch.tribe.url_

---

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [May 3, 2017, 3:14am UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338/3 "2017-05-03T03:14:50Z")

</div>

Solved. I needed below settings.

> **[Configure Kibana | Kibana Guide \[8.11\] | Elastic](https://www.elastic.co/guide/en/kibana/current/settings.html)**

> elasticsearch.tribe.username: and elasticsearch.tribe.password:

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [May 3, 2017, 6:44pm UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338/4 "2017-05-03T18:44:48Z")

</div>

Glad you were able to resolve it. Let me know if anything else comes up.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 31, 2017, 6:45pm UTC](https://discuss.elastic.co/t/kibana-does-not-start-up-with-tribe-node-configuration/84338/5 "2017-05-31T18:45:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
