# Kibana doesn't see the indices

**URL:** https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339
**Category:** Kibana
**Created:** [August 1, 2019, 2:02pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339 "2019-08-01T14:02:38Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 2:02pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/1 "2019-08-01T14:02:38Z")

</div>

Hi there. I've been experiencing a problem with Kibana - the indices don't show in index patterns menu even though all the indexes are present in index management menu.

The whole thing runs under proxy.  
Request: [http://192.168.10.6:5601/elasticsearch/\*/\_search?ignore\_unavailable=true](http://192.168.10.6:5601/elasticsearch/%2A/_search?ignore_unavailable=true)  
Response:  
proxy\_response:  
`{ "took": 833, "timed_out": false, "_shards": { "total": 4, "successful": 4, "skipped": 0, "failed": 0 }, "hits": { "total": { "value": 10000, "relation": "gte" }, "max_score": null, "hits": [] }, "aggregations": { "indices": { "doc_count_error_upper_bound": 0, "sum_other_doc_count": 0, "buckets": [{ "key": "logs-64cb0a97d4594f79bf2b2a5bfd9763e1-2019-08-01", "doc_count": 185111 }, { "key": ".monitoring-es-7-2019.08.01", "doc_count": 201 }, { "key": ".monitoring-kibana-7-2019.08.01", "doc_count": 24 }, { "key": ".kibana", "doc_count": 2 }] } } }`

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 2:05pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/2 "2019-08-01T14:05:41Z")

</div>

kibana.yml:  
server.port: 5601  
server.host: 192.168.10.6  
server.basePath: /dashboard/monitoring/logs\_proxy  
server.rewriteBasePath: false  
elasticsearch.hosts: ["[http://192.168.10.6:9200](http://192.168.10.6:9200)"]  
elasticsearch.preserveHost: True  
kibana.index: ".kibana"  
kibana.defaultAppId: "discover"  
elasticsearch.shardTimeout: 0  
elasticsearch.startupTimeout: 5000

logging.silent: false  
logging.quiet: false  
logging.verbose: true  
optimize.useBundleCache: False

xpack.monitoring.enabled: true  
xpack.monitoring.kibana.collection.enabled: true  
xpack.monitoring.ui.enabled: true

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 2:08pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/3 "2019-08-01T14:08:11Z")

</div>

Index patterns menu:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/c/ec1aab6413c9fcf4e6eea036950964bf7a0a4859.png)  
Index management menu:  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/8/d84207ac6f7c7ca992c8e909aad4cbf6887b05c4.png)

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 2:11pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/4 "2019-08-01T14:11:39Z")

</div>

elasticsearch.yml:  
cluster.name: monasca\_elastic  
node.name: "devstack"  
node.master: true  
node.data: true  
path.data: /opt/stack/data/elasticsearch  
path.logs: /opt/stack/logs/elasticsearch  
network.bind\_host: 192.168.10.6  
network.publish\_host: 192.168.10.6  
transport.tcp.port: 9300  
http.port: 9200  
cluster.initial\_master\_nodes: ["192.168.10.6"]  
xpack.security.enabled: false  
xpack.monitoring.enabled: true  
xpack.monitoring.collection.enabled: true  
xpack.monitoring.elasticsearch.collection.enabled: true

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [August 1, 2019, 2:14pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/5 "2019-08-01T14:14:34Z")

</div>

Do you see the same problem if you bypass the proxy?

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 2:19pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/6 "2019-08-01T14:19:27Z")

</div>

without proxy  
request:  
`curl http://192.168.10.6:5601/elasticsearch/%2A/_search?ignore_unavailable=true -d'{"size":0,"aggs":{"indices":{"terms":{"field":"_index","size":200}}}}' -H 'kbn-xsrf: reporting'`  
response:  
`{"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred"}`

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 1, 2019, 9:29pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/7 "2019-08-01T21:29:16Z")

</div>

Elasticseach and Kibana - both 7.2.1

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [August 2, 2019, 4:14am UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/8 "2019-08-02T04:14:21Z")

</div>

Can you bypass the proxy and access Kibana? How is the proxy set up?

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 2, 2019, 7:59am UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/9 "2019-08-02T07:59:27Z")

</div>

if I set rewriteBasePath to true, everything's accessible outside proxy and I can see all of my indices.  
Otherwise it's not accesible - I'm getting such errors:  
`Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'nonce-WlAeJVZ1TIIKfZ8U'". Either the 'unsafe-inline' keyword, a hash ('sha256-SHHSeLc0bp6xt4BoVVyUy+3IbVqp3ujLaR+s+kSP5UI='), or a nonce ('nonce-...') is required to enable inline execution. bootstrap.js:1 Failed to load resource: the server responded with a status of 404 (Not Found)`  
Proxy is basically rewriting the link, removing basePath, packing headers and sending a request via Python urllib.request.Request.

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 2, 2019, 11:54am UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/10 "2019-08-02T11:54:04Z")

</div>

btw, in 7.3.0(both es and kibana) error looks like that:  
`Uncaught (in promise) Error: Loading chunk 169 failed. (missing: http://192.168.10.6/dashboard/monitoring/logs_proxy/built_assets/dlls/icon.logo_elasticsearch-js.bundle.dll.js) at requireEnsure (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:1) at Array.map (<anonymous>) at webpackAsyncContext (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:192) at EuiIcon.loadIconComponent (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:54) at new EuiIcon (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:54) at vf (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:224) at Og (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:224) at Tg (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:224) at bi (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:224) at ci (/dashboard/monitoring/logs_proxy/built_assets/dlls/vendors.bundle.dll.js:224)`

---

<div class="post-metadata">

### Author: ![arseni-lipinski](https://avatars.discourse-cdn.com/v4/letter/a/7cd45c/32.png) [@arseni-lipinski](https://discuss.elastic.co/u/arseni-lipinski)
#### Post date: [August 6, 2019, 2:59pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/11 "2019-08-06T14:59:07Z")

</div>

If it ever helps anyone, the issue was resolved by adding `Content-Type": "application/json"` to the headers of the request. Good luck everyone!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 3, 2019, 2:59pm UTC](https://discuss.elastic.co/t/kibana-doesnt-see-the-indices/193339/12 "2019-09-03T14:59:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
