# Kibana doesn't start properly at upgrade from 7.17.1 to 8.3.2

**URL:** <https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586>\
**Category:** Kibana\
**Created:** [July 13, 2022, 11:13pm UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586 "2022-07-13T23:13:42Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)\
**Post date:** [July 13, 2022, 11:13pm UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586/1 "2022-07-13T23:13:42Z")

</div>

Log message(s):

```auto
...
... [ERROR][savedobjects-service] [.kibana] Action failed with
  'security_exception: [security_exception] Reason: action [indices:admin/create]
  is unauthorized for user [kibanaserver] with roles [admin] on restricted indices
  [.kibana_8.3.2_001], this action is granted by the index privileges
  [create_index,manage,all]'. ...
...
... [ERROR][savedobjects-service] [.kibana_task_manager] Action failed with
   'security_exception: [security_exception] Reason: action [indices:admin/create]
   is unauthorized for user [kibanaserver] with roles [admin] on restricted indices
   [.kibana_task_manager_8.3.2_001], this action is granted by the index privileges
   [create_index,manage,all]'. ...
...

```

[Line breaks/spaces added here for readability.]  
`users_roles` contains:

```auto
...
admin:kibanaserver
...

```

`roles.yml` contains:

```auto
admin:
  cluster:
    - all
  indices:
    - names: '*'
      privileges:
        - all
...

```

I also tried in `roles.yml`:

```auto
...
    - names: ['*', '.*']
...

```

to no avail.

---

<div class="post-metadata">

**Author:** ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)\
**Post date:** [July 15, 2022, 9:34am UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586/2 "2022-07-15T09:34:15Z")

</div>

Solved it. There were different `users_roles` and `roles.yml` in the configs of our 9 nodes across 3 servers.

But now the `elastic` user's password has been reset to ???. And [Setting passwords for native and built-in users](https://www.elastic.co/guide/en/elasticsearch/reference/current/change-passwords-native-users.html) doesn't work.

I'm feeling like Indiana Jones with this upgrade: one trap door after the other.

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [July 15, 2022, 2:25pm UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586/3 "2022-07-15T14:25:27Z")

</div>

Glad you solved it! Yes, your configs need to match across nodes of the same cluster.

---

<div class="post-metadata">

**Author:** ![gerib](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gerib/32/106584_2.png) [@gerib](https://discuss.elastic.co/u/gerib)\
**Post date:** [July 19, 2022, 11:12am UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586/4 "2022-07-19T11:12:01Z")

</div>

The errors occurred again during one of the next (re-)starts and it persisted until we changed `users_roles` on all 9 nodes from:

```auto
admin:...,kibanaserver,...

```

to:

```auto
admin:...
kibana_system:kibanaserver

```

It remains a mystery to us why it worked when restarting Kibana a few times and suddenly it didn't persistently – with the `admin` role (and its settings in `roles.yml`) assigned to `kibanaserver`. Just a guess: Perhaps an issue of the order of restarting ES nodes and which master node was the previous current master?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 16, 2022, 11:12am UTC](https://discuss.elastic.co/t/kibana-doesnt-start-properly-at-upgrade-from-7-17-1-to-8-3-2/309586/5 "2022-08-16T11:12:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
