# KIBANA - Elastic search PLUGIN IS RED, UI SETTINGS PLUGN IS RED

**URL:** <https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438>\
**Category:** Kibana\
**Created:** [September 13, 2019, 1:28pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438 "2019-09-13T13:28:09Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![nirish](https://avatars.discourse-cdn.com/v4/letter/n/8dc957/32.png) [@nirish](https://discuss.elastic.co/u/nirish)\
**Post date:** [September 13, 2019, 1:28pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/1 "2019-09-13T13:28:09Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/7/3/73aa6a0d4f1ff7ce183c6622249b967c813a216c.png)

**LOGS FROM data ingestion server**  
failed to execute pipeline for a bulk request  
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution of org.elasticsearch.ingest.PipelineExecu  
tionService$2@471e0de7 on EsThreadPoolExecutor[bulk, queue capacity = 200, org.elasticsearch.common.util.concurrent.EsThreadPoolExe  
cutor@73250f05[Running, pool size = 2, active threads = 2, queued tasks = 205, completed tasks = 12360]]  
at org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:50) ~[elasticsearch-5.5.2.ja

**LOGS FROM ELASTIC MASTER**  
[r.suppressed] path: /\_template/filebeat-6.1.2, params: {name=filebeat-6.1.2}  
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException: failed to process cluster event (create-index-template [fil  
ebeat-6.1.2], cause [api]) within 30s

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 13, 2019, 1:31pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/2 "2019-09-13T13:31:59Z")

</div>

What is the status of your Elasticsearch cluster? Is there anything in the logs?

---

<div class="post-metadata">

**Author:** ![nirish](https://avatars.discourse-cdn.com/v4/letter/n/8dc957/32.png) [@nirish](https://discuss.elastic.co/u/nirish)\
**Post date:** [September 13, 2019, 1:42pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/3 "2019-09-13T13:42:53Z")

</div>

Status of ES cluster is running(master, data nodes are running). I have attached the corresponding logs above post

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 13, 2019, 2:41pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/4 "2019-09-13T14:41:31Z")

</div>

What is the specification of your cluster? How many indices and shards do you have in it?

---

<div class="post-metadata">

**Author:** ![nirish](https://avatars.discourse-cdn.com/v4/letter/n/8dc957/32.png) [@nirish](https://discuss.elastic.co/u/nirish)\
**Post date:** [September 13, 2019, 3:46pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/5 "2019-09-13T15:46:00Z")

</div>

I was able to get some far on the previous issue Now I have a different one  
KIBANA LOGS kibana.stdout.log  
{"type":"response","@timestamp":"2019-09-13T15:43:03Z","tags":,"pid":6528,"method":"post","statusCode":200,"req":{"url":"/elasticsearch/\_msearch","method":"post","headers":{"host":"logs","content-length":"865","accept":"application/json, text/plain, _/_","origin":"[https://logs](https://logs)","kbn-version":"5.5.2","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36","sec-fetch-mode":"cors","content-type":"application/x-ndjson","sec-fetch-site":"same-origin","referer":"[https://logs/app/kibana","accept-encoding":"gzip](https://logs/app/kibana%22,%22accept-encoding%22:%22gzip), deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"10.249.0.7","userAgent":"10.249.0.7","referer":"[https://logs/app/kibana"},"res":{"statusCode":200,"responseTime":32,"contentLength":9},"message":"POST](https://logs/app/kibana%22%7D,%22res%22:%7B%22statusCode%22:200,%22responseTime%22:32,%22contentLength%22:9%7D,%22message%22:%22POST) /elasticsearch/\_msearch 200 32ms - 9.0B"}  
{"type":"log","@timestamp":"2019-09-13T15:43:28Z","tags":["error","elasticsearch","admin"],"pid":6528,"message":"Request error, retrying\nPOST [http://127.0.0.1:9200/.kibana/config/5.5.2/\_update](http://127.0.0.1:9200/.kibana/config/5.5.2/_update) =\> socket hang up"}  
{"type":"log","@timestamp":"2019-09-13T15:43:58Z","tags":["error","elasticsearch","admin"],"pid":6528,"message":"Request error, retrying\nPOST [http://127.0.0.1:9200/.kibana/config/5.5.2/\_update](http://127.0.0.1:9200/.kibana/config/5.5.2/_update) =\> socket hang up"}

---

<div class="post-metadata">

**Author:** ![nirish](https://avatars.discourse-cdn.com/v4/letter/n/8dc957/32.png) [@nirish](https://discuss.elastic.co/u/nirish)\
**Post date:** [September 13, 2019, 4:46pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/6 "2019-09-13T16:46:00Z")

</div>

1 master node  
3 data nodes  
1 haproxy  
1 monitor for cluster

---

<div class="post-metadata">

**Author:** ![nirish](https://avatars.discourse-cdn.com/v4/letter/n/8dc957/32.png) [@nirish](https://discuss.elastic.co/u/nirish)\
**Post date:** [September 13, 2019, 6:42pm UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/7 "2019-09-13T18:42:33Z")

</div>

I have the following server configuriation (master, 3 clusters,1haproxy)aster is reporting this  
**Elastic Search Master Logs**  
[elasticsearch\_data/0][1.X.X.X:9300][indices:data/write/bulk]  
Caused by: org.elasticsearch.cluster.block.ClusterBlockException: blocked by: [SERVICE\_UNAVAILABLE/2/no master];  
at org.elasticsearch.cluster.block.ClusterBlocks.globalBlockedException(ClusterBlocks.java:165) ~[elasticsearch-5.5.2.jar:5  
.5.2]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation.handleBlockExceptions(TransportBulkAction.java:396) ~[el  
asticsearch-5.5.2.jar:5.5.2]7

**Elastic Search data node LOGS**  
[o.e.d.z.ZenDiscovery] [elasticsearch\_data/0] not enough master nodes discovered during pingin  
g (found [], but needed [1]), pinging again

**KIBANA LOGS**  
{"type":"response","@timestamp":"2019-09-13T15:43:03Z","tags":,"pid":6528,"method":"post","statusCode":200,"req":{"url":"/elasticsearch/\_msearch","method":"post","headers":{"host":"logs","content-length":"865","accept":"application/json, text/plain, _/_ ","origin":"[https://logs](https://logs/)","kbn-version":"5.5.2","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36","sec-fetch-mode":"cors","content-type":"application/x-ndjson","sec-fetch-site":"same-origin","referer":"[https://logs/app/kibana","accept-encoding":"gzip](https://logs/app/kibana%22,%22accept-encoding%22:%22gzip), deflate, br","accept-language":"en-US,en;q=0.9"},"remoteAddress":"10.249.0.7","userAgent":"10.249.0.7","referer":"[https://logs/app/kibana"},"res":{"statusCode":200,"responseTime":32,"contentLength":9},"message":"POST](https://logs/app/kibana%22%7D,%22res%22:%7B%22statusCode%22:200,%22responseTime%22:32,%22contentLength%22:9%7D,%22message%22:%22POST) /elasticsearch/\_msearch 200 32ms - 9.0B"}  
{"type":"log","@timestamp":"2019-09-13T15:43:28Z","tags":["error","elasticsearch","admin"],"pid":6528,"message":"Request error, retrying\nPOST [http://127.0.0.1:9200/.kibana/config/5.5.2/\_update](http://127.0.0.1:9200/.kibana/config/5.5.2/_update) =\> socket hang up"}  
{"type":"log","@timestamp":"2019-09-13T15:43:58Z","tags":["error","elasticsearch","admin"],"pid":6528,"message":"Request error, retrying\nPOST [http://127.0.0.1:9200/.kibana/config/5.5.2/\_update](http://127.0.0.1:9200/.kibana/config/5.5.2/_update) =\> socket hang up"}\*\*

**CLUSTER HEALTH** DOESNT RESPOND  
curl [http://10.X.X.X:9200/\_cluster/health](http://10.X.X.X:9200/_cluster/health)  
no reponse

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 14, 2019, 9:28am UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/8 "2019-09-14T09:28:21Z")

</div>

Is your Elasticsearch cluster running?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 12, 2019, 9:28am UTC](https://discuss.elastic.co/t/kibana-elastic-search-plugin-is-red-ui-settings-plugn-is-red/199438/9 "2019-10-12T09:28:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
