# Kibana error 403 forbidden

**URL:** https://discuss.elastic.co/t/kibana-error-403-forbidden/200383
**Category:** Kibana
**Created:** [September 20, 2019, 8:55am UTC](https://discuss.elastic.co/t/kibana-error-403-forbidden/200383 "2019-09-20T08:55:05Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)
#### Post date: [September 20, 2019, 8:55am UTC](https://discuss.elastic.co/t/kibana-error-403-forbidden/200383/1 "2019-09-20T08:55:05Z")

</div>

Hi,  
I just setup my xpack in elasticsearch 7.1.0 and changed all my built-in user passwords.  
this is the change i made in Kibana.yml  
`xpack.security.enabled: true elasticsearch.username: "kibana" elasticsearch.password: "password@123"`

When i restarted Kibana,  
i ws prompted with a username password page, where i gave  
`kibana/password@123` that i had set in my yml.

Im getting the below response:  
`{"statusCode":403,"error":"Forbidden","message":"Forbidden"}`

Please help me out.

---

<div class="post-metadata">

### Author: ![corey.robertson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/corey.robertson/32/54611_2.png) [@corey.robertson](https://discuss.elastic.co/u/corey.robertson)
#### Post date: [September 20, 2019, 1:23pm UTC](https://discuss.elastic.co/t/kibana-error-403-forbidden/200383/2 "2019-09-20T13:23:29Z")

</div>

Hi @katara

This 403 - Forbidden will happen when the user does not have the appropriate permissions to access Kibana. Try assigning the `kibana` user the `kibana_user` role to make sure it has the appropriate permissions.

---

<div class="post-metadata">

### Author: ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)
#### Post date: [September 21, 2019, 8:55am UTC](https://discuss.elastic.co/t/kibana-error-403-forbidden/200383/3 "2019-09-21T08:55:17Z")

</div>

Thanks Corey,  
I did try with the "elastic" user and it seems to work well, but when I created another new user and have it a simple kibana dashboard role, there is an error stating "error in visualization internal server error"  
It looks like my user is not about to get to the index.  
How do I provide the access to this user? @corey.robertson

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 19, 2019, 8:55am UTC](https://discuss.elastic.co/t/kibana-error-403-forbidden/200383/4 "2019-10-19T08:55:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
