# Kibana error after DNS entry

**URL:** <https://discuss.elastic.co/t/kibana-error-after-dns-entry/244616>\
**Category:** Kibana\
**Created:** [August 11, 2020, 6:28pm UTC](https://discuss.elastic.co/t/kibana-error-after-dns-entry/244616 "2020-08-11T18:28:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gauti](https://avatars.discourse-cdn.com/v4/letter/g/cdc98d/32.png) [@Gauti](https://discuss.elastic.co/u/Gauti)\
**Post date:** [August 11, 2020, 6:28pm UTC](https://discuss.elastic.co/t/kibana-error-after-dns-entry/244616/1 "2020-08-11T18:28:23Z")

</div>

Hi All,

WE have configured elastic stack by mentioning the IP address in all the config files and we have done OKta integration also. Now we have done a DNS entry for the IP address used, after this change we are not able to access kibana console through Okta authentication.

Below is the error we are getting.

`{"statusCode":401,"error":"Unauthorized","message":"[security_exception] unable to authenticate user [<unauthenticated-saml-user>] for action [cluster:admin/xpack/security/saml/authenticate], with { header={ WWW-Authenticate={ 0=\"Bearer realm=\\\"security\\\"\" & 1=\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\" } } }"}`

Through local login i was able to login. Problem is with Okta authentication.

Any advice please.

Thanks  
Gautham

---

<div class="post-metadata">

**Author:** ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)\
**Post date:** [August 12, 2020, 1:11pm UTC](https://discuss.elastic.co/t/kibana-error-after-dns-entry/244616/2 "2020-08-12T13:11:01Z")

</div>

Hi @Gauti,

Have you properly reconfigured Elasticsearch SAML realm to work with DNS names instead of IPs? Does Okta metadata file/URL you use in Elasticsearch configuration also reflect that change?

Also you should be able to locate a more detailed error message in the [Elasticsearch logs](https://www.elastic.co/guide/en/elasticsearch/reference/current/trb-security-saml.html).

Let me know if you still have any questions,  
Oleg

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 9, 2020, 1:11pm UTC](https://discuss.elastic.co/t/kibana-error-after-dns-entry/244616/3 "2020-09-09T13:11:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
