# Kibana error after upgrade to version 8.0 \[config validation of \[logging\].dest\]: definition for this key is missing\]

**URL:** <https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948>\
**Category:** Kibana\
**Created:** [February 22, 2022, 8:25pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948 "2022-02-22T20:25:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shreesh\_Narayanan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shreesh_narayanan/32/87312_2.png) [@Shreesh\_Narayanan](https://discuss.elastic.co/u/Shreesh_Narayanan)\
**Post date:** [February 22, 2022, 8:25pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948/1 "2022-02-22T20:25:07Z")

</div>

Hi,

I had successfully upgraded to version 8.0 on ELK , while the rest of the stack works , kibana has failed to start citing

```auto
dev-elk-app01 kibana[19018]: FATAL Error: [config validation of [logging].dest]: definition for this key is missing

```

i understand from a bit of googling that logging.dest is no longer supported on 8.0 , however my yml configuration has no entry for logging.dest .

Could someone help out ?

here's the full error:

```auto
Feb 22 20:24:35 dev-elk-app01 systemd[1]: Started Kibana.
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: Configuring logger failed: ValidationError: [config validation of [logging].dest]: definition for this key is missing
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target_node/types/type.js:95:13)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ConfigService.validateAtPath (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:228:19)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber.project (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:236:169)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber.Subscriber.next (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:80:28) {
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: cause: SchemaTypeError: definition for this key is missing
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ObjectType.onError (/usr/share/kibana/node_modules/@kbn/config-schema/target_node/types/type.js:137:14)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at Object.error (/usr/share/kibana/node_modules/@kbn/config-schema/target_node/types/type.js:79:47)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at Object.internals.finalize (/usr/share/kibana/node_modules/joi/lib/validator.js:472:36)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at Object.exports.validate (/usr/share/kibana/node_modules/joi/lib/validator.js:333:38)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at Object.internals.entry (/usr/share/kibana/node_modules/joi/lib/validator.js:142:28)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at Object.exports.entry (/usr/share/kibana/node_modules/joi/lib/validator.js:27:30)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at internals.Base.validate (/usr/share/kibana/node_modules/joi/lib/base.js:548:26)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target_node/types/type.js:89:29)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at ConfigService.validateAtPath (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:228:19)
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: at MapSubscriber.project (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:236:169) {
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: cause: undefined,
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: path: ['dest']
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: }
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: }
Feb 22 20:24:37 dev-elk-app01 kibana[19121]: FATAL Error: [config validation of [logging].dest]: definition for this key is missing
Feb 22 20:24:37 dev-elk-app01 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Feb 22 20:24:37 dev-elk-app01 systemd[1]: kibana.service: Failed with result 'exit-code'.
Feb 22 20:24:40 dev-elk-app01 systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Feb 22 20:24:40 dev-elk-app01 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 1.
Feb 22 20:24:40 dev-elk-app01 systemd[1]: Stopped Kibana.

```

Here;s the YML file

```auto
root@dev-elk-app01:/etc/kibana# cat kibana.yml| grep -v "#"

server.port: 5601

server.host: "172.26.207.174"

server.publicBaseUrl: "http://kibana-dev.staging.com:5601"

server.name: "kibana-dev01"
elasticsearch.hosts: ["http://172.26.207.179:9200"]
logging.root.level: debug

logging:
  appenders:
    file:
      type: file
      fileName: /var/log/kibana/kibana.log
      layout:
        type: json
  root:
    appenders:
      - default
      - file

path.data: /var/lib/kibana/
pid.file: /run/kibana/kibana.pid
data.autocomplete.valueSuggestions.timeout: 100000000
data.autocomplete.valueSuggestions.terminateAfter: 100000000
```

---

<div class="post-metadata">

**Author:** ![Shreesh\_Narayanan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shreesh_narayanan/32/87312_2.png) [@Shreesh\_Narayanan](https://discuss.elastic.co/u/Shreesh_Narayanan)\
**Post date:** [February 22, 2022, 8:49pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948/2 "2022-02-22T20:49:26Z")

</div>

found the reason , it seems my systemd unit was still referring to logging.dest , removing it seemed to have worked and moved on to the next problem

```auto
ExecStart=/usr/share/kibana/bin/kibana --logging.dest="/var/log/kibana/kibana.log" --pid.file="/run/kibana/kibana.pid" --deprecation.skip_deprecated_settings[0]="logging.dest"

```

new error

```auto
 Feb 22 20:47:48 dev-elk-app01 kibana[22911]: FATAL Error: [config validation of [elasticsearch].username]: value of "elastic" is forbidden. This is a superuser account that cannot write to system indices that Kibana needs to function. Use a service account token instead. Learn more: https://www.elastic.co/guide/en/elasticsearch/reference/8.0/service-accounts.html
Feb 22 20:47:48 dev-elk-app01 systemd[1]: kibana.service: Main process exited, code=exited, status=78/n/a
Feb 22 20:47:48 dev-elk-app01 systemd[1]: kibana.service: Failed with result 'exit-code'.

```

---

<div class="post-metadata">

**Author:** ![MUGISHA\_Danny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mugisha_danny/32/102447_2.png) [@MUGISHA\_Danny](https://discuss.elastic.co/u/MUGISHA_Danny)\
**Post date:** [March 1, 2022, 10:04am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948/3 "2022-03-01T10:04:00Z")

</div>

How did you manage to remove it ?

---

<div class="post-metadata">

**Author:** ![Dustin\_Tennill](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dustin_tennill/32/79039_2.png) [@Dustin\_Tennill](https://discuss.elastic.co/u/Dustin_Tennill)\
**Post date:** [March 11, 2022, 11:03pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948/4 "2022-03-11T23:03:26Z")

</div>

Hey,

I had the same issue.

To fix it on Ubuntu/Debian:  
Open /etc/systemd/system/kibana.service in your favorite editor.  
Find the ExecStart line and remove the logging.dest setting.

Before:  
ExecStart=/usr/share/kibana/bin/kibana --logging.dest="/var/log/kibana/kibana.log" --pid.file="/run/kibana/kibana.pid" --deprecation.skip\_deprecated\_settings[0]="logging.dest"

After:  
ExecStart=/usr/share/kibana/bin/kibana --pid.file="/run/kibana/kibana.pid" --deprecation.skip\_deprecated\_settings[0]="logging.dest"

It looks like the command line argument is deprecated and it's expected that setting will be in the /etc/kibana/kibana.yml.

If you want to have kibana logs in /var/log/kibana/kibana.log, make sure your /etc/kibana/kibana.yml has this in it:

```auto
logging:
  appenders:
    file:
      type: file
      fileName: /var/log/kibana/kibana.log
      layout:
        type: json
  root:
    appenders:

```

Dustin

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 8, 2022, 11:04pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948/5 "2022-04-08T23:04:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
