# Kibana error after upgrade to version 8.0 from 7.17.0 \[No validation schema has been defined for \[xpack.canvas\]

**URL:** https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352
**Category:** Kibana
**Created:** [February 27, 2022, 11:40am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352 "2022-02-27T11:40:54Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![sumitpramanik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumitpramanik/32/102380_2.png) [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)
#### Post date: [February 27, 2022, 11:40am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/1 "2022-02-27T11:40:54Z")

</div>

Hi,

I have updated my elasticstack from version 7.17 to 8.0 recenly. All of my 3 Elasticsearch nodes and 2 logstash nodes are working fine. But whenever I am trying to upgrade to Kibana version 8.0 it is thowing below error.

> {"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-27T17:27:39.815+06:00","message":"No validation schema has been defined for [xpack.canvas]","error":{"message":"No validation schema has been defined for [xpack.canvas]","type":"Error","stack\_trace":"Error: No validation schema has been defined for [xpack.canvas]\n at ConfigService.isEnabledAtPath (/usr/share/kibana/node\_modules/@kbn/config/target\_node/config\_service.js:166:13)\n at PluginsService.handleDiscoveredPlugins (/usr/share/kibana/src/core/server/plugins/plugins\_service.js:203:25)\n at PluginsService.discover (/usr/share/kibana/src/core/server/plugins/plugins\_service.js:66:5)\n at Server.preboot (/usr/share/kibana/src/core/server/server.js:155:30)\n at Root.preboot (/usr/share/kibana/src/core/server/root/index.js:48:14)\n at bootstrap (/usr/share/kibana/src/core/server/bootstrap.js:99:9)\n at Command. (/usr/share/kibana/src/cli/serve/serve.js:216:5)"},"log":{"level":"FATAL","logger":"root"},"process":{"pid":5738}}

Can anyone please help me understand what should be the way forward to mitigate this error? Thanks in advance.

---

<div class="post-metadata">

### Author: ![sumitpramanik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumitpramanik/32/102380_2.png) [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)
#### Post date: [February 28, 2022, 6:22am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/2 "2022-02-28T06:22:09Z")

</div>

Anyone facing the same problem?

---

<div class="post-metadata">

### Author: ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)
#### Post date: [March 1, 2022, 10:08am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/3 "2022-03-01T10:08:58Z")

</div>

> [@sumitpramanik](#):
>
> xpack.canvas

You need to remove `xpack.canvas` from `kibana.yml` file. Probably you disabled it some time ago. Only a few plugins can be disabled starting from `v8.0`

---

<div class="post-metadata">

### Author: ![sumitpramanik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumitpramanik/32/102380_2.png) [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)
#### Post date: [March 2, 2022, 9:07am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/4 "2022-03-02T09:07:29Z")

</div>

Thank you for your reply. So I have hashed these lines which I am not using. Below is my xpack configuration.

> #xpack.monitoring.enabled: true  
> #xpack.graph.enabled: false  
> #xpack.ml.enabled: false  
> xpack.security.enabled: true  
> #xpack.watcher.enabled: false  
> xpack.reporting.enabled: true  
> xpack.spaces.enabled: true  
> #xpack.canvas.enabled: true  
> xpack.encryptedSavedObjects.encryptionKey: VALUE  
> xpack.reporting.encryptionKey: VALUE  
> xpack.security.encryptionKey: VALUE  
> xpack:  
> monitoring:  
> enabled: true  
> min\_interval\_seconds: 10  
> monitoring.kibana.collection.enabled: false

But now below error is occurring. I am using SSL and TLS in elasticsearch, but not in Kibana. So is this the issue here?

> {"ecs":{"version":"8.0.0"},"@timestamp":"2022-03-02T15:02:22.184+06:00","message":"[config validation of [xpack.security].enabled]: definition for this key is missing","error":{"message":"[config validation of [xpack.security].enabled]: definition for this key is missing","type":"Error","stack\_trace":"Error: [config validation of [xpack.security].enabled]: definition for this key is missing\n at ObjectType.validate (/usr/share/kibana/node\_modules/@kbn/config-schema/target\_node/types/type.js:95:13)\n at ConfigService.validateAtPath (/usr/share/kibana/node\_modules/@kbn/config/target\_node/config\_service.js:228:19)\n at MapSubscriber.project (/usr/share/kibana/node\_modules/@kbn/config/target\_node/config\_service.js:236:169)\n at MapSubscriber.\_next (/usr/share/kibana/node\_modules/rxjs/internal/operators/map.js:49:35)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node\_modules/rxjs/internal/Subscriber.js:66:18)\n at DistinctUntilChangedSubscriber.\_next (/usr/share/kibana/node\_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)\n at DistinctUntilChangedSubscriber.Subscriber.next (/usr/share/kibana/node\_modules/rxjs/internal/Subscriber.js:66:18)\n at MapSubscriber.\_next (/usr/share/kibana/node\_modules/rxjs/internal/operators/map.js:55:26)\n at MapSubscriber.Subscriber.next (/usr/share/kibana/node\_modules/rxjs/internal/Subscriber.js:66:18)\n at ReplaySubject.\_subscribe (/usr/share/kibana/node\_modules/rxjs/internal/ReplaySubject.js:80:28)\n at ReplaySubject.Observable.\_trySubscribe (/usr/share/kibana/node\_modules/rxjs/internal/Observable.js:44:25)\n at ReplaySubject.Subject.\_trySubscribe (/usr/share/kibana/node\_modules/rxjs/internal/Subject.js:102:51)\n at ReplaySubject.Observable.subscribe (/usr/share/kibana/node\_modules/rxjs/internal/Observable.js:30:22)\n at MapSubscriber.shareReplayOperation (/usr/share/kibana/node\_modules/rxjs/internal/operators/shareReplay.js:48:32)\n at Observable.subscribe (/usr/share/kibana/node\_modules/rxjs/internal/Observable.js:25:31)\n at MapOperator.call (/usr/share/kibana/node\_modules/rxjs/internal/operators/map.js:32:23)"},"log":{"level":"FATAL","logger":"root"},"process":{"pid":64545}}

---

<div class="post-metadata">

### Author: ![sumitpramanik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumitpramanik/32/102380_2.png) [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)
#### Post date: [March 8, 2022, 8:37am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/5 "2022-03-08T08:37:52Z")

</div>

Hi [Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov),

Can you please check my previous comment and let me know what am I doing wrong?

> My error is "message":"[config validation of [xpack.security].enabled]: definition for this key is missing"

As xpack.security is mandatory what to do to remediate this?

---

<div class="post-metadata">

### Author: ![sumitpramanik](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumitpramanik/32/102380_2.png) [@sumitpramanik](https://discuss.elastic.co/u/sumitpramanik)
#### Post date: [March 10, 2022, 9:37am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/6 "2022-03-10T09:37:07Z")

</div>

Solved this by disabling xpack.security.enabled, xpack.reporting.enabled & xpack.spaces.enabled. As mentioned in document these setting are causing the problem.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 7, 2022, 9:37am UTC](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-from-7-17-0-no-validation-schema-has-been-defined-for-xpack-canvas/298352/7 "2022-04-07T09:37:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
