# Kibana error after upgrading to 7.5.0 from 7.3.2

**URL:** <https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484>\
**Category:** Kibana\
**Created:** [December 19, 2019, 12:38pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484 "2019-12-19T12:38:14Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)\
**Post date:** [December 19, 2019, 12:38pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484/1 "2019-12-19T12:38:15Z")

</div>

Hello,

I have just upgraded kibana from 7.3.2 to 7.5.0 and it is failing with the following error:

```
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["fatal","root"],"pid":6490,"message":"{ ValidationError: child \"path\" fails because [\"path\" is not allowed to be empty]\n at Object.exports.process (/usr/share/kibana/node_modules/joi/lib/errors.js:196:19)\n at internals.Object._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:675:31)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n at Object.internals.implementation [as cookie] (/usr/share/kibana/node_modules/hapi-auth-cookie/lib/index.js:94:25)\n at module.exports.internals.Auth._strategy (/usr/share/kibana/node_modules/hapi/lib/auth.js:52:47)\n at createCookieSessionStorageFactory (/usr/share/kibana/src/core/server/http/cookie_session_storage.js:86:15)\n at process._tickCallback (internal/process/next_tick.js:68:7)\n isJoi: true,\n name: 'ValidationError',\n details:\n [{ message: '\"path\" is not allowed to be empty',\n path: [Array],\n type: 'any.empty',\n context: [Object] } ],\n _object:\n { cookie: 'sid',\n password: '69066bb81b64c2c4959fa3150bfa9a8a',\n validateFunc: [AsyncFunction: validateFunc],\n isSecure: false,\n path: '',\n clearInvalid: true,\n isHttpOnly: true,\n isSameSite: false },\n annotate: [Function] }"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","server"],"pid":6490,"message":"stopping server"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","legacy-service"],"pid":6490,"message":"stopping legacy service"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","plugins-service"],"pid":6490,"message":"Stopping plugins service"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","elasticsearch-service"],"pid":6490,"message":"Stopping elasticsearch service"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","elasticsearch-service"],"pid":6490,"message":"Closing elasticsearch clients"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: {"type":"log","@timestamp":"2019-12-19T12:32:21Z","tags":["debug","http","server","Kibana"],"pid":6490,"message":"stopping http server"}
Dec 19 12:32:21 MGT-VMNVLOG02-1c kibana[6490]: FATAL ValidationError: child "path" fails because ["path" is not allowed to be empty]

```

Also uninstalled it and installed if fresh but I get the same error every time I try to start it.

---

<div class="post-metadata">

**Author:** ![Larry\_Gregory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/larry_gregory/32/34969_2.png) [@Larry\_Gregory](https://discuss.elastic.co/u/Larry_Gregory)\
**Post date:** [December 19, 2019, 1:08pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484/2 "2019-12-19T13:08:19Z")

</div>

Hi @zozo6015,

Can you post the full contents of your `kibana.yml` file, redacting any sensitive information?  
This error message is sometimes indicative of incorrect or unexpected configuration values.

---

<div class="post-metadata">

**Author:** ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)\
**Post date:** [December 19, 2019, 1:09pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484/3 "2019-12-19T13:09:14Z")

</div>

Fixed it by commenting out the `server.basePath: ""` line in the `kibana.yml`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 16, 2020, 1:09pm UTC](https://discuss.elastic.co/t/kibana-error-after-upgrading-to-7-5-0-from-7-3-2/212484/4 "2020-01-16T13:09:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
