# Kibana - Error - Can't start - Unable to read Kibana UUID file

**URL:** <https://discuss.elastic.co/t/kibana-error-cant-start-unable-to-read-kibana-uuid-file/291370>\
**Category:** Kibana\
**Created:** [December 9, 2021, 11:00pm UTC](https://discuss.elastic.co/t/kibana-error-cant-start-unable-to-read-kibana-uuid-file/291370 "2021-12-09T23:00:20Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![kmiklas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kmiklas/32/50730_2.png) [@kmiklas](https://discuss.elastic.co/u/kmiklas)\
**Post date:** [December 9, 2021, 11:00pm UTC](https://discuss.elastic.co/t/kibana-error-cant-start-unable-to-read-kibana-uuid-file/291370/1 "2021-12-09T23:00:20Z")

</div>

[ubuntu 20.04]

Howdy,

I've inherited an Elastic installation, which was running. I can't seem to get it restarted.. can anyone help to get me out of the weeds?

I tried to bounce it with the following command, as user `ubuntu` [1]

```auto
sudo systemctl start kibana.service
sudo systemctl stop kibana.service

```

Now, when I restart, I am getting this error:

```auto
Error: Unable to read Kibana UUID file, please check the uuid.server configuration value in kibana.yml and ensure Kibana has sufficient permissions to read / write to this file. Error was: EACCES\n at readUuidFromFile (/usr/share/kibana/src/core/server/environment/resolve_uuid.js:102:11)"}

```

According to ref [2], I have a permissions issue; I need to run kibana as the kibana user.

So I tried to switch user to kibana, but it's prompting me for a password.

Should I simply reset the password, log in as kibana, and try to launch the application? I thought that Kibana is a nonexistant user?

I also tried to run it as the kibana user, like so:

```auto
sudo -H -u kibana bash -c '/usr/share/kibana/bin/kibana'

```

...but the config file was missing. I created a symbolic link from /usr/share/kibana/config/kibana.yml to /etc/kibana/kibana.yml, and tried again, but got this:

```auto
 FATAL Error: Unable to read Kibana UUID file, please check the uuid.server configuration value in kibana.yml and ensure Kibana has sufficient permissions to read / write to this file. Error was: EACCES

```

I've also read that kibana should be the owner of the files. Looks like this was installed as r00t?

```auto
ubuntu@my-sandbox-node-01:/usr/share/kibana/bin$ ls -l
total 12
-rwxr-xr-x 1 root root 835 Dec 4 2020 kibana
-rwxr-xr-x 1 root root 776 Dec 4 2020 kibana-keystore
-rwxr-xr-x 1 root root 813 Dec 4 2020 kibana-plugin

```

Here is my Elasticsearch summary:

```auto
{
  "name" : "foo",
  "cluster_name" : "bar",
  "cluster_uuid" : "10285fmvk1j918925958",
  "version" : {
    "number" : "7.12.1",
    "build_flavor" : "default",
    "build_type" : "deb",
    "build_hash" : "3186837139b9c6b6d23c3200870651f10d3343b7",
    "build_date" : "2021-04-20T20:56:39.040728659Z",
    "build_snapshot" : false,
    "lucene_version" : "8.8.0",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },
  "tagline" : "You Know, for Search"
}

```

REFERENCES:

1. [Start and stop Kibana | Kibana Guide [7.16] | Elastic](https://www.elastic.co/guide/en/kibana/current/start-stop.html)
2. [Kibana cannot read UUID file](https://discuss.elastic.co/t/kibana-cannot-read-uuid-file/252000)

Here I've pasted my /etc/kibana.yml file.

```auto
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://localhost:9200"]

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "elastic"
elasticsearch.password: "qwerty"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout
logging.dest: /var/log/kibana/kibana.log

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"

```

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [December 20, 2021, 6:05pm UTC](https://discuss.elastic.co/t/kibana-error-cant-start-unable-to-read-kibana-uuid-file/291370/2 "2021-12-20T18:05:32Z")

</div>

just to check: are you running the kibana process with the `kibana` user?  
if so, please check the permission for the `kibana` user on that directory and the `uuid` file in that directory. if you have `og+rw` permission, if I'm not wrong, it means that only group and user have permission but not the user, try to add the read/write permission to the user also.

cc @jportner - can you shed some more light whenever you have a chance.

Thanks  
Rashmi

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 17, 2022, 6:06pm UTC](https://discuss.elastic.co/t/kibana-error-cant-start-unable-to-read-kibana-uuid-file/291370/3 "2022-01-17T18:06:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
