# Kibana error - Internal Server Error

**URL:** <https://discuss.elastic.co/t/kibana-error-internal-server-error/269780>\
**Category:** Kibana\
**Tags:** elastic-stack-reporting\
**Created:** [April 10, 2021, 6:04pm UTC](https://discuss.elastic.co/t/kibana-error-internal-server-error/269780 "2021-04-10T18:04:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Post date:** [April 10, 2021, 6:04pm UTC](https://discuss.elastic.co/t/kibana-error-internal-server-error/269780/1 "2021-04-10T18:04:22Z")

</div>

Whenever I try to export data from Kibana, I am getting **internal service error.**

Following is the log entry in kibana.log. Could I kindly request someone to help me resolve this please.

```auto
{"type":"log","@timestamp":"2021-04-10T17:59:47+00:00","tags":["error","plugins","reporting"],"pid":205130,"message":"StatusCodeError: [validation_exception] Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:349:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:306:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node_modules/lodash/lodash.js:4991:19)\n at IncomingMessage.emit (events.js:327:22)\n at endReadableNT (internal/streams/readable.js:1327:12)\n at processTicksAndRejections (internal/process/task_queues.js:80:21) {\n status: 400,\n displayName: 'BadRequest',\n path: '/.reporting-2021-04-04',\n query: {},\n body: {\n error: {\n root_cause: [Array],\n type: 'validation_exception',\n reason: 'Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;'\n },\n status: 400\n },\n statusCode: 400,\n response: '{\"error\":{\"root_cause\":[{\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"}],\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"},\"status\":400}',\n toString: [Function (anonymous)],\n toJSON: [Function (anonymous)]\n}"}
{"type":"log","@timestamp":"2021-04-10T17:59:47+00:00","tags":["error","plugins","reporting"],"pid":205130,"message":"StatusCodeError: [validation_exception] Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:349:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:306:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node_modules/lodash/lodash.js:4991:19)\n at IncomingMessage.emit (events.js:327:22)\n at endReadableNT (internal/streams/readable.js:1327:12)\n at processTicksAndRejections (internal/process/task_queues.js:80:21) {\n status: 400,\n displayName: 'BadRequest',\n path: '/.reporting-2021-04-04',\n query: {},\n body: {\n error: {\n root_cause: [Array],\n type: 'validation_exception',\n reason: 'Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;'\n },\n status: 400\n },\n statusCode: 400,\n response: '{\"error\":{\"root_cause\":[{\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"}],\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"},\"status\":400}',\n toString: [Function (anonymous)],\n toJSON: [Function (anonymous)]\n}"}
{"type":"log","@timestamp":"2021-04-10T17:59:47+00:00","tags":["error","http"],"pid":205130,"message":"StatusCodeError: [validation_exception] Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:349:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:306:7)\n at HttpConnector.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node_modules/lodash/lodash.js:4991:19)\n at IncomingMessage.emit (events.js:327:22)\n at endReadableNT (internal/streams/readable.js:1327:12)\n at processTicksAndRejections (internal/process/task_queues.js:80:21) {\n status: 400,\n displayName: 'BadRequest',\n path: '/.reporting-2021-04-04',\n query: {},\n body: {\n error: {\n root_cause: [Array],\n type: 'validation_exception',\n reason: 'Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;'\n },\n status: 400\n },\n statusCode: 400,\n response: '{\"error\":{\"root_cause\":[{\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"}],\"type\":\"validation_exception\",\"reason\":\"Validation Failed: 1: this action would add [2] total shards, but this cluster currently has [2000]/[2000] maximum shards open;\"},\"status\":400}',\n toString: [Function (anonymous)],\n toJSON: [Function (anonymous)]\n}"}
{"type":"error","@timestamp":"2021-04-10T17:59:47+00:00","tags":[],"pid":205130,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toInternalError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:58:19)\n at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:177:34)\n at runMicrotasks (<anonymous>)\n at processTicksAndRejections (internal/process/task_queues.js:93:5)\n at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)\n at exports.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:60:28)\n at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)\n at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)\n at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:370:32)\n at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:279:9)"},"url":"http://kibanaip:5601/api/reporting/generate/csv","message":"Internal Server Error"}

```

If more diagnostic data is required, could someone kindly guide me as to the query required to provide additional data?

---

<div class="post-metadata">

**Author:** ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Post date:** [April 10, 2021, 6:36pm UTC](https://discuss.elastic.co/t/kibana-error-internal-server-error/269780/2 "2021-04-10T18:36:04Z")

</div>

I had too many open indices (2000+). I closed indices without documents (data) & with very little data (couple of 100 documents) and the error has been resolved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2021, 6:36pm UTC](https://discuss.elastic.co/t/kibana-error-internal-server-error/269780/3 "2021-05-08T18:36:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
