# Kibana Error : Kibana should not be run as root. Use --allow-root to continue

**URL:** https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541
**Category:** Kibana
**Created:** [August 30, 2019, 2:58pm UTC](https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541 "2019-08-30T14:58:50Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [August 30, 2019, 2:58pm UTC](https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541/1 "2019-08-30T14:58:50Z")

</div>

Hi All ,

After the installation of kibana 7.3.1 rpm (Cent Os) , when I am running the binary by command

```
     ./bin/kibana      

```

its showing an error messsage

**"Kibana should not be run as root. Use --allow-root to continue."**

When I am tried with this command "./bin/kibana --allow-root" , issue was solved . Kibana run successfully ?

Is there any changes in Kibana 7.3.1 ? Why this error message comes ?

---

<div class="post-metadata">

### Author: ![lukeelmers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukeelmers/32/35230_2.png) [@lukeelmers](https://discuss.elastic.co/u/lukeelmers)
#### Post date: [August 30, 2019, 4:58pm UTC](https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541/2 "2019-08-30T16:58:16Z")

</div>

Hi @rijinmp -

Yep, what you are running into is expected and was introduced [in this PR](https://github.com/elastic/kibana/pull/21563) that landed in `7.2`

As the PR explains,

> Kibana shouldn't need root access to run - generally it's a good practice to run with the least amount of privileges

We would recommend instead using `service kibana start` to run as the kibana user, since running as root can cause issues.

---

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [September 1, 2019, 8:42am UTC](https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541/3 "2019-09-01T08:42:33Z")

</div>

Do we need to create a user "kibana" in centos ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 29, 2019, 8:42am UTC](https://discuss.elastic.co/t/kibana-error-kibana-should-not-be-run-as-root-use-allow-root-to-continue/197541/4 "2019-09-29T08:42:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
