# Kibana error loop redirect login page - when config server.basePath

**URL:** <https://discuss.elastic.co/t/kibana-error-loop-redirect-login-page-when-config-server-basepath/183282>\
**Category:** Kibana\
**Created:** [May 29, 2019, 9:02am UTC](https://discuss.elastic.co/t/kibana-error-loop-redirect-login-page-when-config-server-basepath/183282 "2019-05-29T09:02:54Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![NguyenVanTrieu](https://avatars.discourse-cdn.com/v4/letter/n/bbce88/32.png) [@NguyenVanTrieu](https://discuss.elastic.co/u/NguyenVanTrieu)\
**Post date:** [May 29, 2019, 9:02am UTC](https://discuss.elastic.co/t/kibana-error-loop-redirect-login-page-when-config-server-basepath/183282/1 "2019-05-29T09:02:55Z")

</div>

I run kibana:7.1.0 - elasticsearch:7.1.0  
My config: /usr/share/kibana/config/kibana.yml  
"  
server.name: kibana  
server.host: 0.0.0.0  
elasticsearch.hosts: [http://elasticsearch:9200](http://elasticsearch:9200)  
"  
Everything woking on [http://ip:5601](http://ip:5601)

But when i add config "server.basePath: /kib" - (use for proxy), it not working  
Hitting access kibana: [http://ip:5601/kib](http://ip:5601/kib) -\> redirect login page.  
The login page looping redirect:  
[http://ip:5601/kib/login?next=%2Fkib%2Fkib%2Flogin%3Fnext%3D%2Fkib%2Fkib%2Flogin%3Fnext%3D%252Fkib%252](http://ip:5601/kib/login?next=%2Fkib%2Fkib%2Flogin%3Fnext%3D%252Fkib%252Fkib%252Flogin%253Fnext%253D%25252Fkib%25252)..........

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [May 29, 2019, 4:24pm UTC](https://discuss.elastic.co/t/kibana-error-loop-redirect-login-page-when-config-server-basepath/183282/2 "2019-05-29T16:24:43Z")

</div>

Hey @NguyenVanTrieu, this is being caused by [https://github.com/elastic/kibana/issues/36825](https://github.com/elastic/kibana/issues/36825). We're actively investigating a solution, but in the mean-time if you close your browser and re-open it, or clear your cookies, you should get out of the infinite redirect.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 26, 2019, 4:24pm UTC](https://discuss.elastic.co/t/kibana-error-loop-redirect-login-page-when-config-server-basepath/183282/3 "2019-06-26T16:24:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
