# Kibana error when The GUI popped up

**URL:** https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193
**Category:** Kibana
**Created:** [March 11, 2016, 6:30pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193 "2016-03-11T18:30:12Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 11, 2016, 6:30pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/1 "2016-03-11T18:30:12Z")

</div>

I tried to bring up the Kibana GUI. IP:5601 this error appeared:

This version of Kibana requires Elasticsearch ^2.2.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v1.3.9 @ inet[localhost/127.0.0.1:9200] (172.22.xx.xx)

I have installed kibana-4.4 and elasticsearch-2.2

Thanks

---

<div class="post-metadata">

### Author: ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)
#### Post date: [March 11, 2016, 10:49pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/2 "2016-03-11T22:49:50Z")

</div>

Could you navigate to `127.0.0.1:9200` in your browser and paste the output here? I don't think we've had reports of Kibana incorrectly identifying Elasticsearch versions in the past.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 11, 2016, 11:13pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/3 "2016-03-11T23:13:06Z")

</div>

Are you using an old version of Logstash with the transport protocol?

---

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 14, 2016, 1:09pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/4 "2016-03-14T13:09:20Z")

</div>

NO page is displayed

---

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 14, 2016, 1:09pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/5 "2016-03-14T13:09:40Z")

</div>

I am using this version: logstash-2.2

---

<div class="post-metadata">

### Author: ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)
#### Post date: [March 14, 2016, 2:47pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/6 "2016-03-14T14:47:06Z")

</div>

Where is your elasticsearch instance running? I thought it was local based on the error in the original post. What happens if you try to to load the url configured in kibana.yml as the elasticsearch host in your web browser? You should get a status page including the elasticsearch version number when sending a simple GET request to ES.

---

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 14, 2016, 4:18pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/7 "2016-03-14T16:18:55Z")

</div>

The elasticsearch is running on the master server.  
I tried opening the GUI 127.0.0.0:9200 and localhost:9200 and 172.22.17.62:9200  
Page cannot be displayed.

Here is the kibana.yml file, is there anything incorrect in the file?

# Kibana is served by a back end server. This controls which port to use.

# server.port: 5601

# The host to bind the server to.

server.host: "172.22.17.62"

# If you are running kibana behind a proxy, and want to mount it at a path,

# specify that path here. The basePath can't end in a slash.

# server.basePath: ""

# The maximum payload size in bytes on incoming server requests.

# server.maxPayloadBytes: 1048576

# The Elasticsearch instance to use for all your queries.

# elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"

elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"

# preserve\_elasticsearch\_host true will send the hostname specified in `elasticsearch`. If you set it to false,

# then the host you use to connect to _this_ Kibana instance will be sent.

# elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations

# and dashboards. It will create a new index if it doesn't already exist.

kibana.index: ".kibana"

# The default application to load.

# kibana.defaultAppId: "discover"

# If your Elasticsearch is protected with basic auth, these are the user credentials

# used by the Kibana server to perform maintenance on the kibana\_index at startup. Your Kibana

# users will still need to authenticate with Elasticsearch (which is proxied through

# the Kibana server)

# elasticsearch.username: "user"

"/opt/kibana/config/kibana.yml"

# elasticsearch.password: "pass"

# SSL for outgoing requests from the Kibana Server to the browser (PEM formatted)

# server.ssl.cert: /path/to/your/server.crt

# server.ssl.key: /path/to/your/server.key

# Optional setting to validate that your Elasticsearch backend uses the same key files (PEM formatted)

# elasticsearch.ssl.cert: /path/to/your/client.crt

# elasticsearch.ssl.key: /path/to/your/client.key

# If you need to provide a CA certificate for your Elasticsearch instance, put

# the path of the pem file here.

# [elasticsearch.ssl.ca](http://elasticsearch.ssl.ca): /path/to/your/CA.pem

# Set to false to have a complete disregard for the validity of the SSL

# certificate.

# elasticsearch.ssl.verify: true

# Time in milliseconds to wait for elasticsearch to respond to pings, defaults to

# request\_timeout setting

# elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or elasticsearch.

# This must be \> 0

# elasticsearch.requestTimeout: 300000

# Time in milliseconds for Elasticsearch to wait for responses from shards.

# Set to 0 to disable.

# elasticsearch.shardTimeout: 0

---

<div class="post-metadata">

### Author: ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)
#### Post date: [March 14, 2016, 11:37pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/8 "2016-03-14T23:37:57Z")

</div>

Could you post that config to a gist or a pastebin so it's easier to read (or at least wrap it in preformatted text tags using the `</>` icon in the comment editor?

It looks like you need update

`elasticsearch.url: "http://localhost:9200"`

If elasticsearch isn't running at localhost:9200, you need to update that config option to whatever address elasticsearch is running at.

---

<div class="post-metadata">

### Author: ![nader](https://avatars.discourse-cdn.com/v4/letter/n/6de8d8/32.png) [@nader](https://discuss.elastic.co/u/nader)
#### Post date: [March 17, 2016, 4:58pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/9 "2016-03-17T16:58:12Z")

</div>

this is the resullt of navigation to 127.0.0.1:9200  
{  
"status" : 200,  
"name" : "Death's Head",  
"version" : {  
"number" : "1.1.1",  
"build\_hash" : "f1585f096d3f3985e73456debdc1a0745f512bbc",  
"build\_timestamp" : "2014-04-16T14:27:12Z",  
"build\_snapshot" : false,  
"lucene\_version" : "4.7"  
},  
"tagline" : "You Know, for Search"  
}

---

<div class="post-metadata">

### Author: ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)
#### Post date: [March 18, 2016, 12:38am UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/10 "2016-03-18T00:38:23Z")

</div>

> [@nader](#):
>
> "number" : "1.1.1",

There's your problem, you're running a very old version of Elasticsearch.

---

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 18, 2016, 1:47pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/11 "2016-03-18T13:47:01Z")

</div>

What I did is remove the old version of elasticsearch and resinstalled the new version using yum.  
Now I am not able to start elasticsearch. Here is the error:

[root@cba-vml-ops-elk01 ~]# service elasticsearch status  
elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled)  
Active: failed (Result: exit-code) since Fri 2016-03-18 08:43:24 EDT; 5s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 17278 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=${PID\_DIR}/elasticsearch.pid -Des.default.path.home=${ES\_HOME} -Des.default.path.logs=${LOG\_DIR} -Des.default.path.data=${DATA\_DIR} -Des.default.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 17276 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 17278 (code=exited, status=1/FAILURE)

Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:169)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.Node.(Node.java:153)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.Node.(Node.java:128)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: Refer to the log for complete error details.  
Mar 18 08:43:24 cba-vml-ops-elk01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Mar 18 08:43:24 cba-vml-ops-elk01 systemd[1]: Unit elasticsearch.service entered failed state.

---

<div class="post-metadata">

### Author: ![rvaedex23](https://avatars.discourse-cdn.com/v4/letter/r/9f8e36/32.png) [@rvaedex23](https://discuss.elastic.co/u/rvaedex23)
#### Post date: [March 18, 2016, 3:29pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/12 "2016-03-18T15:29:09Z")

</div>

The problem with the elasticsearch was permissions to create a node. I fixed that.  
Elasticsearch started properly. I was able to bring up the Kibana GUI when I reinstalled the newer version of elasticsearch. Thank you all for your help.

---

<div class="post-metadata">

### Author: ![Mayank\_Kakoriya](https://avatars.discourse-cdn.com/v4/letter/m/8c91f0/32.png) [@Mayank\_Kakoriya](https://discuss.elastic.co/u/Mayank_Kakoriya)
#### Post date: [January 19, 2017, 10:13am UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/13 "2017-01-19T10:13:16Z")

</div>

{  
"name" : "node-1",  
"cluster\_name" : "my-application",  
"cluster\_uuid" : "\_zHJ37pQS6-\_xPmz1P5Vfg",  
"version" : {  
"number" : "5.1.2",  
"build\_hash" : "c8c4c16",  
"build\_date" : "2017-01-11T20:18:39.146Z",  
"build\_snapshot" : false,  
"lucene\_version" : "6.3.0"  
},  
"tagline" : "You Know, for Search"  
}

i have 5.1.2 version of ES but i'm still getting the same error.

This version of Kibana requires Elasticsearch ^2.3.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v5.1.2 @ undefined (10.10.10.72)

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [January 19, 2017, 10:53am UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/14 "2017-01-19T10:53:57Z")

</div>

Please open a new thread for your issue.

---

<div class="post-metadata">

### Author: ![younes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/younes/32/17512_2.png) [@younes](https://discuss.elastic.co/u/younes)
#### Post date: [April 19, 2017, 10:47pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/15 "2017-04-19T22:47:12Z")

</div>

Hello,

I am getting the same error.

When I go to [http://localhost:9200/](http://localhost:9200/) , here's what I get :

```
{
  "name" : "K0r0l9M",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "-Uqd4hpPTpyvHBM9Y0hUlw",
  "version" : {
    "number" : "5.3.0",
    "build_hash" : "3adb13b",
    "build_date" : "2017-03-23T03:31:50.652Z",
    "build_snapshot" : false,
    "lucene_version" : "6.4.1"
  },
  "tagline" : "You Know, for Search"
}

```

Yet, when I go to Kibana, here's what it shows :

> plugin:elasticsearch : This version of Kibana requires Elasticsearch ^2.2.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v5.3.0 @ undefined (127.0.0.1)

I have both Elasticsearch and Kibana on v5.3, why am I getting this error on Kibana ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:32pm UTC](https://discuss.elastic.co/t/kibana-error-when-the-gui-popped-up/44193/16 "2017-07-06T13:32:12Z")

</div>


