# Kibana errors

**URL:** <https://discuss.elastic.co/t/kibana-errors/296229>\
**Category:** Kibana\
**Created:** [February 3, 2022, 8:58pm UTC](https://discuss.elastic.co/t/kibana-errors/296229 "2022-02-03T20:58:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![sukhsehaj](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@sukhsehaj](https://discuss.elastic.co/u/sukhsehaj)\
**Post date:** [February 3, 2022, 8:58pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/1 "2022-02-03T20:58:18Z")

</div>

Hello, can you plz help me troubleshoot these Kibana errors:

Feb 03 19:49:32 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) systemd[1]: Started Kibana.  
Feb 03 19:49:42 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) kibana[562]: {"type":"log","@timestamp":"2022-02-03T19:49:42Z","tags":["error","Elasticsearch","admin"],"pid":562,"message":"Request error, retrying\nHEAD [http://localhost:9200/](http://localhost:9200/) =\> connect EC... 127.0.0.1:9200"}  
Feb 03 19:49:43 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) kibana[562]: {"type":"log","@timestamp":"2022-02-03T19:49:43Z","tags":["status","plugin:Elasticsearch@5.6.13","error"],"pid":562,"state":"red","message":"Status changed from yellow to red - U...r Elasticsearch"}  
Feb 03 19:49:43 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) kibana[562]: {"type":"log","@timestamp":"2022-02-03T19:49:43Z","tags":["listening","info"],"pid":562,"message":"Server running at [http://localhost:5601](http://localhost:5601)"}  
Feb 03 19:49:43 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) kibana[562]: {"type":"log","@timestamp":"2022-02-03T19:49:43Z","tags":["status","ui settings","error"],"pid":562,"state":"red","message":"Status changed from uninitialized to red - Elasticsea...:"uninitialized"}  
Feb 03 19:50:43 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) kibana[562]: {"type":"log","@timestamp":"2022-02-03T19:50:43Z","tags":["status","plugin:Elasticsearch@5.6.13","error"],"pid":562,"state":"red","message":"Status changed from red to red - Serv...localhost:9200."}  
Hint: Some lines were ellipsized, use -l to show in full.

The Elasticsearch service is running fine

Cerebro is also not running, getting following error:

[root@prozokiba01 ~]# systemctl status cerebro  
● cerebro.service - Cerebro  
Loaded: loaded (/etc/systemd/system/cerebro.service; enabled; vendor preset: disabled)  
Active: active (running) since Thu 2022-02-03 19:49:32 UTC; 1h 10min ago  
Main PID: 560 (java)  
CGroup: /system.slice/cerebro.service  
└─560 java -Duser.dir=/opt/cerebro-0.8.1 -cp -jar /opt/cerebro-0.8.1/lib/cerebro.cerebro-0.8.1-launcher.jar

Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:716)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:259)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:291)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:634)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: Caused by: java.net.ConnectException: Connection refused  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:716)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:259)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:291)  
Feb 03 19:50:16 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) cerebro[560]: at play.shaded.ahc.io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:634)

[root@prozokiba01 ~]# curl localhost:9200/\_cluster/health?pretty  
{  
"error" : {  
"root\_cause" : [  
{  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
}  
],  
"type" : "master\_not\_discovered\_exception",  
"reason" : null  
},  
"status" : 503  
}

---

<div class="post-metadata">

**Author:** ![pindropviolence](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pindropviolence/32/101494_2.png) [@pindropviolence](https://discuss.elastic.co/u/pindropviolence)\
**Post date:** [February 3, 2022, 9:13pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/2 "2022-02-03T21:13:31Z")

</div>

Hi ,  
Can you please share the Elasticsearch.yml ?  
I think you will need to mention initial master nodes in your Elasticsearch.yml for cluster formation and bootstrapping.

```auto

cluster.initial_master_nodes:
   - master-node-1
   - master-node-2

```

Regards,  
Subhankar.

---

<div class="post-metadata">

**Author:** ![sukhsehaj](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@sukhsehaj](https://discuss.elastic.co/u/sukhsehaj)\
**Post date:** [February 3, 2022, 9:40pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/3 "2022-02-03T21:40:58Z")

</div>

Can you plz tell me where I can find this file?  
I know the ES service is running

root@prozokiba01 ~]# systemctl status Elasticsearch  
● Elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/Elasticsearch.service; enabled; vendor preset: disabled)  
Active: active (running) since Thu 2022-02-03 21:13:27 UTC; 26min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 996 ExecStartPre=/usr/share/Elasticsearch/bin/Elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 1008 (java)  
CGroup: /system.slice/Elasticsearch.service  
└─1008 /bin/java -Xms12g -Xmx12g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.perm...

Feb 03 21:13:27 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) systemd[1]: Starting Elasticsearch...  
Feb 03 21:13:27 [prozokiba01.pinpointtech.com](http://prozokiba01.pinpointtech.com) systemd[1]: Started Elasticsearch.

---

<div class="post-metadata">

**Author:** ![sukhsehaj](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@sukhsehaj](https://discuss.elastic.co/u/sukhsehaj)\
**Post date:** [February 3, 2022, 9:42pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/4 "2022-02-03T21:42:44Z")

</div>

I found it.

[root@prozokiba01 elasticsearch]# ls  
elasticsearch.yml elasticsearch.yml.bak elasticsearch.yml.rpmnew jvm.options log4j2.properties scripts  
[root@prozokiba01 elasticsearch]# vi elasticsearch.yml

# 

# 3. You want this node to be neither master nor data node, but

# to act as a "search load balancer" (fetching data from nodes,

# aggregating results, etc.)

# 

node.master: false  
node.data: false  
node.ingest: false

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

#path.data: /path/to/data

# 

# Path to log files:

# 

#path.logs: /path/to/logs

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

network.host: 0.0.0.0

# 

# Set a custom port for HTTP:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when new node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

discovery.zen.ping.unicast.hosts: ["10.100.40.68", "10.100.40.69", "10.100.40.70", "10.100.40.71", "10.100.40.72"]

# 

# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):

# 

#discovery.zen.minimum\_master\_nodes: 3

# 

# For more information, consult the zen discovery module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true

# 

# Testing recovery time

transport.tcp.connect\_timeout: 2s

---

<div class="post-metadata">

**Author:** ![sukhsehaj](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@sukhsehaj](https://discuss.elastic.co/u/sukhsehaj)\
**Post date:** [February 3, 2022, 10:20pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/5 "2022-02-03T22:20:46Z")

</div>

I found this elasticserach.ymal file as as well on one the data node

[root@labzostic02 elasticsearch]# vi elasticsearch.yml  
cluster.name: labstic

# 

# ------------------------------------ Node ------------------------------------

# 

# Use a descriptive name for the node:

# 

node.name: ${HOSTNAME}

# 

# Add custom attributes to the node:

# 

#node.attr.rack: r1

# 

# ----------------------------------- Paths ------------------------------------

# 

# Path to directory where to store the data (separate multiple locations by comma):

# 

path.data: /data/elasticsearch

# 

# Path to log files:

# 

#path.logs: /path/to/logs

# 

# ----------------------------------- Memory -----------------------------------

# 

# Lock the memory on startup:

# 

#bootstrap.memory\_lock: true

# 

# Make sure that the heap size is set to about half the memory available

# on the system and that the owner of the process is allowed to use this

# limit.

# 

# Elasticsearch performs poorly when the system is swapping the memory.

# 

# ---------------------------------- Network -----------------------------------

# 

# Set the bind address to a specific IP (IPv4 or IPv6):

# 

network.host: 0.0.0.0

# 

# Set a custom port for HTTP:

# 

#http.port: 9200

# 

# For more information, consult the network module documentation.

# 

# --------------------------------- Discovery ----------------------------------

# 

# Pass an initial list of hosts to perform discovery when new node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

discovery.zen.ping.unicast.hosts: ["10.100.80.111", "10.100.80.112"]

# 

# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):

# 

#discovery.zen.minimum\_master\_nodes: 3

# 

# For more information, consult the zen discovery module documentation.

# 

# ---------------------------------- Gateway -----------------------------------

# 

# Block initial recovery after a full cluster restart until N nodes are started:

# 

#gateway.recover\_after\_nodes: 3

# 

# For more information, consult the gateway module documentation.

# 

# ---------------------------------- Various -----------------------------------

# 

# Require explicit names when deleting indices:

# 

#action.destructive\_requires\_name: true

---

<div class="post-metadata">

**Author:** ![pindropviolence](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pindropviolence/32/101494_2.png) [@pindropviolence](https://discuss.elastic.co/u/pindropviolence)\
**Post date:** [February 4, 2022, 5:21pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/6 "2022-02-04T17:21:01Z")

</div>

Hi ,

Please format the yaml code , kindly read the standards for the forum.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 4, 2022, 5:21pm UTC](https://discuss.elastic.co/t/kibana-errors/296229/7 "2022-03-04T17:21:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
