# Kibana export issues (xpack.reporting.encryptionKey, timeout and data too large)

**URL:** <https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408>\
**Category:** Kibana\
**Created:** [March 16, 2021, 6:10pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408 "2021-03-16T18:10:46Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Post date:** [March 16, 2021, 6:10pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/1 "2021-03-16T18:10:46Z")

</div>

I have a three node cluster running in my homelab. It is a virtualised environment (ESXi) with Ubuntu server OS (LTS) & two nodes being data nodes & the third one being a voting only node. **Both the data nodes run a Kibana instance.** Underlying hardware is SSDs with segregation for OS disk and elasticsearch log storage disk. I usually fail to have logs being exported with two prominent errors:

1. **Error: Failed to decrypt report job data. Please ensure that xpack.reporting.encryptionKey is set and re-generate this report. Error: Unsupported state or unable to authenticate data**  
A. I only get this error when both the Kibana instances are running. If I manually stop (service kibana stop) Kibana on one of the VMs, I am able to export logs successfully.  
B. I found configuration inconsistencies between the Kibana instances. I've fixed this and restarted the services.  
C. None of the Kibana instances have xpack.reporting.encrpyitonKey set. I am unaware as to what this should be. **Should it be same as - xpack.encryptedSavedObjects.encryptionKey?**

2. **I've set xpack.reporting.csv.maxSizeBytes: 100mb, yet most of the reports time out or get error "data too large" - What is the best way to overcome this?**  
A. I'm a student and I have been collecting data for over a year. The indice size is over 1 TB. I need to export some of this data for my rerpoting. Without export entire year of collection may go to waste.

Thank you!

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [March 17, 2021, 1:25am UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/2 "2021-03-17T01:25:15Z")

</div>

> [@parthmaniar](#):
>
> - C. None of the Kibana instances have xpack.reporting.encrpyitonKey set. I am unaware as to what this should be. **Should it be same as - xpack.encryptedSavedObjects.encryptionKey?**

This setting is explained in the documentation: [Reporting settings in Kibana | Kibana Guide [8.11] | Elastic](https://www.elastic.co/guide/en/kibana/current/reporting-settings-kb.html#general-reporting-settings)

An example similar to yours is explained further in the documentation: [https://www.elastic.co/guide/en/kibana/current/configuring-reporting.html#encryption-keys](https://www.elastic.co/guide/en/kibana/current/configuring-reporting.html#encryption-keys)

You can use any alphanumeric, at least 32 characters long text string as the encryption key. When you have multiple instances of Kibana, the encryption key should be the same on every instance, as they split the workload in the reporting queue across any instance that is available. Without an encryption key in the settings, a random encryption key is generated at startup time, and it isn't going to be the same on every instance.

> [@parthmaniar](#):
>
> **I've set xpack.reporting.csv.maxSizeBytes: 100mb, yet most of the reports time out or get error "data too large" - What is the best way to overcome this?**

It sounds like you have a backup use case, not a reporting use case. You should look into Elasticsearch snapshots so that you can back up your data: [Snapshot and restore | Elasticsearch Guide [7.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.11/snapshot-restore.html)

BTW the "data too large" error is most likely coming from Elasticsearch or a proxy somewhere in your stack - that is not an error type that Kibana sends.

---

<div class="post-metadata">

**Author:** ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Post date:** [March 19, 2021, 1:34pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/3 "2021-03-19T13:34:03Z")

</div>

Thank you very much for this. Let me check and update.

> BTW the "data too large" error is most likely coming from Elasticsearch or a proxy somewhere in your stack - that is not an error type that Kibana sends.

I don't have a proxy between source and accessing Elasticsearch. I either access via Kibana (URL) or via postman (API calls)

I've uploaded a printscreen, please let me know if it helps.

 ![elk_entity_too_large](https://us1.discourse-cdn.com/elastic/original/3X/a/8/a8f7efddf53e989cc99d588c712ed9f210f33827.png)

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [March 22, 2021, 5:46pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/4 "2021-03-22T17:46:17Z")

</div>

If you don't have a proxy, then the "Request Entity Too Large" error is coming from Elasticsearch.

Check the `http.max_content_length` setting on the ES nodes: [HTTP | Elasticsearch Reference [7.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-http.html#_http_settings)

---

<div class="post-metadata">

**Author:** ![parthmaniar](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@parthmaniar](https://discuss.elastic.co/u/parthmaniar)\
**Post date:** [April 11, 2021, 2:30pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/5 "2021-04-11T14:30:07Z")

</div>

Thank you very much. This worked perfectly.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 9, 2021, 2:30pm UTC](https://discuss.elastic.co/t/kibana-export-issues-xpack-reporting-encryptionkey-timeout-and-data-too-large/267408/6 "2021-05-09T14:30:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
