# Kibana failed to connect to ElasticSearch with error Request Timeout after 3000ms

**URL:** <https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970>\
**Category:** Kibana\
**Created:** [July 27, 2018, 3:51pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970 "2018-07-27T15:51:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![kkr78](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkr78/32/33806_2.png) [@kkr78](https://discuss.elastic.co/u/kkr78)\
**Post date:** [July 27, 2018, 3:51pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970/1 "2018-07-27T15:51:59Z")

</div>

1. Elastic Search 6.3.2

Installed the opensource version of Elastic Search Cluster in AWS. Its configured to reach via domain. No Username and password configured. The setup has been validate using /\_cat/health and can confirm its working from the browser as well as from Kibana docker container (see below for more explanation)

elasticsearch.yml file

cluster.name: "elasticsearch"  
bootstrap.memory\_lock: false  
network.host: 0.0.0.0  
network.publish\_host: _ec2:privateIp_  
transport.publish\_host: _ec2:privateIp_  
discovery.zen.hosts\_provider: ec2  
discovery.ec2.tag.ElasticSearch: esnode  
discovery.ec2.endpoint: ec2.${REGION}.amazonaws.com  
s3.client.default.endpoint: s3.${REGION}.amazonaws.com  
cloud.node.auto\_attributes: true  
cluster.routing.allocation.awareness.attributes: aws\_availability\_zone  
node.master: ${IS\_MASTER:true}  
node.data: ${IS\_DATA:true}  
node.ingest: ${IS\_INGEST:true}

1. Kibana 6.3.2

Started the Kibana docker container locally by pointing to the elastic search domain configured above. I logged into the container and validated it is able to reach the elastic search (using curl -XGET). For some reason, I see error "Request Timeout after 3000ms" in the log and Kibana UI displays the same message next to plugin:elasticsearch@6.3.2. Am doing anything wrong? Do I need to configure the username and password?

docker run -p 5601:5601 -e ELASTICSEARCH\_URL=http://xxx.xxx.xxx.com/ kibana-docker:latest

{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["status","plugin:kibana@6.3.2","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["status","plugin:elasticsearch@6.3.2","info"],"pid":1,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["status","plugin:timelion@6.3.2","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["status","plugin:console@6.3.2","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["status","plugin:metrics@6.3.2","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}  
{"type":"log","@timestamp":"2018-07-27T14:39:05Z","tags":["listening","info"],"pid":1,"message":"Server running at [http://0.0.0.0:5601](http://0.0.0.0:5601)"}  
{"type":"log","@timestamp":"2018-07-27T14:39:08Z","tags":["status","plugin:elasticsearch@6.3.2","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Request Timeout after 3000ms","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

kibana.yml

server.host: '0.0.0.0'  
server.port: 5601  
elasticsearch.url : ${ELASTICSEARCH\_URL}

---

<div class="post-metadata">

**Author:** ![kkr78](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkr78/32/33806_2.png) [@kkr78](https://discuss.elastic.co/u/kkr78)\
**Post date:** [July 27, 2018, 4:06pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970/2 "2018-07-27T16:06:43Z")

</div>

I found the problem. I need to explicitly pass the port number in the URL. The same issue discussed in the below thread.

> [@\[ES 6.2.4\] - Request Timeout after 3000ms](https://discuss.elastic.co/t/es-6-2-4-request-timeout-after-3000ms/132302/3):
>
> Ping resolves the name of the service as expected from Kibana: bash-4.2$ ping elasticsearch-logging PING elasticsearch-logging.latest.svc.cluster.local (100.68.201.39) 56(84) bytes of data. Logs from Kibana when initializing (verbose mode): .... {"type":"log","@timestamp":"2018-05-17T15:23:56Z","tags":["status","plugin:console@6.2.4","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"lo…

Please close the thread.

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [July 30, 2018, 4:20pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970/3 "2018-07-30T16:20:27Z")

</div>

Hey @kkr78, I'm glad to hear you were able to solve your issue, and thanks for sharing your solution here for others.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 27, 2018, 4:20pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970/4 "2018-08-27T16:20:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
