# Kibana failed to connect to ElasticSearch with error Request Timeout after 3000ms

**URL:** <https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970>\
**Category:** Kibana\
**Created:** [July 27, 2018, 3:51pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970 "2018-07-27T15:51:59Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![kkr78](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kkr78/32/33806_2.png) [@kkr78](https://discuss.elastic.co/u/kkr78)\
**Post date:** [July 27, 2018, 4:06pm UTC](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970/2 "2018-07-27T16:06:43Z")

</div>

I found the problem. I need to explicitly pass the port number in the URL. The same issue discussed in the below thread.

> [@\[ES 6.2.4\] - Request Timeout after 3000ms](https://discuss.elastic.co/t/es-6-2-4-request-timeout-after-3000ms/132302/3):
>
> Ping resolves the name of the service as expected from Kibana: bash-4.2$ ping elasticsearch-logging PING elasticsearch-logging.latest.svc.cluster.local (100.68.201.39) 56(84) bytes of data. Logs from Kibana when initializing (verbose mode): .... {"type":"log","@timestamp":"2018-05-17T15:23:56Z","tags":["status","plugin:console@6.2.4","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"lo…

Please close the thread.

---

_[View the full topic](https://discuss.elastic.co/t/kibana-failed-to-connect-to-elasticsearch-with-error-request-timeout-after-3000ms/141970)._
