# Kibana Failed to parse value 4.0 for setting node.processors must be = 1

**URL:** https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894
**Category:** Kibana
**Tags:** elastic-stack-monitoring, docker
**Created:** [November 24, 2023, 4:09am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894 "2023-11-24T04:09:11Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![VijayIQA](https://avatars.discourse-cdn.com/v4/letter/v/e19b73/32.png) [@VijayIQA](https://discuss.elastic.co/u/VijayIQA)
#### Post date: [November 24, 2023, 4:09am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/1 "2023-11-24T04:09:11Z")

</div>

Hi Team,

Unable to start Kibana throwing an error as

`kibana Failed to parse value 4.0 for setting node.processors must be = 1)`

Elasticsearch cluster running on docker container.

```auto
Kibana version: 8.8.1
Elasticsearch version: 8.8.1
nodes: 2 (one master and data node)

```

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [December 1, 2023, 9:22pm UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/2 "2023-12-01T21:22:25Z")

</div>

Can you check your `node.processors` setting? It seems to be invalid.

> **[Thread pools | Elasticsearch Guide \[8.11\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-threadpool.html#node.processors)**

---

<div class="post-metadata">

### Author: ![VijayIQA](https://avatars.discourse-cdn.com/v4/letter/v/e19b73/32.png) [@VijayIQA](https://discuss.elastic.co/u/VijayIQA)
#### Post date: [December 4, 2023, 3:48am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/3 "2023-12-04T03:48:31Z")

</div>

hey @tsullivan thank you. How to update that setting using API.

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [December 5, 2023, 3:46pm UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/4 "2023-12-05T15:46:06Z")

</div>

Hi Vijay, it doesn't look possible to update `node.processors` using an API. According to the documentation:

> Thread pool settings are [static](https://www.elastic.co/guide/en/elasticsearch/reference/current/settings.html#static-cluster-setting) and can be changed by editing `elasticsearch.yml`

---

<div class="post-metadata">

### Author: ![VijayIQA](https://avatars.discourse-cdn.com/v4/letter/v/e19b73/32.png) [@VijayIQA](https://discuss.elastic.co/u/VijayIQA)
#### Post date: [December 6, 2023, 3:35am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/5 "2023-12-06T03:35:36Z")

</div>

Yup, @tsullivan that's what I am looking for I want to update that using API due to My elastic servers running as containers after updating elasticsearh.yml file need to restart containers after restarting the elastic servers not working properly due to it troughing cluster not healthy unable to determine cluster health and data node saying this node already part of another cluster and unable to up that data node.

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [December 6, 2023, 5:43pm UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/6 "2023-12-06T17:43:03Z")

</div>

You should check out the documentation of how to restart an Elasticsearch cluster: [Full-cluster restart and rolling restart | Elasticsearch Guide [8.11] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/restart-cluster.html)

This will be the only option since there is no API or way of dynamically changing the setting you want to change.

---

<div class="post-metadata">

### Author: ![VijayIQA](https://avatars.discourse-cdn.com/v4/letter/v/e19b73/32.png) [@VijayIQA](https://discuss.elastic.co/u/VijayIQA)
#### Post date: [December 7, 2023, 3:19am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/7 "2023-12-07T03:19:29Z")

</div>

Thanks @tsullivan I will try that.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 4, 2024, 3:20am UTC](https://discuss.elastic.co/t/kibana-failed-to-parse-value-4-0-for-setting-node-processors-must-be-1/347894/8 "2024-01-04T03:20:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
