# Kibana failing to install on centos6 or upgrading to kibana-7.11.1-1.x86\_64

**URL:** <https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110>\
**Category:** Kibana\
**Created:** [February 22, 2021, 6:47pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110 "2021-02-22T18:47:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bjen\_Shah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjen_shah/32/46250_2.png) [@Bjen\_Shah](https://discuss.elastic.co/u/Bjen_Shah)\
**Post date:** [February 22, 2021, 6:47pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110/1 "2021-02-22T18:47:48Z")

</div>

While I try to install on centos 7 is fine but on centos 6 I get all of these errors

` /usr/share/kibana/bin/../node/bin/node: /lib64/libc.so.6: version`GLIBC\_2.16' not found (required by /usr/share/kibana/bin/../node/bin/node)  
/usr/share/kibana/bin/../node/bin/node: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by /usr/share/kibana/bin/../node/bin/node) /usr/share/kibana/bin/../node/bin/node: /lib64/libc.so.6: version `GLIBC\_2.14' not found (required by /usr/share/kibana/bin/../node/bin/node)  
/usr/share/kibana/bin/../node/bin/node: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/share/kibana/bin/../node/bin/node) /usr/share/kibana/bin/../node/bin/node: /usr/lib64/libstdc++.so.6: version `GLIBCXX\_3.4.18' not found (required by /usr/share/kibana/bin/../node/bin/node)  
/usr/share/kibana/bin/../node/bin/node: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by /usr/share/kibana/bin/../node/bin/node) /usr/share/kibana/bin/../node/bin/node: /usr/lib64/libstdc++.so.6: version `GLIBCXX\_3.4.15' not found (required by /usr/share/kibana/bin/../node/bin/node)  
chown: cannot access `/etc/kibana/kibana.keystore': No such file or directory chmod: cannot access `/etc/kibana/kibana.keystore': No such file or directory  
md5sum: /etc/kibana/kibana.keystore: No such file or directory  
warning: %posttrans(kibana-7.11.1-1.x86\_64) scriptlet failed, exit status 1  
`

when I start I get errors: as

chroot: cannot change root directory to : No such file or directory  
chroot: cannot change root directory to : No such file or directory

Any Suggestion How to fix this issue.

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [February 22, 2021, 6:54pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110/2 "2021-02-22T18:54:59Z")

</div>

Hi,

According to the docs Kibana 7.x requires CentOS 7: [Elastic Support Matrix | Elasticsearch](https://www.elastic.co/de/support/matrix)

You can try upgrading the libraries manually but there are no guarantees that this will work.

Best regards  
Wolfram

---

<div class="post-metadata">

**Author:** ![Bjen\_Shah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjen_shah/32/46250_2.png) [@Bjen\_Shah](https://discuss.elastic.co/u/Bjen_Shah)\
**Post date:** [February 22, 2021, 7:05pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110/3 "2021-02-22T19:05:23Z")

</div>

I wonder how 7.10 was working just fine though.

---

<div class="post-metadata">

**Author:** ![Wolfram\_Haussig](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wolfram_haussig/32/70528_2.png) [@Wolfram\_Haussig](https://discuss.elastic.co/u/Wolfram_Haussig)\
**Post date:** [February 22, 2021, 7:18pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110/4 "2021-02-22T19:18:19Z")

</div>

There is a difference between working and supported but I guess the root cause is the change from Node.js 12 to 14: [Upgrade Node.js to version 14 by watson · Pull Request #83425 · elastic/kibana · GitHub](https://github.com/elastic/kibana/pull/83425)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 22, 2021, 7:19pm UTC](https://discuss.elastic.co/t/kibana-failing-to-install-on-centos6-or-upgrading-to-kibana-7-11-1-1-x86-64/265110/5 "2021-03-22T19:19:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
