# Kibana Fails due to Depreciation Warning

**URL:** <https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413>\
**Category:** Kibana\
**Created:** [February 16, 2021, 10:58am UTC](https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413 "2021-02-16T10:58:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gosborne](https://avatars.discourse-cdn.com/v4/letter/g/8c91f0/32.png) [@Gosborne](https://discuss.elastic.co/u/Gosborne)\
**Post date:** [February 16, 2021, 10:58am UTC](https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413/1 "2021-02-16T10:58:20Z")

</div>

I have installed kibana following the elastic guide and configured it to point to my two elastic node via elasticsearch.hosts: ["[https://xx.xx.xx.xx:9200](https://xx.xx.xx.xx:9200)","[https://xx.xx.xx.xx:9200](https://xx.xx.xx.xx:9200)"]. The only other settings i've changed are the server.host variable to the IP of the host and the elastic username and password to the kibana\_system user.

However when starting i get this error, but unsure how to fix it:  
` Feb 16 10:48:14 kibana[29468]: DeprecationWarning: Setting the TLS ServerName to an IP address is not permitted by RFC 6066. This will be ignored in a future version. Feb 16 10:48:14 kibana[29468]: at Object.connect (_tls_wrap.js:1619:15) Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createConnection (https.js:129:22) Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createSocket (/usr/share/kibana/node_modules/agentkeepalive/lib/_http_agent.js:26 5:26) Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createSocket (/usr/share/kibana/node_modules/agentkeepalive/lib/agent.js:77:11) Feb 16 10:48:14 kibana[29468]: at HttpsAgent.addRequest (/usr/share/kibana/node_modules/agentkeepalive/lib/_http_agent.js:239: 10) Feb 16 10:48:14 kibana[29468]: at new ClientRequest (_http_client.js:306:16) Feb 16 10:48:14 kibana[29468]: at Object.request (https.js:313:10) Feb 16 10:48:14 kibana[29468]: at Object.request (/usr/share/kibana/node_modules/agent-base/patch-core.js:25:22) Feb 16 10:48:14 kibana[29468]: at HttpConnector.request (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http. js:182:23) Feb 16 10:48:14 kibana[29468]: at sendReqWithConnection (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:263 :35) Feb 16 10:48:14 kibana[29468]: at Object.utils.applyArgs (/usr/share/kibana/node_modules/elasticsearch/src/lib/utils.js:188:19 ) Feb 16 10:48:14 kibana[29468]: at wrapper (/usr/share/kibana/node_modules/lodash/lodash.js:5213:19) Feb 16 10:48:14 kibana[29468]: at processTicksAndRejections (internal/process/task_queues.js:75:11) Feb 16 10:48:14 kibana[29468]: at runNextTicks (internal/process/task_queues.js:62:3) Feb 16 10:48:14 kibana[29468]: at processTimers (internal/timers.js:494:9) Feb 16 10:48:14 kibana[29468]: Terminating process... Feb 16 10:48:14 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE Feb 16 10:48:14 systemd[1]: kibana.service: Failed with result 'exit-code'. Feb 16 10:48:17 systemd[1]: kibana.service: Service hold-off time over, scheduling restart. Feb 16 10:48:17 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3. Feb 16 10:48:17 systemd[1]: Stopped Kibana. Feb 16 10:48:17 systemd[1]: kibana.service: Start request repeated too quickly. Feb 16 10:48:17 systemd[1]: kibana.service: Failed with result 'exit-code'. Feb 16 10:48:17 systemd[1]: Failed to start Kibana. `

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [February 17, 2021, 8:58pm UTC](https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413/2 "2021-02-17T20:58:27Z")

</div>

> [@Gosborne](#):
>
> kibana[29468]: DeprecationWarning: Setting the TLS ServerName to an IP address is not permitted by RFC 6066.

As a potential workaround this could work:  
`NODE_OPTIONS="--no-warnings" yarn start --run-examples`

cc @jportner / @Larry_Gregory any inputs here?

---

<div class="post-metadata">

**Author:** ![jportner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jportner/32/75692_2.png) [@jportner](https://discuss.elastic.co/u/jportner)\
**Post date:** [February 17, 2021, 9:47pm UTC](https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413/3 "2021-02-17T21:47:15Z")

</div>

> [@rashmi](#):
>
> As a potential workaround this could work:  
> `NODE_OPTIONS="--no-warnings" yarn start --run-examples`

That example is for running Kibana from source. It's close, but I don't think it will work without an export (read more below).

@Gosborne I reformatted the logs that you provided:

```auto
Feb 16 10:48:14 kibana[29468]: DeprecationWarning: Setting the TLS ServerName to an IP address is not permitted by RFC 6066. This will be ignored in a future version.
Feb 16 10:48:14 kibana[29468]: at Object.connect (_tls_wrap.js:1619:15)
Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createConnection (https.js:129:22)
Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createSocket (/usr/share/kibana/node_modules/agentkeepalive/lib/_http_agent.js:26 5:26)
Feb 16 10:48:14 kibana[29468]: at HttpsAgent.createSocket (/usr/share/kibana/node_modules/agentkeepalive/lib/agent.js:77:11)
Feb 16 10:48:14 kibana[29468]: at HttpsAgent.addRequest (/usr/share/kibana/node_modules/agentkeepalive/lib/_http_agent.js:239: 10)
Feb 16 10:48:14 kibana[29468]: at new ClientRequest (_http_client.js:306:16)
Feb 16 10:48:14 kibana[29468]: at Object.request (https.js:313:10)
Feb 16 10:48:14 kibana[29468]: at Object.request (/usr/share/kibana/node_modules/agent-base/patch-core.js:25:22)
Feb 16 10:48:14 kibana[29468]: at HttpConnector.request (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http. js:182:23)
Feb 16 10:48:14 kibana[29468]: at sendReqWithConnection (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:263 :35)
Feb 16 10:48:14 kibana[29468]: at Object.utils.applyArgs (/usr/share/kibana/node_modules/elasticsearch/src/lib/utils.js:188:19 )
Feb 16 10:48:14 kibana[29468]: at wrapper (/usr/share/kibana/node_modules/lodash/lodash.js:5213:19)
Feb 16 10:48:14 kibana[29468]: at processTicksAndRejections (internal/process/task_queues.js:75:11)
Feb 16 10:48:14 kibana[29468]: at runNextTicks (internal/process/task_queues.js:62:3)
Feb 16 10:48:14 kibana[29468]: at processTimers (internal/timers.js:494:9)
Feb 16 10:48:14 kibana[29468]: Terminating process...
Feb 16 10:48:14 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Feb 16 10:48:14 systemd[1]: kibana.service: Failed with result 'exit-code'.
Feb 16 10:48:17 systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Feb 16 10:48:17 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.
Feb 16 10:48:17 systemd[1]: Stopped Kibana.
Feb 16 10:48:17 systemd[1]: kibana.service: Start request repeated too quickly.
Feb 16 10:48:17 systemd[1]: kibana.service: Failed with result 'exit-code'.
Feb 16 10:48:17 systemd[1]: Failed to start Kibana.

```

This looks fairly straightforward. Starting in Node 12+ (which we upgraded Kibana to use in the Kibana 7.11 release), Node will emit this warning when you try to establish a TLS connection using an IP address. You should use a hostname or a fully-qualified domain name (FQDN) instead. But this isn't something you'll have to worry about in production for a long time.

As to why this is causing a start failure: are you running Kibana from source? If you are doing so and running it in dev mode ( **not recommended for production** ), it is [configured throw an error when encountering a Node deprecation warning](https://github.com/elastic/kibana/pull/51431).

I recommend using the default distribution of Kibana which you can download [here](https://www.elastic.co/downloads/kibana), but if you need to get this working in dev mode for some reason, you can use this command to run Kibana from source:

```auto
export NODE_OPTIONS="--no-warnings" && yarn start

```

The `export` directive is needed to make this environment variable available to the Node process when running it with `yarn start`.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 17, 2021, 9:47pm UTC](https://discuss.elastic.co/t/kibana-fails-due-to-depreciation-warning/264413/4 "2021-03-17T21:47:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
