# Kibana fails in talking to Tribe Node

**URL:** <https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861>\
**Category:** Elasticsearch\
**Created:** [March 24, 2015, 3:25pm UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861 "2015-03-24T15:25:16Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Abigail](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@Abigail](https://discuss.elastic.co/u/Abigail)\
**Post date:** [March 24, 2015, 3:25pm UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861/1 "2015-03-24T15:25:16Z")

</div>

Hi,

I have two ElasticSearch clusters and one tribe node for searching across  
the two clusters. And there is a kibana 4 connects to the tribe node. What  
I have done are:

1. Created .kibana and kibana-int manually in the cluster
2. Launch kibana
3. Got to the screen "Configure an index pattern", hit the create button

Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"  
error.

It seems a known issue. I also tried adding "tribe.blocks.write: false"  
into tribe node config file without any luck. I am sure saving dash board  
will throw the same error. Can anyone help to confirm that if Kibana can  
talk to tribe node? And anyone figure it out how to do it?

Thank you!  
Abigail

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c0b2a218-572e-4e1f-929e-09852b847185%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c0b2a218-572e-4e1f-929e-09852b847185%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ramdev\_Wudali](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ramdev_wudali/32/7894_2.png) [@Ramdev\_Wudali](https://discuss.elastic.co/u/Ramdev_Wudali)\
**Post date:** [May 13, 2015, 8:58pm UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861/2 "2015-05-13T20:58:55Z")

</div>

Hi Abigail;  
Did you get any resolution on this issue ? I am in a similar situation  
and would like to know if anything came of your investigations.

Thanks

Ramdev

On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:

> Hi,
> 
> I have two Elasticsearch clusters and one tribe node for searching across  
> the two clusters. And there is a kibana 4 connects to the tribe node. What  
> I have done are:
> 
> 1. Created .kibana and kibana-int manually in the cluster
> 2. Launch kibana
> 3. Got to the screen "Configure an index pattern", hit the create button
> 
> Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"  
> error.
> 
> It seems a known issue. I also tried adding "tribe.blocks.write: false"  
> into tribe node config file without any luck. I am sure saving dash board  
> will throw the same error. Can anyone help to confirm that if Kibana can  
> talk to tribe node? And anyone figure it out how to do it?
> 
> Thank you!  
> Abigail

## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Abigail](https://avatars.discourse-cdn.com/v4/letter/a/a587f6/32.png) [@Abigail](https://discuss.elastic.co/u/Abigail)\
**Post date:** [May 14, 2015, 3:07pm UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861/3 "2015-05-14T15:07:35Z")

</div>

Hey Ramdev,

It works for us now. It has been a while. I think I did create .kibana  
index manually and changed kibana to talk to a regular node first instead  
of tribe node, after setting up, pointed kibana back to tribe node.

Hope this work for you.  
Abigail

On Wednesday, May 13, 2015, Ramdev Wudali [agastya71@gmail.com](mailto:agastya71@gmail.com) wrote:

> Hi Abigail;  
> Did you get any resolution on this issue ? I am in a similar situation  
> and would like to know if anything came of your investigations.
> 
> Thanks
> 
> Ramdev
> 
> On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:
> 
> > Hi,
> > 
> > I have two Elasticsearch clusters and one tribe node for searching across  
> > the two clusters. And there is a kibana 4 connects to the tribe node. What  
> > I have done are:
> > 
> > 1. Created .kibana and kibana-int manually in the cluster
> > 2. Launch kibana
> > 3. Got to the screen "Configure an index pattern", hit the create button
> > 
> > Kibana loads then throws "MasterNotDiscoveredException[waited for [30s]]"  
> > error.
> > 
> > It seems a known issue. I also tried adding "tribe.blocks.write: false"  
> > into tribe node config file without any luck. I am sure saving dash board  
> > will throw the same error. Can anyone help to confirm that if Kibana can  
> > talk to tribe node? And anyone figure it out how to do it?
> > 
> > Thank you!  
> > Abigail
> 
> ## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)
> 
> You received this message because you are subscribed to a topic in the  
> Google Groups "elasticsearch" group.  
> To unsubscribe from this topic, visit  
> [https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe](https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe).  
> To unsubscribe from this group and all its topics, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com)  
> \<javascript:\_e(%7B%7D,'cvml','elasticsearch%2Bunsubscribe@googlegroups.com');\>  
> .  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF\_nTBzejY3hg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ramdev\_Wudali](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ramdev_wudali/32/7894_2.png) [@Ramdev\_Wudali](https://discuss.elastic.co/u/Ramdev_Wudali)\
**Post date:** [May 14, 2015, 3:11pm UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861/4 "2015-05-14T15:11:41Z")

</div>

Hi Abigail:  
yeah I had to do the same. I had to create the .kibana index, as well  
as the mappings for visualization,dashboard,index-pattern and search  
(refer to [Kibana 4 with tribe node MasterNotDiscoveredException · Issue #3114 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/3114) ) and the gist :  
[Kibana mapping · GitHub](https://gist.github.com/rjosephwright/4ed7d4d25f89f83875db) .  
Also direct all write traffic to one ES Custer through some judicial use of  
the tribe.blocks directive in the configuration.

to get it working. Its a rather hacky workaround to get it working  
right.(either that or the implementation seems to be a bit thrown together.

Thanks for the response.

Cheers

Ramdev

On Thu, 14 May 2015 at 10:07 naye923 [naye923@gmail.com](mailto:naye923@gmail.com) wrote:

> Hey Ramdev,
> 
> It works for us now. It has been a while. I think I did create .kibana  
> index manually and changed kibana to talk to a regular node first instead  
> of tribe node, after setting up, pointed kibana back to tribe node.
> 
> Hope this work for you.  
> Abigail
> 
> On Wednesday, May 13, 2015, Ramdev Wudali [agastya71@gmail.com](mailto:agastya71@gmail.com) wrote:
> 
> > Hi Abigail;  
> > Did you get any resolution on this issue ? I am in a similar  
> > situation and would like to know if anything came of your investigations.
> > 
> > Thanks
> > 
> > Ramdev
> > 
> > On Tuesday, 24 March 2015 10:25:16 UTC-5, Abigail wrote:
> > 
> > > Hi,
> > > 
> > > I have two Elasticsearch clusters and one tribe node for searching  
> > > across the two clusters. And there is a kibana 4 connects to the tribe  
> > > node. What I have done are:
> > > 
> > > 1. Created .kibana and kibana-int manually in the cluster
> > > 2. Launch kibana
> > > 3. Got to the screen "Configure an index pattern", hit the create button
> > > 
> > > Kibana loads then throws "MasterNotDiscoveredException[waited for  
> > > [30s]]" error.
> > > 
> > > It seems a known issue. I also tried adding "tribe.blocks.write: false"  
> > > into tribe node config file without any luck. I am sure saving dash board  
> > > will throw the same error. Can anyone help to confirm that if Kibana can  
> > > talk to tribe node? And anyone figure it out how to do it?
> > > 
> > > Thank you!  
> > > Abigail
> > 
> > ## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)
> > 
> > You received this message because you are subscribed to a topic in the  
> > Google Groups "elasticsearch" group.  
> > To unsubscribe from this topic, visit  
> > [https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe](https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe).  
> > To unsubscribe from this group and all its topics, send an email to  
> > [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/4595c475-9c22-49d4-8f8b-c4e1d65768b1%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> ## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)
> 
> You received this message because you are subscribed to a topic in the  
> Google Groups "elasticsearch" group.  
> To unsubscribe from this topic, visit  
> [https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe](https://groups.google.com/d/topic/elasticsearch/SsO3IBCz1U4/unsubscribe).  
> To unsubscribe from this group and all its topics, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF\_nTBzejY3hg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com)  
> [https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF\_nTBzejY3hg%40mail.gmail.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/CAJNTK5-4qcAAXkn%2BWQtUpZ%3DY9NJ8REwNcz38ReF_nTBzejY3hg%40mail.gmail.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

## -- Please update your bookmarks! We have moved to [https://discuss.elastic.co/](https://discuss.elastic.co/)

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gsBEVWEvBuXCBZcxbxY-0mtNcJ54SkEiD2wZ1VwREz0Q%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gsBEVWEvBuXCBZcxbxY-0mtNcJ54SkEiD2wZ1VwREz0Q%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:14am UTC](https://discuss.elastic.co/t/kibana-fails-in-talking-to-tribe-node/22861/5 "2017-07-06T00:14:02Z")

</div>


