# Kibana "Fails to load indices" when trying to set up an index pattern in Management tab

**URL:** https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964
**Category:** Kibana
**Created:** [March 26, 2019, 3:53pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964 "2019-03-26T15:53:19Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 26, 2019, 3:53pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/1 "2019-03-26T15:53:19Z")

</div>

Hey all, I recently upgraded my elastic stack to 6.6.2 from 5.6.x. I got everything running but when I load into Kibana's Management tab to create my index patterns it says "Failed to load indices". The strange thing is when I go to Management --\> Elasticsearch --\> Index Management, all of my indices are properly listed. Why would one tab of Kibana be able to see it fine but the other not? Thanks!

Setup info: Running on Windows 10 server. Elasticsearch installed with MSI as Local System Service, Kibana set up with NSSM as Local System Service. Created URL Rewrite rules for both in the IIS setup. Am able to properly communicate with both via the configured website.

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [March 26, 2019, 5:49pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/2 "2019-03-26T17:49:07Z")

</div>

@mattkime can you please grab this one?

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 27, 2019, 1:03pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/3 "2019-03-27T13:03:15Z")

</div>

@bhavyarm Did anyone get a chance to look at this? The upgrade is a bit time sensitive. Thanks!!

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [March 27, 2019, 1:10pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/4 "2019-03-27T13:10:49Z")

</div>

Where is IIS in the flow? Does it work if you exclude IIS?

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 27, 2019, 1:41pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/5 "2019-03-27T13:41:23Z")

</div>

@Christian_Dahlqvist After Installing Elasticsearch via MSI and Kibana via zip, I wrapped the folder location in a website with IIS. I then set up 2 URL rewrite rules:

The Kibana rule (applied to the Kibana install folder) is Pattern: (._), Rewrite URL: http://{server IP}:5601/{R:1}  
The Elasticsearch rule (applied to the Elasticsearch install folder) is Pattern: (._), Rewrite URL: [http://127.0.0.1:9200/{R:1}](http://127.0.0.1:9200/%7BR:1%7D)

This seems to work as I can access Kibana and write logs to Elasticsearch via the DNS entry our company created. In fact, as I stated in the first post, under Management --\> Elasticsearch --\> Index Management in Kibana it correctly shows all the log indices that have been written to Elasticsearch so that all seems to be working. It is only in the Management --\> Kibana --\> Create Index Pattern screen where I immediately get 2 pop up errors and see no indices:

"Failed to load remote clusters"  
"Failed to load indices"

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [March 27, 2019, 1:51pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/6 "2019-03-27T13:51:25Z")

</div>

Does Kibana connect to Elasticsearch via IIS? If so, does the behaviour change if you connect Kibana directly to Elasticsearch?

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 27, 2019, 1:53pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/7 "2019-03-27T13:53:21Z")

</div>

@Christian_Dahlqvist No, Im only using IIS as a wrapper so the outside word can communicate with it (URL Rewrite rules), pretty sure both of them are running in localhost as far as they are concerned.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [March 27, 2019, 2:36pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/8 "2019-03-27T14:36:24Z")

</div>

> [@ljh33txm](#):
>
> pretty sure both of them are running in localhost

Can you show us the kibana.yml file just to be sure?

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 27, 2019, 2:45pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/9 "2019-03-27T14:45:06Z")

</div>

@Christian_Dahlqvist I have most everything commented out except:

server.port: 5601  
server.basePath: "/custompath" #This is reflected in the IIS setup  
server.rewriteBasePath: false  
server.name: "TheServerName"

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [March 27, 2019, 2:57pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/10 "2019-03-27T14:57:31Z")

</div>

Can you go to the Console under Dev Tools in Kibana and run `GET /.kibana*/_settings`?

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [March 27, 2019, 2:59pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/11 "2019-03-27T14:59:57Z")

</div>

@Christian_Dahlqvist Sure thing, here it is:

{  
".kibana\_1" : {  
"settings" : {  
"index" : {  
"number\_of\_shards" : "1",  
"auto\_expand\_replicas" : "0-1",  
"provided\_name" : ".kibana\_1",  
"creation\_date" : "1553614167821",  
"number\_of\_replicas" : "0",  
"uuid" : "NSChLFobQ3CpDQNCEGxzXQ",  
"version" : {  
"created" : "6060299"  
}  
}  
}  
}  
}

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [April 2, 2019, 1:14pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/12 "2019-04-02T13:14:27Z")

</div>

@Christian_Dahlqvist, @bhavyarm Any updates on this? Need me to provide more info? Our logs have been down now for a week.

---

<div class="post-metadata">

### Author: ![mattkime](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattkime/32/43522_2.png) [@mattkime](https://discuss.elastic.co/u/mattkime)
#### Post date: [April 4, 2019, 7:43pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/13 "2019-04-04T19:43:06Z")

</div>

[ljh33txm](https://discuss.elastic.co/u/ljh33txm) -

If you pop open your browser's inspector, do you see a failed http request?  
Similarly, do you see an error in the Kibana logs?

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [April 5, 2019, 12:57pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/14 "2019-04-05T12:57:14Z")

</div>

@mattkime Not a web developer so bear with me, I think so?

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/9/89354723bf6633b44dada97aa08928523632659a.png)

---

<div class="post-metadata">

### Author: ![mattkime](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattkime/32/43522_2.png) [@mattkime](https://discuss.elastic.co/u/mattkime)
#### Post date: [April 9, 2019, 4:22pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/15 "2019-04-09T16:22:16Z")

</div>

@ljh33txm Yes, those are failed http requests. Do you see matching failures in the kibana logs? I wonder if the urls are being rewritten incorrectly and I'm curious if they're making it to kibana.

---

<div class="post-metadata">

### Author: ![m2web](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/m2web/32/43804_2.png) [@m2web](https://discuss.elastic.co/u/m2web)
#### Post date: [April 9, 2019, 6:36pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/16 "2019-04-09T18:36:35Z")

</div>

We were seeing the same thing with Kibana 6.7.0 on Windows 2016 Server. Looking at the Event Logs in Windows I noted the following:  
HttpException  
A potentially dangerous Request.Path value was detected from the client (_). at System.Web.HttpRequest.ValidateInputIfRequiredByConfig() at System.Web.HttpApplication.PipelineStepManager.ValidateHelper(HttpContext context) [http://OurURL/elasticsearch/](http://OurURL/elasticsearch/)_/\_search?ignore\_unavailable=true/elasticsearch/\*/\_search

The fix was to add the following to the IIS web.config:  
\<system.web\>  
\<httpRuntime requestPathInvalidCharacters="" / \>  
\</system.web\>

Stop and restart the web in IIS and we were good.

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [April 9, 2019, 6:59pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/17 "2019-04-09T18:59:18Z")

</div>

@m2web In the Elasticsearch or Kibana web.config? Thanks!

---

<div class="post-metadata">

### Author: ![ljh33txm](https://avatars.discourse-cdn.com/v4/letter/l/df705f/32.png) [@ljh33txm](https://discuss.elastic.co/u/ljh33txm)
#### Post date: [April 9, 2019, 7:11pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/18 "2019-04-09T19:11:56Z")

</div>

@m2web Actually, scratch that, got it to work in the Kibana web.config. Thank you so much!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 7, 2019, 7:11pm UTC](https://discuss.elastic.co/t/kibana-fails-to-load-indices-when-trying-to-set-up-an-index-pattern-in-management-tab/173964/19 "2019-05-07T19:11:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
