# Kibana fails to start after upgrade

**URL:** https://discuss.elastic.co/t/kibana-fails-to-start-after-upgrade/146438
**Category:** Kibana
**Created:** [August 29, 2018, 12:14am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-after-upgrade/146438 "2018-08-29T00:14:43Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![kernelpanic](https://avatars.discourse-cdn.com/v4/letter/k/c89c15/32.png) [@kernelpanic](https://discuss.elastic.co/u/kernelpanic)
#### Post date: [August 29, 2018, 12:14am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-after-upgrade/146438/1 "2018-08-29T00:14:43Z")

</div>

Hello all,

I've upgraded all our Elasticsearch cluster components from 6.2.4 to 6.3.2

The cluster itself seem fine but Kibana will not start; in the Kibana log  
it shows the following:

> {"type":"log","@timestamp":"2018-08-28T15:17:36Z","tags":["reporting","error"],"pid":76937,"message":"Failed  
> to install browser. See kibana logs for more details."}

When I enable verbose logging I don't get an error message, the last line  
just shows the following:

> {"type":"log","@timestamp":"2018-08-28T15:31:26Z","tags":["reporting","debug","exportTypes"],"pid":77142,"message":"Found  
> exportType at  
> /usr/local/www/kibana6/node\_modules/x-pack/plugins/reporting/export\_types/csv/server/index.js"}

I've tried removing and reinstalling Kibana and its dependencies but no joy.

Any help much appreciated.

---

<div class="post-metadata">

### Author: ![kernelpanic](https://avatars.discourse-cdn.com/v4/letter/k/c89c15/32.png) [@kernelpanic](https://discuss.elastic.co/u/kernelpanic)
#### Post date: [August 29, 2018, 12:41am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-after-upgrade/146438/2 "2018-08-29T00:41:16Z")

</div>

I should've mentioned I'm usin Elastic Stack on FreeBSD, it appears we have to disable the XPACK features to get Kibana to start, adding the following to kibana.yml did the trick:

```
xpack.apm.enabled: false
xpack.grokdebugger.enabled: false
xpack.searchprofiler.enabled: false
xpack.graph.enabled: false
xpack.ml.enabled: false
xpack.monitoring.enabled: false
xpack.reporting.enabled: false
xpack.security.enabled: false
```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 26, 2018, 12:41am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-after-upgrade/146438/3 "2018-09-26T00:41:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
