# Kibana fails to start with FATAL error

**URL:** <https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011>\
**Category:** Kibana\
**Created:** [May 28, 2019, 7:48am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011 "2019-05-28T07:48:13Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ishan\_deep](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ishan_deep/32/45690_2.png) [@Ishan\_deep](https://discuss.elastic.co/u/Ishan_deep)\
**Post date:** [May 28, 2019, 7:48am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/1 "2019-05-28T07:48:14Z")

</div>

kibana running in kubernetes pod fails to start with following error:

FATAL Error: "port", "service.port", and "service.host" settings were not applied. Check for spelling errors and ensure that expected plugins are installed.  
kibana May 28, 2019, 1:05:27 PM   
kibana May 28, 2019, 1:05:27 PM {"type":"log","@timestamp":"2019-05-28T07:35:27Z","tags":["fatal","root"],"pid":1,"message":"{ Error: "port", "service.port", and "service.host" settings were not applied. Check for spelling errors and ensure that expected plugins are installed.\n at KbnServer.exports.default (/usr/share/kibana/src/server/config/complete.js:88:17) code: 'InvalidConfig', processExitCode: 64 }"}

i haven't included these 3 settings in kibana.yml also!

---

<div class="post-metadata">

**Author:** ![Larry\_Gregory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/larry_gregory/32/34969_2.png) [@Larry\_Gregory](https://discuss.elastic.co/u/Larry_Gregory)\
**Post date:** [May 28, 2019, 11:29am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/2 "2019-05-28T11:29:41Z")

</div>

Hey @Ishan_deep,  
Can you check the environment variables being passed to Kibana? Kibana attempts to interpret those variables as settings, and may fail to start if it doesn't recognize something.

In your example, you might have variables called `PORT`, `SERVICE_PORT`, and `SERVICE_HOST` defined somewhere.

---

<div class="post-metadata">

**Author:** ![Ishan\_deep](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ishan_deep/32/45690_2.png) [@Ishan\_deep](https://discuss.elastic.co/u/Ishan_deep)\
**Post date:** [May 29, 2019, 3:25am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/3 "2019-05-29T03:25:02Z")

</div>

Hey @Larry_Gregory  
this is my deployment

apiVersion: v1  
kind: Service  
metadata:  
name: kibana  
annotations:  
[cloud.google.com/load-balancer-type:](http://cloud.google.com/load-balancer-type:) "Internal"  
labels:  
component: kibana  
spec:  
selector:  
component: kibana  
ports:

- name: http  
port: 80  
targetPort: 5601  
protocol: TCP  
type: LoadBalancer

* * *

## apiVersion: v1 kind: ConfigMap metadata: name: kibana-config data: kibana.yml: | --- server.name: kibana elasticsearch.url: [http://x.x.x.x:9200](http://x.x.x.x:9200) server.maxPayloadBytes: 2048576

apiVersion: apps/v1beta1  
kind: Deployment  
metadata:  
name: kibana  
labels:  
component: kibana  
spec:  
replicas: 1  
selector:  
matchLabels:  
component: kibana  
template:  
metadata:  
labels:  
component: kibana  
spec:  
containers:  
- name: kibana  
image: xxx/kibana-6.7:v4.0  
env:  
resources:  
limits:  
cpu: 4  
requests:  
cpu: 2  
ports:  
- containerPort: 5601  
name: http  
readinessProbe:  
httpGet:  
path: /api/status  
port: http  
initialDelaySeconds: 20  
timeoutSeconds: 5  
volumeMounts:  
- name: config  
mountPath: /usr/share/kibana/config  
readOnly: true  
volumes:  
- name: config  
configMap:  
name: kibana-config

---

<div class="post-metadata">

**Author:** ![Ishan\_deep](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ishan_deep/32/45690_2.png) [@Ishan\_deep](https://discuss.elastic.co/u/Ishan_deep)\
**Post date:** [May 29, 2019, 3:27am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/4 "2019-05-29T03:27:08Z")

</div>

also find my kibana image dockerfile

FROM node:10.15.2-alpine

LABEL maintainer "[https://github.com/blacktop](https://github.com/blacktop)"

ENV VERSION 6.7.1  
ENV DOWNLOAD\_URL [https://artifacts.elastic.co/downloads/kibana](https://artifacts.elastic.co/downloads/kibana)  
ENV TARBAL "{DOWNLOAD\_URL}/kibana-oss-{VERSION}-linux-x86\_64.tar.gz"  
ENV TARBALL\_ASC "{DOWNLOAD\_URL}/kibana-oss-{VERSION}-linux-x86\_64.tar.gz.asc"  
ENV TARBALL\_SHA "309c25a16d535b1c5f0853ea89b7b69b61e3472afdabdd6f60a86fabba4c76c034b620cbe3d7f988cc78d21e5ed058b4f97e4995d868876a55fcc30769822882"  
ENV GPG\_KEY "46095ACC8548582C1A2699A9D27D666CD88E42B4"

ENV PATH /usr/share/kibana/bin:$PATH

RUN apk add --no-cache bash su-exec  
RUN apk add --no-cache -t .build-deps wget ca-certificates gnupg openssl   
&& set -ex   
&& cd /tmp   
&& echo "===\> Install Kibana..."   
&& wget --progress=bar:force -O kibana.tar.gz "$TARBAL";   
if ["$TARBALL\_SHA"]; then   
echo "$TARBALL\_SHA \*kibana.tar.gz" | sha512sum -c -;   
fi;   
if ["$TARBALL\_ASC"]; then   
wget --progress=bar:force -O kibana.tar.gz.asc "TARBALL\_ASC"; \ export GNUPGHOME="(mktemp -d)";   
( gpg --keyserver [ha.pool.sks-keyservers.net](http://ha.pool.sks-keyservers.net) --recv-keys "$GPG\_KEY"   
|| gpg --keyserver pgp.mit.edu --recv-keys "$GPG\_KEY"   
|| gpg --keyserver [keyserver.pgp.com](http://keyserver.pgp.com) --recv-keys "$GPG\_KEY" );   
gpg --batch --verify kibana.tar.gz.asc kibana.tar.gz;   
rm -rf "$GNUPGHOME" kibana.tar.gz.asc || true;   
fi;   
tar -xf kibana.tar.gz   
&& ls -lah   
&& mv kibana-$VERSION-linux-x86\_64 /usr/share/kibana   
&& adduser -DH -s /sbin/nologin kibana \

# usr alpine nodejs and not bundled version

&& bundled='NODE="${DIR}/node/bin/node"'   
&& apline\_node='NODE="/usr/bin/node"'   
&& sed -i "s|$bundled|$apline\_node|g" /usr/share/kibana/bin/kibana-plugin   
&& sed -i "s|$bundled|$apline\_node|g" /usr/share/kibana/bin/kibana   
&& rm -rf /usr/share/kibana/node   
&& chown -R kibana:kibana /usr/share/kibana   
&& rm -rf /tmp/\*   
&& apk del --purge .build-deps

COPY config/kibana/kibana.yml /usr/share/kibana/config/kibana.yml  
COPY docker-entrypoint.sh /  
RUN chmod +x /docker-entrypoint.sh

WORKDIR /usr/share/kibana

EXPOSE 5601

ENTRYPOINT ["/docker-entrypoint.sh"]  
CMD ["kibana"]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 29, 2019, 6:18am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/5 "2019-05-29T06:18:46Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

---

<div class="post-metadata">

**Author:** ![Ishan\_deep](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ishan_deep/32/45690_2.png) [@Ishan\_deep](https://discuss.elastic.co/u/Ishan_deep)\
**Post date:** [May 29, 2019, 6:44am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/6 "2019-05-29T06:44:45Z")

</div>

understood @warkolm . will keep that in mind next time!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 26, 2019, 6:44am UTC](https://discuss.elastic.co/t/kibana-fails-to-start-with-fatal-error/183011/7 "2019-06-26T06:44:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
