# Kibana FATAL Error: \[elasticsearch.url\]: definition for this key is missing

**URL:** https://discuss.elastic.co/t/kibana-fatal-error-elasticsearch-url-definition-for-this-key-is-missing/190087
**Category:** Kibana
**Created:** [July 11, 2019, 6:27pm UTC](https://discuss.elastic.co/t/kibana-fatal-error-elasticsearch-url-definition-for-this-key-is-missing/190087 "2019-07-11T18:27:16Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ryan\_Downey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_downey/32/35987_2.png) [@Ryan\_Downey](https://discuss.elastic.co/u/Ryan_Downey)
#### Post date: [July 11, 2019, 6:27pm UTC](https://discuss.elastic.co/t/kibana-fatal-error-elasticsearch-url-definition-for-this-key-is-missing/190087/1 "2019-07-11T18:27:16Z")

</div>

Just upgraded a node from 6.8.1 to 7.2.0 and I'm getting the error message right after I start with journalctl that states

```auto
Jul 11 14:10:30 dch1092ql5app kibana[25880]: FATAL Error: [elasticsearch.url]: definition for this key is missing

```

After reading the error message it seemed like a pretty easy fix, just make sure that elasticsearch.url has been filled in. Yet when I add our elasticsearch url in Kibana starts and then stops with the same error message.

Yaml settings

```auto
# The URL of the Elasticsearch instance to use for all your queries.
#elasticsearch.url: "http://localhost:9200"
#elasticsearch.url: "https://abc.gov:9200"
elasticsearch.url: "http://abc.gov:9200"

```

---

<div class="post-metadata">

### Author: ![Ryan\_Downey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ryan_downey/32/35987_2.png) [@Ryan\_Downey](https://discuss.elastic.co/u/Ryan_Downey)
#### Post date: [July 11, 2019, 7:33pm UTC](https://discuss.elastic.co/t/kibana-fatal-error-elasticsearch-url-definition-for-this-key-is-missing/190087/2 "2019-07-11T19:33:20Z")

</div>

Problem solved. During the upgrade the new format of the kibana.yml was not installed. Either this was an installation problem or I just didn't read that I was supposed to do it. If you run into this issue check that your kibana yaml is correct, ie the appropriate version.

---

<div class="post-metadata">

### Author: ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)
#### Post date: [July 18, 2019, 10:03pm UTC](https://discuss.elastic.co/t/kibana-fatal-error-elasticsearch-url-definition-for-this-key-is-missing/190087/3 "2019-07-18T22:03:27Z")

</div>


