# Kibana Fleet Error message Old fleet indices cleanup failed: security\_exception

**URL:** https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816
**Category:** Kibana
**Created:** [September 26, 2023, 12:11am UTC](https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816 "2023-09-26T00:11:47Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![matled](https://avatars.discourse-cdn.com/v4/letter/m/ba8739/32.png) [@matled](https://discuss.elastic.co/u/matled)
#### Post date: [September 26, 2023, 12:11am UTC](https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816/1 "2023-09-26T00:11:47Z")

</div>

Currently we observe an issue in the Kibana eventlog that seems to be permission related. We run Elastic-Stack 8.10.2. Any ideas what could gone wrong or where we need to correct this? Or might this even be a bug?

```auto
{"tags":["monitoring_alert_cpu_usage","1a404b10-fa9e-11eb-ac95-6109d2c7328d","rule-run-failed"],"error":{},"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:11.129+02:00","message":"Executing Rule default:monitoring_alert_cpu_usage:1a404b10-fa9e-11eb-ac95-6109d2c7328d has resulted in Error: Saved object [action/19a71850-fa9e-11eb-ac95-6109d2c7328d] not found - ","log":{"level":"ERROR","logger":"plugins.alerting.monitoring_alert_cpu_usage"},"process":{"pid":128177},"span":{"id":"46f642361c33c719"},"trace":{"id":"a27640271bd9168ad021cc0b091f19d7"}}

{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:25.587+02:00","message":"Beginning fleet setup","log":{"level":"INFO","logger":"plugins.fleet"},"process":{"pid":128177},"trace":{"id":"12e569d8604dcae927a44e9f849d7035"},"transaction":{"id":"1fd746eb05da0325"}}

{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:25.590+02:00","message":"Old fleet indices cleanup failed: security_exception\n\tRoot causes:\n\t\tsecurity_exception: action [indices:admin/delete] is unauthorized for user [kibana_system] with effective roles [kibana_system] on indices [.fleet-file-data-agent-000001,.fleet-file-data-endpoint-000001], this action is granted by the index privileges [delete_index,manage,all]","log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":128177},"trace":{"id":"12e569d8604dcae927a44e9f849d7035"},"transaction":{"id":"1fd746eb05da0325"}}

{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:25.811+02:00","message":"Fleet setup completed","log":{"level":"INFO","logger":"plugins.fleet"},"process":{"pid":128177},"trace":{"id":"12e569d8604dcae927a44e9f849d7035"},"transaction":{"id":"1fd746eb05da0325"}}

{"tags":["monitoring_alert_disk_usage","1a407221-fa9e-11eb-ac95-6109d2c7328d","rule-run-failed"],"error":{},"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:26.166+02:00","message":"Executing Rule default:monitoring_alert_disk_usage:1a407221-fa9e-11eb-ac95-6109d2c7328d has resulted in Error: Saved object [action/19a71850-fa9e-11eb-ac95-6109d2c7328d] not found - ","log":{"level":"ERROR","logger":"plugins.alerting.monitoring_alert_disk_usage"},"process":{"pid":128177},"span":{"id":"415059ee4179c27e"},"trace":{"id":"a27640271bd9168ad021cc0b091f19d7"}}

```

---

<div class="post-metadata">

### Author: ![matled](https://avatars.discourse-cdn.com/v4/letter/m/ba8739/32.png) [@matled](https://discuss.elastic.co/u/matled)
#### Post date: [September 26, 2023, 12:12am UTC](https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816/2 "2023-09-26T00:12:21Z")

</div>

> [@matled](#):
>
> ```auto
> {"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:25.590+02:00","message":"Old fleet indices cleanup failed: security_exception\n\tRoot causes:\n\t\tsecurity_exception: action [indices:admin/delete] is unauthorized for user [kibana_system] with effective roles [kibana_system] on indices [.fleet-file-data-agent-000001,.fleet-file-data-endpoint-000001], this action is granted by the index privileges [delete_index,manage,all]","log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":128177},"trace":{"id":"12e569d8604dcae927a44e9f849d7035"},"transaction":{"id":"1fd746eb05da0325"}}
> 
> ```

to format it better:

> {"service":{"node":{"roles":["background\_tasks","ui"]}},"ecs":{"version":"8.6.1"},"@timestamp":"2023-09-26T02:08:25.590+02:00","message":"Old fleet indices cleanup failed: security\_exception\n\tRoot causes:\n\t\tsecurity\_exception: action [indices:admin/delete] is unauthorized for user [kibana\_system] with effective roles [kibana\_system] on indices [.fleet-file-data-agent-000001,.fleet-file-data-endpoint-000001], this action is granted by the index privileges [delete\_index,manage,all]","log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":128177},"trace":{"id":"12e569d8604dcae927a44e9f849d7035"},"transaction":{"id":"1fd746eb05da0325"}}

---

<div class="post-metadata">

### Author: ![haden](https://avatars.discourse-cdn.com/v4/letter/h/2bfe46/32.png) [@haden](https://discuss.elastic.co/u/haden)
#### Post date: [October 2, 2023, 6:50am UTC](https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816/3 "2023-10-02T06:50:40Z")

</div>

Hi matled,

According to my information from an Elastic employee, this is a bug that is about to be fixed in **8.10.3**. This should be the corresponding pull request: [added .fleet-file-data\* to kibana\_system privileges by juliaElastic · Pull Request #100019 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/pull/100019)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 30, 2023, 6:50am UTC](https://discuss.elastic.co/t/kibana-fleet-error-message-old-fleet-indices-cleanup-failed-security-exception/343816/4 "2023-10-30T06:50:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
