# Kibana Getting Started Error - No default index pattern

**URL:** <https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254>\
**Category:** Kibana\
**Created:** [July 9, 2015, 5:20pm UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254 "2015-07-09T17:20:35Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![ScottLawrenceLawson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scottlawrencelawson/32/3644_2.png) [@ScottLawrenceLawson](https://discuss.elastic.co/u/ScottLawrenceLawson)\
**Post date:** [July 9, 2015, 5:20pm UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/1 "2015-07-09T17:20:35Z")

</div>

I am a newbie trying to get local Logstash and Kibana working on my Win7 laptop with Elastic Search Found in the cloud. On firing up Kibana which I configured to use my Found instance, I get the error: "Warning No default index pattern. You must select or create one to continue." How do I do that?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 10, 2015, 2:01am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/2 "2015-07-10T02:01:13Z")

</div>

Have you put any data into your Found cluster?

---

<div class="post-metadata">

**Author:** ![ScottLawrenceLawson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scottlawrencelawson/32/3644_2.png) [@ScottLawrenceLawson](https://discuss.elastic.co/u/ScottLawrenceLawson)\
**Post date:** [July 10, 2015, 4:14am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/3 "2015-07-10T04:14:14Z")

</div>

Yes, I have a few (8) records into my Found cluster and can visualize them in Kibana. I can see the data in the found "/search" uri and in the Kibana v3 on Found AND in my Kibana install on my laptop. I just can't get LS to send data to the ES instance.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 10, 2015, 4:17am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/4 "2015-07-10T04:17:23Z")

</div>

Did you get the index pattern created then

---

<div class="post-metadata">

**Author:** ![ScottLawrenceLawson](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scottlawrencelawson/32/3644_2.png) [@ScottLawrenceLawson](https://discuss.elastic.co/u/ScottLawrenceLawson)\
**Post date:** [July 10, 2015, 8:35pm UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/5 "2015-07-10T20:35:11Z")

</div>

Yes, I learned that I had two indices and when Kibana first started it defaulted to the logstash-\*. Since I did not have any data from logstash at the time, the error showed. When I finally understood that, I switched the index to my other test one, I could see data in Kibana. Thanks!

---

<div class="post-metadata">

**Author:** ![nqioweryuadfge](https://avatars.discourse-cdn.com/v4/letter/n/d9b06d/32.png) [@nqioweryuadfge](https://discuss.elastic.co/u/nqioweryuadfge)\
**Post date:** [December 14, 2015, 10:22am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/6 "2015-12-14T10:22:19Z")

</div>

I am getting this error after my kibana started to work:

Warning No default index pattern. You must select or create one to continue.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 14, 2015, 8:56pm UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/7 "2015-12-14T20:56:33Z")

</div>

Please keep to your own thread, this one is nearly 6 months old and has been resolved.

---

<div class="post-metadata">

**Author:** ![Vincent\_Xian](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vincent_xian/32/19810_2.png) [@Vincent\_Xian](https://discuss.elastic.co/u/Vincent_Xian)\
**Post date:** [July 6, 2017, 5:33am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/8 "2017-07-06T05:33:10Z")

</div>

Hi Scott,

I have the similar problem--"No default index pattern, You must select or create one to continue". but the "Create" button is grayed out therefore I do have the opportunity to create one.

Did you say you have (8) records? How did you add these records in? Through kibana or through the command line from the elasticsearch?

I have added a couple records in the command line like:

curl -uelastic:vincent -X POST "[http://localhost:9200/tutorial1/helloworld/1](http://localhost:9200/tutorial1/helloworld/1)" -d "{ "message": "Hello World2!" }".

Is that correct?

Thank you in advance

Vincent

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 6, 2017, 7:48am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/9 "2017-07-06T07:48:12Z")

</div>

Please start your own thread, this one is quite old 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 6, 2017, 7:48am UTC](https://discuss.elastic.co/t/kibana-getting-started-error-no-default-index-pattern/25254/10 "2017-07-06T07:48:15Z")

</div>


