# Kibana giving did not load properly error

**URL:** <https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379>\
**Category:** Kibana\
**Created:** [January 22, 2017, 2:07am UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379 "2017-01-22T02:07:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![kopacko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kopacko/32/10733_2.png) [@kopacko](https://discuss.elastic.co/u/kopacko)\
**Post date:** [January 22, 2017, 2:07am UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/1 "2017-01-22T02:07:33Z")

</div>

I got my cluster up and running yesterday and verified that it was accepting data and created a dashboard.

Today, I getting the following error:

> Kibana did not load properly. Check the server output for more information.

I've double checked my config, turned on verbose logging, but not seeing any errors.

Here are the settings, via curl:

```
  ".kibana" : {
    "settings" : {
      "index" : {
        "creation_date" : "1484939141938",
        "number_of_shards" : "1",
        "number_of_replicas" : "0",
        "uuid" : "wgZgSyUzT8CLICKFR2Wp5Q",
        "version" : {
          "created" : "5010299"
        },
        "provided_name" : ".kibana"
      }
    }
  },

```

Here is the cluster health:

```
{
  "cluster_name" : "CLUSTER",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 8,
  "number_of_data_nodes" : 4,
  "active_primary_shards" : 17,
  "active_shards" : 17,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 100.0
}

```

Here is my Kibana config:

```
> # Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
> # The default is 'localhost', which usually means remote machines will not be able to connect.
> # To allow connections from remote users, set this parameter to a non-loopback address.
> server.host: "localhost"

```

Here are the listening ports:

```
manager@KIBANA:/etc/kibana$ sudo lsof -nPi | grep -E 'kibana|nginx'
nginx 1510 root 6u IPv4 18742 0t0 TCP *:80 (LISTEN)
nginx 1511 www-data 6u IPv4 18742 0t0 TCP *:80 (LISTEN)
nginx 1512 www-data 6u IPv4 18742 0t0 TCP *:80 (LISTEN)
nginx 1513 www-data 6u IPv4 18742 0t0 TCP *:80 (LISTEN)
nginx 1514 www-data 6u IPv4 18742 0t0 TCP *:80 (LISTEN)
node 23951 kibana 10u IPv4 218557 0t0 TCP 127.0.0.1:55014->127.0.0.1:9200 (ESTABLISHED)
node 23951 kibana 11u IPv4 214390 0t0 TCP 127.0.0.1:5601 (LISTEN)
node 23951 kibana 12u IPv4 218558 0t0 TCP 127.0.0.1:55016->127.0.0.1:9200 (ESTABLISHED)

```

I use nginx for a reverse proxy. I changed the Kibana config so I could hit 5601 and got the same results. When I go to the /status page, I get this (behind the proxy or direct):

```
Status: Green
Heap Total (MB) 65.47
Heap Used (MB) 56.47
Load 0.03, 0.03, 0.01
Response Time Avg (ms) 0.00
Response Time Max (ms) 0.00
Requests Per Second 0.00

Status Breakdown
ui settings Ready
plugin:kibana@5.1.2 Ready
plugin:elasticsearch@5.1.2 Kibana index ready
plugin:console@5.1.2 Ready
plugin:timelion@5.1.2 Ready

```

Please help.

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [January 23, 2017, 4:42pm UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/2 "2017-01-23T16:42:47Z")

</div>

Hi Jason,

Can you check the console in your browser and tell me what errors are there? If you need help finding it, just let me know what browser you are using.

---

<div class="post-metadata">

**Author:** ![kopacko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kopacko/32/10733_2.png) [@kopacko](https://discuss.elastic.co/u/kopacko)\
**Post date:** [January 23, 2017, 11:20pm UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/3 "2017-01-23T23:20:29Z")

</div>

It's now working again, but I could not load any pages, except the status page.

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [January 24, 2017, 2:14am UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/4 "2017-01-24T02:14:10Z")

</div>

The only guess I have is it wasn't able to load some of the assets. Possibly related to the nginx proxy?

---

<div class="post-metadata">

**Author:** ![kopacko](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kopacko/32/10733_2.png) [@kopacko](https://discuss.elastic.co/u/kopacko)\
**Post date:** [January 24, 2017, 10:48pm UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/5 "2017-01-24T22:48:57Z")

</div>

> [@kopacko](#):
>
> I use nginx for a reverse proxy. I changed the Kibana config so I could hit 5601 and got the same results.

Yeap, I tried that when the issue was happening.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 21, 2017, 10:49pm UTC](https://discuss.elastic.co/t/kibana-giving-did-not-load-properly-error/72379/6 "2017-02-21T22:49:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
