# Kibana ignoring requestTimeout setting

**URL:** <https://discuss.elastic.co/t/kibana-ignoring-requesttimeout-setting/322627>\
**Category:** Kibana\
**Created:** [January 6, 2023, 3:51pm UTC](https://discuss.elastic.co/t/kibana-ignoring-requesttimeout-setting/322627 "2023-01-06T15:51:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [January 6, 2023, 3:51pm UTC](https://discuss.elastic.co/t/kibana-ignoring-requesttimeout-setting/322627/1 "2023-01-06T15:51:01Z")

</div>

Hello,

I'm having some issues with some requests that timeout on _Dev Tools_ and returns `stream timeout`.

I change the `elasticsearch.requestTimeout` setting to `300000` which means 5 minutes, but Kibana stills timeout around 30s.

What else should I look and change to troubleshoot this?

After each timeout I have a line like this one in the logs:

```auto
{"service":{"node":{"roles":["background_tasks","ui"]}},"ecs":{"version":"8.4.0"},"@timestamp":"2023-01-06T15:48:22.233+00:00","message":"Client request timeout","error":{"message":"Client request timeout","type":"Error","stack_trace":"Error: Client request timeout\n at Timeout._onTimeout (/usr/share/kibana/src/plugins/console/server/lib/proxy_request.js:104:37)\n at listOnTimeout (node:internal/timers:559:17)\n at processTimers (node:internal/timers:502:7)"},"log":{"level":"ERROR","logger":"plugins.console"},"process":{"pid":696977},"trace":{"id":"258092a6b8bad61e744a10acd8721ebf"},"transaction":{"id":"a406ec01caf41c6c"}}

```

The Kibana service was already restarted.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [January 6, 2023, 4:03pm UTC](https://discuss.elastic.co/t/kibana-ignoring-requesttimeout-setting/322627/2 "2023-01-06T16:03:35Z")

</div>

Well, a full stop and start solved the issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 3, 2023, 4:04pm UTC](https://discuss.elastic.co/t/kibana-ignoring-requesttimeout-setting/322627/3 "2023-02-03T16:04:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
