# Kibana index .kibana\_task\_manager goes unassigned after few days and cause Red cluster health

**URL:** https://discuss.elastic.co/t/kibana-index-kibana-task-manager-goes-unassigned-after-few-days-and-cause-red-cluster-health/309028
**Category:** Kibana
**Created:** [July 6, 2022, 3:36pm UTC](https://discuss.elastic.co/t/kibana-index-kibana-task-manager-goes-unassigned-after-few-days-and-cause-red-cluster-health/309028 "2022-07-06T15:36:01Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![AaronSarkissian](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaronsarkissian/32/72676_2.png) [@AaronSarkissian](https://discuss.elastic.co/u/AaronSarkissian)
#### Post date: [July 6, 2022, 11:40pm UTC](https://discuss.elastic.co/t/kibana-index-kibana-task-manager-goes-unassigned-after-few-days-and-cause-red-cluster-health/309028/2 "2022-07-06T23:40:29Z")

</div>

It seems that others had similar issues too which were not solved!

> [@Geoip\_databases index allocation failed](https://discuss.elastic.co/t/geoip-databases-index-allocation-failed/300783):
>
> Im learning and playing around with Elasticsearch. Just setup a new local test cluster with 3 nodes on kubernetes (Elasticsearch 8.1.0) and also set up kibana 8.1.0. In kubernetes its a StateFulset with storage on NFS. The cluster health says "red" because there seems to be an unassigned shard: .geoip\_databases p UNASSIGNED ALLOCATION\_FAILED taking a closer look with: \_cluster/allocation/explain?pretty { "note": "No shard was specified in the explain API request, so this response …

---

_[View the full topic](https://discuss.elastic.co/t/kibana-index-kibana-task-manager-goes-unassigned-after-few-days-and-cause-red-cluster-health/309028)._
