# Kibana - internal/search/es error 404

**URL:** <https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115>\
**Category:** Kibana\
**Created:** [April 23, 2021, 4:40pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115 "2021-04-23T16:40:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![gferrette](https://avatars.discourse-cdn.com/v4/letter/g/bbce88/32.png) [@gferrette](https://discuss.elastic.co/u/gferrette)\
**Post date:** [April 23, 2021, 4:40pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115/1 "2021-04-23T16:40:48Z")

</div>

Hello!

I'm using kibana 7.10.2 behind a proxy with elasticsearch 7.10.2. We are facing the error "POST [https://proxy-host/internal/search/es](https://proxy-host/internal/search/es) 404 (Not Found)" sometimes when using the kibana dashboards. Prior upgrading to ELK 7.10.2 we used to use Kibana 7.0.1 and this error did not occurs.

Is there any configurations that might be missing?

Thanks!

Gabriel.

---

<div class="post-metadata">

**Author:** ![gferrette](https://avatars.discourse-cdn.com/v4/letter/g/bbce88/32.png) [@gferrette](https://discuss.elastic.co/u/gferrette)\
**Post date:** [April 26, 2021, 12:15pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115/2 "2021-04-26T12:15:08Z")

</div>

Hello,

I find out that this error occurs only when kibana is behind the apache proxy.  
Is there any rules that we have to apply to the reverse proxy when using it with kibana?

Thanks!

---

<div class="post-metadata">

**Author:** ![gferrette](https://avatars.discourse-cdn.com/v4/letter/g/bbce88/32.png) [@gferrette](https://discuss.elastic.co/u/gferrette)\
**Post date:** [April 28, 2021, 6:00pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115/3 "2021-04-28T18:00:08Z")

</div>

Hello,

Some updates on this problem:

- On dashboards the error that occurs is: esaggs not found.
- On Chrome development tools we see the error:  
Refused to apply style from '[http://host/ui/legacy\_light\_theme.css](http://host/ui/legacy_light_theme.css)' because its MIME type ('application/json') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

---

<div class="post-metadata">

**Author:** ![gferrette](https://avatars.discourse-cdn.com/v4/letter/g/bbce88/32.png) [@gferrette](https://discuss.elastic.co/u/gferrette)\
**Post date:** [April 30, 2021, 12:45pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115/4 "2021-04-30T12:45:27Z")

</div>

Hello!

After some troubleshooting, we found that our Apache Proxy had the mod\_evasive turned on, blocking some Kibana URL's.  
Disabling the mod\_evasive solved the problem!

Thanks!

Gabriel.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 28, 2021, 12:46pm UTC](https://discuss.elastic.co/t/kibana-internal-search-es-error-404/271115/5 "2021-05-28T12:46:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
