# Kibana is not able to visit with error code 503 and 000

**URL:** <https://discuss.elastic.co/t/kibana-is-not-able-to-visit-with-error-code-503-and-000/287434>\
**Category:** Kibana\
**Created:** [October 22, 2021, 12:10pm UTC](https://discuss.elastic.co/t/kibana-is-not-able-to-visit-with-error-code-503-and-000/287434 "2021-10-22T12:10:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![KypMon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kypmon/32/96254_2.png) [@KypMon](https://discuss.elastic.co/u/KypMon)\
**Post date:** [October 22, 2021, 12:10pm UTC](https://discuss.elastic.co/t/kibana-is-not-able-to-visit-with-error-code-503-and-000/287434/1 "2021-10-22T12:10:52Z")

</div>

I just follow along the tutorial [helm-charts/elasticsearch/examples/security at main · elastic/helm-charts · GitHub](https://github.com/elastic/helm-charts/tree/main/elasticsearch/examples/security/) and [helm-charts/kibana/examples/security at main · elastic/helm-charts · GitHub](https://github.com/elastic/helm-charts/tree/main/kibana/examples/security)

Elasticsearch all works file, but for Kibana, even the status is ready and running, like this:

```auto
helm-kibana-kibana-947699464-fpbms 1/1 Running 0 18m

```

I cannot visit the app no matter via `kubectl port-forward` or `kubectl exec` and then `curl -k` the `localhost` . Response is always `localhost didn’t send any data.` (in browser or `

```auto
bash-curl -k https://0.0.0.0:5601
bash-4.4$

```

when `kubectl describe` , the response is

```auto
  Normal Started 12m kubelet Started container kibana
  Warning Unhealthy 11m kubelet Readiness probe failed: Error: Got HTTP code 503 but expected a 200
  Warning Unhealthy 11m (x2 over 12m) kubelet Readiness probe failed: Error: Got HTTP code 000 but expected a 200

```

the kubectl logs returns

```auto
...
[2021-10-22T11:42:26.209+00:00][INFO][plugins.monitoring.monitoring.kibana-monitoring] Starting monitoring stats collection
[2021-10-22T11:42:26.964+00:00][INFO][plugins.securitySolution] Dependent plugin setup complete - Starting ManifestTask
[2021-10-22T11:42:27.708+00:00][INFO][status] Kibana is now degraded
[2021-10-22T11:42:27.731+00:00][INFO][plugins.reporting.chromium] Browser executable: /usr/share/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/headless_shell
[2021-10-22T11:42:27.732+00:00][WARN][plugins.reporting.chromium] Enabling the Chromium sandbox provides an additional layer of protection.
[2021-10-22T11:42:33.234+00:00][INFO][status] Kibana is now available (was degraded)

```

please comment if you need further details

**Steps to reproduce:**

1. just follow along the tutorial. I only make several changes to the default `values.yaml`

in the kibana one, add

```auto
kibanaConfig:
  kibana.yml: |
    server.ssl:
      enabled: true
      key: /usr/share/kibana/config/certs/elastic-certificate.pem
      certificate: /usr/share/kibana/config/certs/elastic-certificate.pem
    xpack.security.encryptionKey: ${KIBANA_ENCRYPTION_KEY}
    xpack.encryptedSavedObjects.encryptionKey: ${KIBANA_ENCRYPTION_KEY}
    elasticsearch.ssl:
      certificateAuthorities: /usr/share/kibana/config/certs/elastic-certificate.pem
      verificationMode: certificate

```

and

```auto
healthCheckPath: /api/status

```

---

<div class="post-metadata">

**Author:** ![KypMon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kypmon/32/96254_2.png) [@KypMon](https://discuss.elastic.co/u/KypMon)\
**Post date:** [October 23, 2021, 5:29pm UTC](https://discuss.elastic.co/t/kibana-is-not-able-to-visit-with-error-code-503-and-000/287434/2 "2021-10-23T17:29:29Z")

</div>

checked the matrix found that my kubernetes cluster version is not supported anymore.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 20, 2021, 5:29pm UTC](https://discuss.elastic.co/t/kibana-is-not-able-to-visit-with-error-code-503-and-000/287434/3 "2021-11-20T17:29:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
