# Kibana is not connecting with elasticsearch of 8.15.0

**URL:** <https://discuss.elastic.co/t/kibana-is-not-connecting-with-elasticsearch-of-8-15-0/367082>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting, docker\
**Created:** [September 25, 2024, 6:06am UTC](https://discuss.elastic.co/t/kibana-is-not-connecting-with-elasticsearch-of-8-15-0/367082 "2024-09-25T06:06:44Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![vikascateina](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikascateina/32/123762_2.png) [@vikascateina](https://discuss.elastic.co/u/vikascateina)\
**Post date:** [September 25, 2024, 6:06am UTC](https://discuss.elastic.co/t/kibana-is-not-connecting-with-elasticsearch-of-8-15-0/367082/1 "2024-09-25T06:06:44Z")

</div>

Hi,  
My elasticsearch is not connecting with kibana because we are using 8.15.0 version.It is giving error [ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. security\_exception  
Root causes:  
security\_exception: missing authentication credentials for REST request [/\_nodes?filter\_path=nodes._.version%2Cnodes._.http.publish\_address%2Cnodes.\*.ip]  
[2024-09-25T04:40:47.156+00:00][INFO][plugins.screenshotting.chromium] Browser executable: /usr/share/kibana/node\_modules/@kbn/screenshotting-plugin/chromium/headless\_shell-linux\_x64/headless\_shell  
My docker-compose file is below.

version: '3.6'  
services:  
Elasticsearch:  
image: elasticsearch:8.15.0  
container\_name: elasticsearch  
hostname: elasticsearch  
restart: always  
volumes:  
- elastic\_data:/usr/share/elasticsearch/data/  
environment:  
ES\_JAVA\_OPTS: "-Xmx256m -Xms256m"  
discovery.type: single-node  
xpack.security.enabled: "true"  
ELASTIC\_PASSWORD: "password" # Set the  
ports:  
- '9200:9200'  
- '9300:9300'  
networks:  
- elk

Kibana:  
image: kibana:8.15.0  
container\_name: kibana  
restart: always  
ports:  
- '5601:5601'  
environment:  
- ELASTICSEARCH\_HOSTS=[http://elasticsearch:9200](http://elasticsearch:9200)  
- xpack.security.enabled=true  
- ELASTIC\_USERNAME=elastic  
- ELASTIC\_PASSWORD=password  
- ELASTICSEARCH\_SERVICE\_CHECK\_INTERVAL=10000  
depends\_on:  
- Elasticsearch  
networks:  
- elk  
volumes:  
elastic\_data: {}

networks:  
elk:  
We have used ELASTICSEARCH\_SERVICE\_TOKEN also but it doesn't work.  
But we have used the above docker-compose for the version elasticsearch:7.16.2 and kibana:7.16.2 and it is working good,but it doesn't work for 8.15.0 version.Can anyone help on this?
