# Kibana is not ready yet in 7.12.0 Error in description

**URL:** <https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402>\
**Category:** Kibana\
**Tags:** vega, kibana-plugin-development\
**Created:** [May 29, 2021, 11:55am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402 "2021-05-29T11:55:17Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![LombardoAndrea195](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lombardoandrea195/32/88080_2.png) [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Post date:** [May 29, 2021, 11:55am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/1 "2021-05-29T11:55:17Z")

</div>

I've obtained this error after creating the visualization element according the following link [How to bring Jupyter Notebook visualizations to Kibana dashboards for data science | Elastic Blog](https://www.elastic.co/blog/how-to-jupyter-notebook-visualizations-kibana-dashboards-vega-data-science) . I've installed kibana through docker-compose and the version of kibana is 7.12.0. Maybe I need to delete all the saved object. How can I manage to that? I've seen on the documentation that I can use delete rest operation but I don't know the id of the saved object. I 've the code the built them so I can recreate them as new. Kibana service was up until I've inserted to the kibana serverice a lot of graph. I've tryed to add memory to the virutal machine and on kibana itself but nothing change. Below is the log of what happened. I've not found out anything on hte web. Someone can help?

```auto

kibana | {"type":"log","@timestamp":"2021-05-28T07:47:15+00:00","tags":["info","plugins","taskManager"],"pid":6,"message":"TaskManager is identified by the Kibana UUID: 70b8c42e-5405-437c-998f-4aa640b5173b"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:17+00:00","tags":["warning","plugins","security","config"],"pid":6,"message":"Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:17+00:00","tags":["warning","plugins","security","config"],"pid":6,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:18+00:00","tags":["warning","plugins","reporting","config"],"pid":6,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.reporting.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:18+00:00","tags":["warning","plugins","reporting","config"],"pid":6,"message":"Chromium sandbox provides an additional layer of protection, but is not supported for Linux CentOS 8.3.2011\n OS. Automatically setting 'xpack.reporting.capture.browser.chromium.disableSandbox: true'."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:18+00:00","tags":["warning","plugins","encryptedSavedObjects"],"pid":6,"message":"Saved objects encryption key is not set. This will severely limit Kibana functionality. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:18+00:00","tags":["warning","plugins","fleet"],"pid":6,"message":"Fleet APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:19+00:00","tags":["warning","plugins","actions","actions"],"pid":6,"message":"APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:20+00:00","tags":["warning","plugins","alerts","plugins","alerting"],"pid":6,"message":"APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:21+00:00","tags":["info","plugins","monitoring","monitoring"],"pid":6,"message":"config sourced from: production cluster"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["info","savedobjects-service"],"pid":6,"message":"Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["error","elasticsearch"],"pid":6,"message":"Request error, retrying\nGET http://elasticsearch:9200/_xpack?accept_enterprise=true => connect ECONNREFUSED 172.20.0.3:9200"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["warning","elasticsearch"],"pid":6,"message":"Unable to revive connection: http://elasticsearch:9200/"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["warning","elasticsearch"],"pid":6,"message":"No living connections"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["warning","plugins","licensing"],"pid":6,"message":"License information could not be obtained from Elasticsearch due to Error: No Living connections error"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:25+00:00","tags":["warning","plugins","monitoring","monitoring"],"pid":6,"message":"X-Pack Monitoring Cluster Alerts will not be available: No Living connections"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:26+00:00","tags":["error","savedobjects-service"],"pid":6,"message":"Unable to retrieve version information from Elasticsearch nodes."}
elasticsearch | {"type": "server", "timestamp": "2021-05-28T07:47:48,798Z", "level": "INFO", "component": "o.e.p.PluginsService", "cluster.name": "docker-cluster", "node.name": "d2e496359d00", "message": "no plugins loaded" }
elasticsearch | {"type": "server", "timestamp": "2021-05-28T07:47:49,604Z", "level": "INFO", "component": "o.e.e.NodeEnvironment", "cluster.name": "docker-cluster", "node.name": "d2e496359d00", "message": "using [1] data paths, mounts [[/usr/share/elasticsearch/data (/dev/sda5)]], net usable_space [13.8gb], net total_space [43.5gb], types [ext4]" }
elasticsearch | {"type": "server", "timestamp": "2021-05-28T07:47:49,619Z", "level": "INFO", "component": "o.e.e.NodeEnvironment", "cluster.name": "docker-cluster", "node.name": "d2e496359d00", "message": "heap size [4gb], compressed ordinary object pointers [true]" }
elasticsearch | {"type": "server", "timestamp": "2021-05-28T07:47:51,238Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "d2e496359d00", "message": "node name [d2e496359d00], node ID [kHGHvefFTViG8CdPdF5pxw], cluster name [docker-cluster], roles [transform, data_frozen, master, remote_cluster_client, data, ml, data_content, data_hot, data_warm, data_cold, ingest]" }
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:55+00:00","tags":["warning","elasticsearch"],"pid":6,"message":"Unable to revive connection: http://elasticsearch:9200/"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:55+00:00","tags":["warning","elasticsearch"],"pid":6,"message":"No living connections"}
kibana | {"type":"log","@timestamp":"2021-05-28T07:47:55+00:00","tags":["warning","plugins","licensing"],"pid":6,"message":"License information could not be obtained from Elasticsearch due to Error: No Living connections error"}

```

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [May 31, 2021, 8:40am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/2 "2021-05-31T08:40:53Z")

</div>

> [@LombardoAndrea195](#):
>
> `"Unable to revive connection: http://elasticsearch:9200/"`

Your logs suggest the Elasticsearch instance you try to connect to is not available. Make sure your Elasticsearch cluster is up and healthy, then start Kibana.

---

<div class="post-metadata">

**Author:** ![LombardoAndrea195](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lombardoandrea195/32/88080_2.png) [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Post date:** [May 31, 2021, 4:03pm UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/3 "2021-05-31T16:03:24Z")

</div>

I manage to resolve. The problem was that Kibana has too much saved object.

---

<div class="post-metadata">

**Author:** ![LombardoAndrea195](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lombardoandrea195/32/88080_2.png) [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Post date:** [May 31, 2021, 7:19pm UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/4 "2021-05-31T19:19:27Z")

</div>

Sorry @flash1293 I've obtained again this error I don't know why. I've imported only 5 element from vega how is it possible?

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [June 2, 2021, 8:48am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/5 "2021-06-02T08:48:27Z")

</div>

I don't think this is related to Kibana, it looks more like an Elasticsearch problem. Check the logs and health of your Elasticsearch cluster.

---

<div class="post-metadata">

**Author:** ![LombardoAndrea195](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lombardoandrea195/32/88080_2.png) [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Post date:** [June 2, 2021, 9:18am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/6 "2021-06-02T09:18:30Z")

</div>

Yes you have right it's change the error as the problem of the elasticsearch. Could be that I need to insert a new node? Because I've only a node of elastic and one of kibana, maybe I need a cluster of node

> ```
> kibana | FATAL Error: Unable to complete saved object migrations for the [.kibana] index. Please check the health of your Elasticsearch cluster and try again. Error: [undefined]: Response Error
> kibana |
> 
> ```

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [June 2, 2021, 9:23am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/7 "2021-06-02T09:23:32Z")

</div>

Can you share the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![LombardoAndrea195](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lombardoandrea195/32/88080_2.png) [@LombardoAndrea195](https://discuss.elastic.co/u/LombardoAndrea195)\
**Post date:** [June 2, 2021, 9:24am UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/8 "2021-06-02T09:24:11Z")

</div>

`

> {"cluster\_name":"docker-cluster","status":"yellow","timed\_out":false,"number\_of\_nodes":1,"number\_of\_data\_nodes":1,"active\_primary\_shards":49,"active\_shards":49,"relocating\_shards":0,"initializing\_shards":0,"unassigned\_shards":4,"delayed\_unassigned\_shards":0,"number\_of\_pending\_tasks":0,"number\_of\_in\_flight\_fetch":0,"task\_max\_waitinandrea@andrea-VirtualBox:~$

`It's the reply of the system analyzing the routine `

> curl localhost:9200/\_cluster/health

`

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [June 2, 2021, 4:26pm UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/9 "2021-06-02T16:26:13Z")

</div>

Can you please share the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 30, 2021, 4:26pm UTC](https://discuss.elastic.co/t/kibana-is-not-ready-yet-in-7-12-0-error-in-description/274402/10 "2021-06-30T16:26:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
