# Kibana keep loading after config the domain name resolve in a ngnix

**URL:** https://discuss.elastic.co/t/kibana-keep-loading-after-config-the-domain-name-resolve-in-a-ngnix/136921
**Category:** Kibana
**Created:** [June 21, 2018, 5:23pm UTC](https://discuss.elastic.co/t/kibana-keep-loading-after-config-the-domain-name-resolve-in-a-ngnix/136921 "2018-06-21T17:23:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![marcus1](https://avatars.discourse-cdn.com/v4/letter/m/d78d45/32.png) [@marcus1](https://discuss.elastic.co/u/marcus1)
#### Post date: [June 21, 2018, 5:23pm UTC](https://discuss.elastic.co/t/kibana-keep-loading-after-config-the-domain-name-resolve-in-a-ngnix/136921/1 "2018-06-21T17:23:15Z")

</div>

hi, I met a issue by accessing kibana from a domain name, but by IP address that is fine.

Here is my ngnix config file, I have configed reverse-proxy for kibana, I can access the server by the ip address without any problem. for example suppose my ip address is 10.10.10.1, I can access kibana by [http://10.10.10.1](http://10.10.10.1) from the browser, however if I am using the domain name, the page is stuck in the kibana loading screen.  
by domain name I mean by [http://www.test.com](http://www.test.com), it is stuck in the loading screen.

server {  
listen 80;  
server\_name [www.test.com](http://www.test.com);

```
    error_log /var/log/nginx/kibana.error.log;
    access_log /var/log/nginx/kibana.access.log;

    auth_basic "Restricted Access";
    auth_basic_user_file /etc/nginx/htpasswd.users;

    location / {
            rewrite ^/(.*) /$1 break;
            proxy_ignore_client_abort on;
            proxy_pass http://localhost:5601;
            proxy_set_header X-Real-IP $remote_addr;
            proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header Host $http_host;

    }

```

}

I have checked the /var/log/nginx/kibana.access.log, the difference I found is that after kibana.bundle.js is load, the process stops. and for the normal log which is accessed by ip. the next step would be to get the "/ui/fonts/open\_sans/ ", see logs below.  
can anyone help on this issue. I was in a hurry. Thanks in advance. Also in the error case, I notice this is error ‘Uncaught SyntaxError: Unexpected end of input’ in the console of the chrome devtools.  
Error log:  
114.93.211.105 - admin [22/Jun/2018:00:54:35 +0800] "GET /bundles/commons.bundle.js?v=16627 HTTP/1.1" 304 0 "[http://www.test.com/app/kibana](http://www.test.com/app/kibana)" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36"  
114.93.211.105 - admin [22/Jun/2018:00:54:36 +0800] "GET /bundles/kibana.bundle.js?v=16627 HTTP/1.1" 304 0 "[http://www.test.com/app/kibana](http://www.test.com/app/kibana)" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36"

successful log:  
114.93.211.105 - admin [22/Jun/2018:00:58:02 +0800] "GET /bundles/kibana.bundle.js?v=16627 HTTP/1.1" 304 0 "[http://10.10.10.1/app/kibana](http://10.10.10.1/app/kibana)" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/  
537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36"  
\<\<\<\<\<after get bundle.js, should get the fonts, but this is not happen when access by the domain name.  
114.93.211.105 - admin [22/Jun/2018:00:58:03 +0800] "GET /ui/fonts/open\_sans/open\_sans\_v13\_latin\_regular.woff2 HTTP/1.1" 304 0 "[http://10.10.10.1/app/kibana](http://10.10.10.1/app/kibana)" "Mozilla/5.0 (Windows NT 10.0; Win6  
4; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36"  
114.93.211.105 - admin [22/Jun/2018:00:58:03 +0800] "GET /api/console/api\_server?sense\_version=%40%40SENSE\_VERSION&apis=es\_5\_0 HTTP/1.1" 200 10586 "[http://10.10.10.1/app/kibana](http://10.10.10.1/app/kibana)" "Mozilla/5.0 (W  
indows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36"

---

<div class="post-metadata">

### Author: ![chrisronline](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrisronline/32/28230_2.png) [@chrisronline](https://discuss.elastic.co/u/chrisronline)
#### Post date: [June 22, 2018, 1:23pm UTC](https://discuss.elastic.co/t/kibana-keep-loading-after-config-the-domain-name-resolve-in-a-ngnix/136921/2 "2018-06-22T13:23:36Z")

</div>

Hi @marcus1,

It sounds like something with the proxy. Have you checked the nginx logs?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 20, 2018, 1:23pm UTC](https://discuss.elastic.co/t/kibana-keep-loading-after-config-the-domain-name-resolve-in-a-ngnix/136921/3 "2018-07-20T13:23:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
