# Kibana login page

**URL:** https://discuss.elastic.co/t/kibana-login-page/138421
**Category:** Kibana
**Created:** [July 3, 2018, 3:59pm UTC](https://discuss.elastic.co/t/kibana-login-page/138421 "2018-07-03T15:59:12Z")
**Posts on this page:** 1
**Showing post:** 12

<div class="post-metadata">

### Author: ![Preethi](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@Preethi](https://discuss.elastic.co/u/Preethi)
#### Post date: [July 14, 2018, 3:58pm UTC](https://discuss.elastic.co/t/kibana-login-page/138421/12 "2018-07-14T15:58:15Z")

</div>

Yes, I also tried to set password for teh default users for elasticsearch. But Throws me newly error. I don't think I changed the password for Elasticsearch or bootstrap before.

I ran this:  
bin/elasticsearch-setup-passwords interactive

Error:  
Failed to authenticate user 'elastic' against [http://127.0.0.1:9200/\_xpack/security/\_authenticate?pretty](http://127.0.0.1:9200/_xpack/security/_authenticate?pretty)  
Possible causes include:

- The password for the 'elastic' user has already been changed on this cluster
- Your elasticsearch node is running against a different keystore  
This tool used the keystore at /Path to elasticsearch-6.3.0/config/elasticsearch.keystore

So I referred this thread....

> [@I lost the password that has been changed](https://discuss.elastic.co/t/i-lost-the-password-that-has-been-changed/91867/2):
>
> Note: These instructions are quite old. Newer instructions are available here [X-Pack Authentication issue](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/7) It is possible to reset the elastic user password (see below) but from your description, it doesn't sound like this is necessarily what you need. The elastic user is a superuser. We don't recommend using it for any purpose other than administering the system. In particular, Kibana should not connect to Elasticsearch using the elastic user - by default it uses the kibana user, so the p…

Then created another user and tried to reset the password for elastic user as shown below:

curl -u my\_admin -XPUT '[http://localhost:9200/\_xpack/security/user/elastic/\_password?pretty](http://localhost:9200/_xpack/security/user/elastic/_password?pretty)' -H 'Content-Type: application/json' -d'  
{  
"password" : "my\_password"  
}'  
Enter host password for user 'my\_admin':  
{  
"error" : {  
"root\_cause" : [  
{  
"type" : "cluster\_block\_exception",  
"reason" : "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"  
}  
],  
"type" : "cluster\_block\_exception",  
"reason" : "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"  
},  
"status" : 403  
}

How to fix it?

Thanks

---

_[View the full topic](https://discuss.elastic.co/t/kibana-login-page/138421)._
