# Kibana logs shows HTTP 403 (Forbidden)

**URL:** <https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216>\
**Category:** Beats\
**Tags:** heartbeat\
**Created:** [May 29, 2019, 4:05am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216 "2019-05-29T04:05:55Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [May 29, 2019, 4:05am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/1 "2019-05-29T04:05:55Z")

</div>

Hi,

We are using kibana for monitoring where we defined the a custom files for url and TCP monitoring in heartbeat with all details a month back.Since last week URL and TCP monitoring data shows "No results found" in kibana dashboard and from logs noticed HTTP 403 Forbidden error.  
Please help me to fix the issue and snippit of log mentioned below  
2019-05-29T11:57:23.195+0800 WARN elasticsearch/client.go:523 Cannot index event publisher.Event{Content:beat.Event{Timestamp:time.Time{wall:0xbf339ea88c7166a1, ext:1715053200758, loc:(\*time.Location)(0x1fe1a00)}, Meta:common.MapStr(nil), Fields:common.MapStr{"tcp":common.MapStr{"rtt":common.MapStr{"connect":common.MapStr{"us":276}}, "port":0x20fb}, "monitor":common.MapStr{"ip":"X.X.X.X", "status":"up", "duration":common.MapStr{"us":349}, "host":"X.X.X.X", "scheme":"tcp"

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [June 3, 2019, 2:45pm UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/2 "2019-06-03T14:45:57Z")

</div>

A 403 error indicates a lack of permissions. It usually means a user/password combo are incorrect. Are you sure you've included the correct error message below? There is no mention of 403 in it.

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [June 4, 2019, 2:34am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/3 "2019-06-04T02:34:44Z")

</div>

Hi Andrew,

Below is the snippet from kibana.stdout log  
{"type":"log","@timestamp":"2019-06-04T02:33:20Z","tags":["error","task\_manager"],"pid":17644,"message":"Failed to poll for work: [cluster  
\_block\_exception] blocked by: [FORBIDDEN/12/index read-only / allow delete (api)]; :: {"path":"/.kibana\_task\_manager/\_doc/Maps-maps\_tel  
emetry/\_update","query":{"if\_seq\_no":40,"if\_primary\_term":4,"refresh":"true"},"body":"{\"doc\":{\"type\":\"task\  
",\"task\":{\"taskType\":\"maps\_telemetry\",\"state\":\"{\\\"runs\\\":1,\\\"stats\\\":{}}\",\"params  
\":\"{}\",\"attempts\":0,\"scheduledAt\":\"2019-05-27T04:27:32.931Z\",\"runAt\":\"2019-06-04T02:34:20.887Z\",\  
"status\":\"running\"},\"kibana\":{\"uuid\":\"979cbc12-fc31-443f-9583-0071fb272f4b\",\"version\":6070299,\"apiVers  
ion\":1}}}","statusCode":403,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"cluster\_block\_exception\",\"rea  
son\":\"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];\"}],\"type\":\"cluster\_block\_exception\",\"reason  
\":\"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];\"},\"status\":403}"}"}  
{"type":"log","@timestamp":"2019-06-04T02:33:23Z","tags":["error","task\_manager"],"pid":17644,"message":"Failed to poll for work: [cluster  
\_block\_exception] blocked by: [FORBIDDEN/12/index read-only / allow delete (api)]; :: {"path":"/.kibana\_task\_manager/\_doc/Maps-maps\_tel  
emetry/\_update","query":{"if\_seq\_no":40,"if\_primary\_term":4,"refresh":"true"},"body":"{\"doc\":{\"type\":\"task\  
",\"task\":{\"taskType\":\"maps\_telemetry\",\"state\":\"{\\\"runs\\\":1,\\\"stats\\\":{}}\",\"params  
\":\"{}\",\"attempts\":0,\"scheduledAt\":\"2019-05-27T04:27:32.931Z\",\"runAt\":\"2019-06-04T02:34:23.911Z\",\  
"status\":\"running\"},\"kibana\":{\"uuid\":\"979cbc12-fc31-443f-9583-0071fb272f4b\",\"version\":6070299,\"apiVers  
ion\":1}}}","statusCode":403,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"cluster\_block\_exception\",\"rea  
son\":\"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];\"}],\"type\":\"cluster\_block\_exception\",\"reason  
\":\"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];\"},\"status\":403}"}"}

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [June 19, 2019, 4:22am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/4 "2019-06-19T04:22:23Z")

</div>

> [@ksunil](#):
>
> tatusCode":403,"response

Hi Andrew,

Copied entire error message from logs have shown below. please help me on this.  
still we are seeing this error

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [June 28, 2019, 11:37am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/5 "2019-06-28T11:37:10Z")

</div>

It looks like you have not granted permissions for heartbeat to write to Elasticsearch. That would be the root cause.

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [July 8, 2019, 4:39am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/6 "2019-07-08T04:39:35Z")

</div>

Hi Andrew,

Can you help me on how to provide permissions for heartbeat to write to elasticsearch

---

<div class="post-metadata">

**Author:** ![ksunil](https://avatars.discourse-cdn.com/v4/letter/k/439d5e/32.png) [@ksunil](https://discuss.elastic.co/u/ksunil)\
**Post date:** [July 24, 2019, 2:51am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/7 "2019-07-24T02:51:10Z")

</div>

Hi Andrew,

Can i have an update on this

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 21, 2019, 2:51am UTC](https://discuss.elastic.co/t/kibana-logs-shows-http-403-forbidden/183216/8 "2019-08-21T02:51:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
